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In This Manual
This document is the self-paced training manual to help you to understand how to use the 
Agilent EasyEXPERT software.

• Module 1. Getting Started

This module explains the basic operations of the EasyEXPERT. You will learn how to 
perform application test, quick test, and tracer test.

• Module 2. Data Display and Management

This module explains the data display and analysis capabilities of the EasyEXPERT 
software. You will learn how to use analysis tools, how to change display setup, and 
how to print/export test result data.

• Module 3. Classic Test Environment

This module explains the classic test mode of the EasyEXPERT. You will learn how to 
create the classic test setup in the course exercises.

• Module 4. Measurement Functions

This module explains the measurement functions available with the EasyEXPERT. You 
will learn how to use various measurement functions in the course exercises.

• Module 5. Modifying Application Test Definitions

This module explains a modification example of an application test definition. You will 
learn how to modify the definition in a course exercise.

• Module 6. Creating Your Test Definitions

This module explains about the application test definition. You will learn how to create 
your application test definition in a course exercise.

• Module 7. Advanced Definitions and Operations

This module explains how to control external GPIB devices, how to call an execution 
file, how to perform a repeat measurement, and how to use the prober control script.

• Module 8. Miscellaneous Operations

This module explains what is the status indicator, what is the automatic data export 
function and the automatic data record function, how to perform selftest and 
calibration, how to perform SMU zero offset cancel, and such.

EasyEXPERT is a trademark of Agilent Technologies. All other trademarks are the 
property of their respective owners.



Class Exercises 
Class exercises use the test setup listed below. The test setup data are only examples and 
included in the Demo.xpg file stored in Agilent B1500 Series Manual CD.

Module Exercise Device Test setup/definition/data Page 

Module 1 Id-Vd measurement MOSFET Id-Vd 1-19

Id-Vg, gm-Vg measurement MOSFET Vth gmMax 1-27

Id-Vd measurement MOSFET Trace IdVd 1-31

B2200/E5250 switch control - - 1-52

Module 2 Id-Vg, gm-Vg measurement MOSFET GMMAX 2-29

Using Preview window - - 2-32

Module 3 Id-Vd measurement MOSFET Trng Id-Vd 3-27

Multi Channel I/V Sweep 
Measurement

Bipolar Tr 
LED

Trng Multi 3-39

I/V List Sweep Measurement MOSFET Trng List 3-51

I/V-t sampling measurement 0.1 μF Trng Sampling 3-65

C-V sweep measurement MOSFET Trng CV 3-79

B2200/E5250 switch control - Trng Switch 3-84

Direct Control (C-f measurement) 0.1 μF Trng C-f 3-91

Module 4 SMU pulse mode MOSFET IDVD-Pulse 4-7

RC measurement 0.1 μF and 
511 kohm

RC-sampling-log 4-15

Negative hold time 511 kohm R-sampl-neg-hold 4-21

Auto analysis MOSFET GMMAX 4-27

Bias hold function LED LED 4-38

Module 5 Modifying application test 
definition

MOSFET Trng IdVd Vth 5-14

Trng idvd idvg2 5-29

Trng idvd idvg3 5-32

Using auto analysys twice MOSFET Vth gmMax and Id 5-34

Using vector data MOSFET Trng Cgg-Vg 5-42



NOTE Demo.xpg file

Demo.xpg file is required to create the Demo preset group which contains the test setup 
data used by the class exercises. And it is stored in the \data folder on Agilent B1500 Series 
Manual CD.

The Demo preset group should be created before starting the class exercise. To create the 
preset group, launch EasyEXPERT and import the file by using the Preset Group Import 
dialog box opened by clicking My Favorite Setup > Preset Group > Import Preset Group. 
The test setup data are only examples for the class exercises.

Before importing the Demo.xpg file, import the .xtd files stored in the same folder.

NOTE .xtd files

The \data folder stores some .xtd files. They are the application test definitions used by 
some class exercises. To use the definition file, import the file by using the Test Definition 
Import dialog box opened by clicking Library > Import Test Definition. The test definition 
data are only examples for the class exercises.

NOTE .xtr files

The \data folder also stores some .xtr files. They are the sample test results created by 
executing the test setup which has the same name as the result data. To display these 
sample test results, import the files by using the Test Result Import dialog box opened by 
clicking Results > Transport Data > Import.

NOTE About sample data

The test setup data described in this manual are only examples. If these example data 
damage your devices, Agilent is NOT LIABLE for the damage.

Module 6 Creating application test definition MOSFET Trng idvd idvg 6-17

Module 7 no exercise

Module 8 no exercise

Module Exercise Device Test setup/definition/data Page 



Required Devices for Class Exercises
To perform the class exercises, you need the device set (Agilent part number 04156-87001) 
which contains the following devices.

Description Quantity

N-channel MOSFET 2 ea.

NPN Bipolar Transistor 1 ea.

Red Miniature LED 1 ea.

0.1 μF Capacitor 50 V 1 ea.

1.0 Ω Resistor 1/8 W 1 ea.

1.1 kΩ Resistor 1/8 W 1 ea.

511 kΩ Resistor 1/8 W 1 ea.

NPN bipolar TransistorN-ch MOSFET LED

1 ohm Resistor

Brown
Black
Black
Silver

1.1 kohm Resistor

Brown
Brown
Black
Brown

511 kohm Resistor

Green
Brown
Brown
Orange

0.1 uF Capacitor



Required Accessories for Class Exercises
To perform the class exercises, you need the following accessories. Prepare the accessories 
shown below.

Designation Description Model No. Qty. 

1 Test Fixture 16442A/B 1 ea.

28 pin socket module 1 ea.

Connection wire 6 ea.

2 Triaxial Cable 16494A 4 ea.

3 Interlock Cable 16493J 1 ea.

16442A/B Test Fixture (1ea.)
Triaxial Cable (4ea.)

INTLK Cable (1ea.)

Connection Wire (6ea.)

28 pin DIP Socket Module (1ea.)

2

3

1
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In This Module

• To Launch EasyEXPERT

• To Specify/Create Workspace

• To Perform Application Test

• To Save/Recall Your Test Setup

• To Export/Import Your Preset Group

• To Export/Import Test Record

• To Perform Quick Test

• To Perform Tracer Test

• To Control Switching Matrix

• To Manage Data Display Window
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To Turn on/off B1500A/B1505A

The Standby button works to turn on the B1500A/B1505A when it is turned off. When the 

B1500A/B1505A is turned on, the Standby button works to terminate the EasyEXPERT software, 

Windows, and turn off the B1500A/B1505A.

After the B1500A/B1505A is turned on, log on Windows.

The default user is Agilent B1500 User with no password.
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To Launch EasyEXPERT

Start EasyEXPERT button/window

Start EasyEXPERT icon

After logging on, click Start EasyEXPERT button to launch the EasyEXPERT software.

If you do not see the Start EasyEXPERT button, double click the Start EasyEXPERT icon to open 

the Start EasyEXPERT window.

This window has the File menu and the Option menu.  The File menu is used to close this window.  

The Option menu provides the following functions.

•Auto Start of EasyEXPERT: Enables or disables the automatic start function.  If this label is 

checked, the function is enabled.  From the next boot or logon, the Start EasyEXPERT window will 

be skipped and EasyEXPERT will be launched.  To disable this function, use the Start EasyEXPERT

window opened by the File > Exit menu on the EasyEXPERT main screen.  This function is not 

effective for Desktop EasyEXPERT.

•Backup EasyEXPERT Database: Used to make backup of the EasyEXPERT database.

•Restore EasyEXPERT Database: Used to restore the EasyEXPERT database.

Note:

Desktop EasyEXPERT provides the following additional functions in the Option menu.

Execution Mode: Used to change the software execution mode.

Move EasyEXPERT Database: Used to move the EasyEXPERT database.
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To Specify Workspace

Case 1

Case 2 Case 3

After launching the EasyEXPERT, you will see one of the above screens.

Case 1: If this is the first time to launch the EasyEXPERT

The LCD displays the EasyEXPERT main screen.

Case 2: If the B1500 has one workspace only

Select Yes, and click OK if you use the existing workspace.

The EasyEXPERT main screen is displayed.

Select No, and click Next if you want to create a new workspace.

See next slide.

Case 3: If the B1500 has some workspaces (more than one)

Select workspace you want to use, and click Continue.

The EasyEXPERT main screen is displayed.

If you create workspace, check the Create a new Workspace radio button, and click Continue.

To create a public workspace, check the Allow other users to access this workspace box.  The public 
workspace can be used by all users.

To create a private workspace, delete the check from the Allow other users to access this workspace
box.

Workspace is the space created in the B1500 internal hard disk drive, and is used to store the test 
setup, measurement result data, and so on.  The workspace can be created and allocated for each  
user.

Work on the same setups and data in the next time and Choose the same Workspace in the next time:

If this check box is checked, the workspace selection screen will be skipped at the next startup and 
EasyEXPERT will be launched with the workspace used at the last operation. To perform this setup 
again, click the File > Close Workspace menu on the EasyEXPERT main screen.
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To Create Workspace

1: New workspace name to create

Check this box for

Public workspace

2: New workspace name to rename

1

2

Enter the workspace name and click OK to create/rename the workspace.

If you want to create a public workspace, check the Allow other users to access this workspace box.

The public workspace can be used by all users.

If you want to create a private workspace, delete the check from the Allow other users to access this 

workspace box.



Module 1

Getting Started

1-7

Online Help

Online Help is available for the B1500 and EasyEXPERT.  Select Help > Agilent EasyEXPERT 

Help menu to display the online help window.  The online help provides the following information.

•Introduction describes overview, front view, rear view, and measurement units of the B1500.

•Using EasyEXPERT provides the reference information of the Agilent EasyEXPERT software.

•Function Details explains the measurement functions of the B1500 with EasyEXPERT.

•Built-in Programming Tool provides the reference information of the built-in function, read out 

functions, and script programming statements.

•If You Have a Problem describes the problem solving information, the B1500 system maintenance 

information, and the error messages.
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Application Test Description

To know about the application test, click the ( i ) icon.  This icon displays the message box that 

explains the application test definition.  This function will help you to know what is and how to use 

the application test.
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Typical Value Selection

Right clicking 

this field 

displays the 

menu.

The values are 

defined as 

typical values 

in the Test 

Definition.

You do not need to hit the keyboard.

When you set a test condition of application test, you do not need to use keyboard.  You can select 

the value from the typical values as shown below.

•Click the entry field of a setup parameter by using the touch screen or the mouse.  This displays the 

typical values for the specified parameter on the softkeys.

•Select one of the softkeys.

Also you can use the following manner.

•Point the entry field of a setup parameter by using the mouse. 

•Right click the mouse to display the popup menu.

•Click the Select menu to display the typical values for the specified parameter.

•Select one from the typical values.

Note:

The typical values are defined in the test definition.  And you can change the values by using the 

Define typical values window opened by clicking the Typical Values button on the Test Specification 

screen of the Test Definition window.  For the Test Definition window, see Module 5.
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Screen Keyboard

When you need to enter numeric characters in an entry field, you will see the icon at the right side of 

the entry field.  This icon opens the Numeric KeyPad.  You can use this screen keypad instead of the 

USB keyboard.

When you need to enter alphabetic characters in an entry field, you will see the icon at the right side 

of the entry field.  This icon opens the On Screen Keyboard.  You can use this screen keyboard 

instead of the USB keyboard.
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To Perform Application Test

Test Record List area

Step 1: Click Application Test tab.

Step 2: Select one or more technology categories, and select a desired test from the list of tests 

associated with the selected technology categories.

Step 3: Change the setup parameters (Device parameters and Test parameters) if you want.

Step 4: Connect DUT, and click the Single button.  The B1500 starts the selected test.

After the measurement, the test result data is displayed on the Data Display window.  And the Test 

Result Editor shown in the next page is displayed on the lower left area of the B1500 screen if the 

Auto Record function or the Auto Export function is set to ON.  Check the status indicator at the 

bottom of the screen.

Step 5: Analyze the measurement result data.
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Test Result Editor

• Save/Delete

• ! Important

• # Valid

• ? Questionable

• Remarks

• OK

The Test Result Editor provides the following GUI to set a flag and remarks to the test result record.  

Set the flag and remarks to the test record.

•Save button and Delete button

Divides test records into groups, Save and Delete.

Test records in Save-group are always listed in the lower area of the EasyEXPERT main screen.

Test records in Delete-group can be listed when Results > Filter > Show Deleted Data is checked.

•Flags buttons

The following buttons are available.  You can set one of the following flags.

•Important ! Button

Sets the important flag (!) to the test result record.

•Valid # button

Sets the valid flag (#) to the test result record.

•Questionable ? Button

Sets the questionable flag (?) to the test result record.

•Remarks field

You can enter characters into this field.  The characters will be recorded as the Remarks value of the 

test result record.

•OK button

Applies the setup on the Test Result Editor, and closes this dialog box.
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Test Record List Area

Flag Setup Name

Vth gmMax

Vth gmMax

Vth gmMax

Vth gmMax

ID-VD1

ID-VD1

ID-VD1

ID-VD1

Vth gmMax

Vth gmMax

ID-VD1

#

#

?

?

!

!

A

A

S

S

A

A

S

*Flag Setup Name

Vth gmMax

Vth gmMax

ID-VD1

ID-VD1

Vth gmMax

Vth gmMax

ID-VD1

#

#

!

!

…

…

…

*

Flag Setup Name

Vth gmMax

ID-VD1

ID-VD1

Vth gmMax

ID-VD1

#

!

…

…

*

Results > Filter > Show Deleted Data

Show All Append Data

Expand Application Test Results

The test result records are listed in the test record list area. The area also lists the following data.

•Append measurement data marked with …

•Deleted data marked with * if Results > Filter > Show Deleted Data is checked

•Test name defined in the application test definition if Results > Filter > Expand Application Test 

Results is checked

If Results > Filter > Show All Append Data is checked, all append data will be listed and the symbol 

will be changed to A for the data obtained by the Append measurement or S for the data obtained by 

the Single measurement.
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Single/Append/Repeat measurement

Single

RepeatAppend

Counter reset

The EasyEXPERT provides three execution modes, Single, Append, and Repeat. 

Single button triggers a single measurement.

Append button triggers an append measurement. The measurement results will be appended to the 

Data Display window that shows the previous measurement results. The Data Display window can 

have maximum 10 layers for displaying measurement results.

Repeat button opens the Repeat Measurement Setup dialog box used to set the repeat measurement 

condition.  To perform the repeat measurement, see Module 7.

To abort measurement, click Stop button that appears instead of the Single button.

To reset the counter, click the reset button.
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To Save/Recall Your Test Setup

Preset Group name.

Use this field to select 

preset group.

My Favorite Setup button

The test setups you create or modify MUST be saved in a preset group (My Favorite Setup).

To save the setup, click the Save button.

To recall the setup, click the Recall button.

You can organize the setups by using the My Favorite Setup button. 

To select the available preset group, use the field below the My Favorite Setup button.  In the above 

example, the Demo group is selected and listed in the My Favorite Setup list.

To rename, duplicate, or delete the setups, and to add, rename, duplicate, delete, import, or export the 

preset group, use the function of the My Favorite Setup button menu or the Organize Preset Group 

dialog box shown in the next page.
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To organize preset group for test setup 

My Favorite Setup   button

This dialog box is opened by selecting the Organize Preset Group function of the My Favorite Setup 

button menu, and is used to organize the preset group.

•Preset Group List

Lists the preset groups saved in the workspace.  The Add, Rename, Duplicate, Delete, Import, and 

Export buttons are available to organize the preset groups.

•Copy 

Sets the operation of the >> button and the << button. They work as Copy when this check box is 

checked, and as Move when this check box is blank.

•>> 

Copies or moves the preset setup selected in the left Preset Group box to the right Preset Group box.

•<< 

Copies or moves the preset setup selected in the right Preset Group box to the left Preset Group box.

•Close 

Closes the Organize Preset Group dialog box.

•Preset Group 

Lists the preset setups saved in the preset group.  The Select All, Unselect All, Rename, Duplicate, 

and Delete buttons are available to select or organize the setups saved in the preset group.
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To Export/Import Your Preset Group

My Favorite Setup

button

You can export/import your preset group.

To export the present preset group, click the My Favorite Setup button, select Export, and specify the 

folder and the name of the preset group to export. 

To import the preset group, click the My Favorite Setup button, select Import, and specify the preset 

group to import. 
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To Export/Import Test Record

1. Select data record to export, and right click.

2. Select Transport Data > Export As xxxx.

To export multiple data, select Transport Data > Folder Export.

To export the test result record, specify the data records and select the Transport Data > Export As 

xxxx menu.

You can save the data records as an EasyEXPERT file, a CSV file, a XML spreadsheet file, or a 

XML file created by using the specified XML style sheet.  

You can import the data record exported as the EasyEXPERT file or the XML spreadsheet file.

To import the file, select the Transport Data > Import… Then the Test Result Import dialog box is 

opened.  On the dialog box, select the file to import. 

You can read by using a text editor or a spreadsheet software as shown above.  This example reads a 

test record exported to a CSV file. 

Note:

To export multiple test records, select Transport Data > Folder Export…, and specify the destination 

folder and file names automatically set.  Then the multiple test records can be exported to the 

specified folder.
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Class Exercise

Perform Application Test.

1. Connect device (MOSFET). See the following pages.

2. Open Id-Vd test definition in the CMOS library.

3. Change the setup (SMU, output value, etc.)

4. Create your preset group, and save your setup. 

5. Click                 button to start a single measurement.

6. Perform this exercise for the Vth gmMax test 

definition.

Note:
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SMU Triax Connection

Force Lines to Fixture 1,2,3,4 Ports

16442A/B Fixture

B1500A Rear View

SMU4

SMU3

SMU2

SMU1

CMU

GNDU

Force side Sense side

For the non-Kelvin connections, connect only the Force lines, leaving the Sense lines open.

Connect corresponding numbers.  On the 16442A/B fixture use the numbers labeled 1 - 6, not 1 - 3. 

Your B1500A may not match the SMU configuration shown in this figure.  Note that SMU1 is the 

module top of the GNDU (ground unit).  The SMU number become large from bottom to top as 

shown.

This is the SMU cable setup that will be used in the remainder of the class exercises.
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Jumper Leads - MOS transistor

16088-60002

Dual in line package

(28 pin)

1 2 3 4 5 6

7 8 9 10 11 12

13 14 15 16 17 18

2019 21 22 23 24

25

27

26

28

14

1528

1

F

G

3
F

G

4
F

G

5

F

G

6
F

G

2
F

G

1

SMU

21
VMU

21

VSU

F

S

GNDU

F
2

F
1

PGU

With the 16442A/B fixture, note that there are two SMU numbering schemes....3 SMUs with force 

and sense, or six SMUs with force only.   For this class example we will use the six (6) SMU scheme.  

On older fixtures, this scheme is shown in light blue lettering. In newer fixtures, this scheme is 

shown in white reverse background lettering.
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Device Orientation and Insertion

Insert the transistor last, 

AFTER connecting the 

cables and leads.  Remove 

the shorting wire after 

insertion in the socket.

14

15

1
1: Substrate

2: Source

3: Gate

4: Drain

23

G

S D

Sub

The MOS FET leads must be re-arranged into a straight line as shown.

IMPORTANT:

The MOS FET is highly sensitive to electrostatic damage.  Touching the bare leads can definitely 

destroy the device.  The device comes with a special shorting wire attached.  Bend the leads the way 

you want, insert the device in the socket, and then remove the shorting wire.  The wire has a tab.  Just 

grab the tab and pull straight out.  The wire will spiral out as you pull.  

Once the shorting wire is removed, you must use a wrist strap when handling the device.
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Result Example

3. change

3. change

3. change

3. change

4. create

5. save
2. select

Test result data (record) is automatically saved after measurement.

1. check

1. Check the CMOS check box.

2. Select Id-Vd (or Vth gmMax) and click the Select button.

3. Change the SMU setting as follows.

Substrate: SMU1

Source: SMU2

Gate: SMU3

Drain: SMU4

4. Create your preset group (ex. Exercise).

5. Save the changed setup to your preset group.

After this class exercise, the Id-Vd setup and the Vth gmMax setup will be saved in your preset 

group.
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Result Example

This is the Id-Vd measurement result example of the following source setup.

Gate voltage: 0.5 V to 2 V, 0.5 V step

Drain voltage: 0 V to 2 V, 0.05 V step

Source voltage: 0 V

Substrate voltage: 0 V
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To Perform Quick Test

Softkeys

for single 

measurement

Step 1: Click Quick Test tab.

Step 2: Select the Preset Group.

Step 3: Set the execution ON/OFF and the data record ON/OFF for each test.

Step 4: Connect DUT, and click the Single button.  The B1500 starts the selected tests from top to 

bottom in the list.

After the measurement, the test result data is displayed on the Data Display window.  And the Test 

Result Editor is displayed on the lower left area of the B1500 screen if the Auto Record function or 

the Auto Export function is set to ON.  Check the status indicator at the bottom of the screen.

Step 5: Analyze the measurement result data.

The softkeys placed right side of the LCD are used to trigger a single measurement of the associated 

test.
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To organize preset group for test setup 
My Favorite Setup banner

This dialog box is opened by selecting the Organize Preset Group function of the My Favorite Setup 

banner menu, and is used to organize the test preset group.

•Preset Group List

Lists the preset groups saved in the workspace.  The Add, Rename, Duplicate, Delete, Import, and 

Export buttons are available to organize the preset groups.

•Copy 

Sets the operation of the >> button and the << button. They work as Copy when this check box is 

checked, and as Move when this check box is blank.

•>> 

Copies or moves the preset setup selected in the left Preset Group box to the right Preset Group box.

•<< 

Copies or moves the preset setup selected in the right Preset Group box to the left Preset Group box.

•Close 

Closes the Organize Preset Group dialog box.

•Preset Group 

Lists the preset setups saved in the preset group.  The Select All, Unselect All, Rename, Duplicate, 

and Delete buttons are available to select or organize the setups saved in the preset group.
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Class Exercise

Perform Quick Test.

1. Use the device connection of the previous exercise. 

2. Open your preset group.

3. Edit your preset group as you want (changing the test 

execution order etc.).

4. Save your preset group. 

5. Perform Quick Test.

Note:
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Result Example

Note:
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To Perform Tracer Test

Step 1: Click Tracer Test tab.

Step 2: Define the source and measurement channels.

Step 3: Set the source output parameters.

Step 4: Connect DUT, and click the Single button to start a single measurement.

After the measurement, the test result data is displayed on the graph area.  And the Test Result Editor 

is displayed on the lower left area of the B1500 screen if the Auto Record function or the Auto 

Export function is set to ON.  Check the status indicator at the bottom of the screen.
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Setup Example

1

3

4

5

4

3

2

You can complete the measurement setup by the following steps. 

1. Click Add button and add SMU1, SMU2, SMU3, and SMU4.

2. Set the channel definition.  See below.

3. Set the X axis parameter, polarity and maximum value.

4. Set the Y axis parameter, polarity and maximum value.

5. Define the VAR1, VAR2, and CONST setup.  See below.

Channel definition:

SMU1: Vsub, Isub, V mode, CONST

SMU2: Vs, Is, V mode, CONST

SMU3: Vg, Ig, V mode, VAR2

SMU4: Vd, Id, V mode, VAR1

Source setup:

VAR1: Stop 0 V, Compliance 100 mA

VAR2: Start 2 V, Stop 5 V, NOS 4, Compliance 10 mA

CONST: Compliance 100 mA

This is the MOSFET Id-Vd measurement setup example.

This measurement setup is effective for the device connection of the Application Test class exercise.
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Class Exercise

2

4

Perform Tracer Test.

1. Complete the measurement setup shown in the previous page.

2. Highlight the VAR1 Stop entry field and leave it.

3. Click            button to start a repeat measurement.

4. Rotate the rotary knob to change sweep range.

Note:
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Result Example

Note:
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Graph Setup and Option Tools

Y axis setup X axis setup

Sample setups 

Line/Dot

Cancel zoom

Set stop condition area

Replay traces

Capture a reference trace

Select reference traces

Select tracking traces

Marker

Color and thickness

Tangent line

Regression line

X or Y axis setup: Used to set the X or Y direction forward or reverse, the variables for X-Y plot, the 

graph scale linear or log, and the plot polarity positive, negative, or both.

Line/Dot: Used to switch line or dots of trace. See “Line/Dot” page.

Cancel zoom: This button is available for the graph zoomed in, and is used to return the graph scale 

to the original setting. The graph can be zoomed in by the point and drag operation. See “Zoom in 

and Cancel zoom” page.

Set stop condition area: See “To Use Stop Condition” page.

Replay traces: Opens/closes the dialog box used for managing the record and replay of traces. See 

“To Use Replay Function” page.

Capture a reference trace: Used to capture the trace as the reference trace. Up to 10 traces can be 

captured. See “To Use Reference Trace” page.

Select reference traces: Opens/closes the dialog box used for managing the reference traces. See 

“Select reference traces and Select tracking traces” page.

Select tracking traces: Opens/closes the dialog box used for managing the tracking traces. See 

“Select reference traces and Select tracking traces” page.

Marker: Enables/disables the marker.

Tangent line: Enables the marker and enables/disables the tangent line.

Regression line: Enables the marker and enables/disables the regression line.

Color and thickness: Opens/closes the dialog box for changing graph color and trace thickness.

Sample setups: See “Sample Setups” page.
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Sample Setups

MOSFET: ID-VDS, ID-VGS, ID(off)-VDS, BVDSS

Diode: IF-VF, IR-VR

BJT: IC-VCE, IC-VBE, IC-VCEO, BVCEO

MOSFET: ID-VDS, ID-VGS, ID(off)-VDS, BVDSS

Diode: IF-VF, IR-VR

IGBT: IC-VCE, IC-VGE, IC(off)-VCE, BVCES

BJT: IC-VCE, IC-VCEO, BVCEO, IC-VCBO, BVCBO

For B1505A

For B1500A

The Sample setup button displays the sample setup menu.  Clicking a setup name in the menu applies 

its setup to the tracer test environment. 
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Line/Dot

Clicking Line/Dot button 

toggles the line type between 

dotted and solid lines.

Note:
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Zoom in and Cancel zoom

Point and drag operation zooms in the graph.

Clicking the Cancel zoom 

button returns the graph scale 

to the original setting.

Note:
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Graph Minimum and Maximum

Clicking the minimum or 

maximum scale number 

pops up a dialog.
Enter the 

number and 

close the dialog.

E.g.: maximum is 

changed on Y-scale.

Clicking the Cancel zoom 

button returns the graph scale 

to the original setting.

Note:
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Marker

Click the Marker button 

to display the marker.

MarkerMarker position

To move the marker:

• Rotate the knob.

• Click somewhere on the 

graph.

• Use the mouse scroll button.

Note:
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Tangent Line

Click the Tangent line button 

to display the marker and the 

tangent line.

Marker

Line parameters:

• X-intercept

• Y-intercept

• Gradient

Tangent line

Note:
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Regression Line

1. Click the Regression line 

button to display the marker.

2. Point and drag to specify the data 

used for the regression calculation.

Line parameters:

• X-intercept

• Y-intercept

• Gradient

Regression line

Marker

3. Click the trace to draw 

the regression line.

Marker

Note:
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To Use Stop Condition

1. Click the Set stop condition area button.

2. Point and drag to specify the abnormal region.

Red

Yellow

Green

Red

Sweep measurement is stopped 

if the measurement data enters 

into the abnormal region.

Note:
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To Use Replay Function

Automatic trace record ON/OFF

Open trace record

Save trace record

Selects recorded trace.

N/M

N: Trace number

M: Total number of recorded traces

Click the Replay traces button to open this dialog box.

Use the slide bar or the arrow buttons (<<, <, >, >>) to select the recorded trace to display.

Long-clicking the << or >> button changes the trace sequentially.

Replay Interval is used to set the time interval of the long-click operation of the << and >> buttons. 

Maximum Records is used to set the maximum record count. After the record number reaches this 

value, the record numbers are shifted to the newer side and the oldest record is deleted. This number 

is always assigned to the last record.

Recording Interval is used to set the time interval of the automatic trace record operation.



Module 1

Getting Started

1-43

To Use Reference Trace

Click the Capture a reference trace 

button to capture the trace as the 

reference trace.

Comparing with reference trace 

expressly shows difference in such 

as thermal drift effect.

Note:
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Select reference traces and 

Select tracking traces

Erase selected trace

Open a trace

Save selected trace

Show/hide selected trace

Inversion

Erase selected trace

Select reference traces Select tracking traces

Reference trace means the trace set as the reference by using the Capture a reference trace button.  

Up to 10 traces can be captured.

The Select tracking traces button is available for the measurement result which contains at least two 

traces by the append measurement.  Tracking trace means each trace of this measurement result.
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GUI of Source Setup Area

Click title bar to display hidden parameters.

VAR2 and 

CONST hide 

behind.

Point and drag 

operation slides the 

source setup area.

Hidden parameters 

are displayed.

The source setup area is too small to display all setup parameter.  So the source setup area provides 

two display mode, short and full. To switch the mode, click the title bar, VAR1, VAR2, or CONST.  

You can see the hidden setup parameters.  Also use the point and drag operation to display the hidden 

parameters.
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Mode: LIN-SGL (linear single sweep)

LOG-SGL (log single sweep)

LIN-DBL (linear double sweep)

LOG-DBL (log double sweep)

NOS (numbers of steps)

Interlacing

Pulse Base

Pulse Delay

Pulse Width

Pulse Period

Baseline of Pulse Period

VAR1 Setup Parameters

Power Compliance

In the short mode, the VAR1 setup area shows Mode, Stop, MOS, and Compliance only.

In the full mode, Start, Step, Interlacing, and Pwr Comp. are added.

For the VPULSE source, Pulse Base, Pulse Delay, and Pulse Width are also added.

When a pulse source is set, Pulse Period is available instead of Step Time.
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2 points

NOS and Interlacing

Rough plots

Complete plots

Time

For “NOS = 3” and  “Interlacing = 5”

Start

Stop

Center

Sweep 1 2

Output

3 4 5

For “NOS = 11” and  “Interlacing = 1”

Start

Stop
Output

Sweep 1

11 points

3 points

2 points

2 points
2 points

Total 11 points

This slide explains the effect of the Interlacing parameter.  The NOS parameter sets the number of 

steps in a sweep operation.  And the Interlacing parameter sets the number of sweep operations 

performed in a single measurement.

This is the example of NOS=3 and Interlacing=5.  At first, the sweep measurement is performed for 

the Start, Center, and Stop values.  After that, the sweep measurement is repeated four times to 

narrow the sweep step.  This results the same sweep steps as the sweep output of NOS=11 and 

Interlacing=1 although the timing is not same for some steps.  By using the Interlacing, you can see 

the rough characteristics in the early stages.  This is effective for the measurement such as the total 

pulsed sweep time is so long.

For NOS=N and Interlacing=M, the sweep is repeated M times so that the final sweep step is equal to 

Step/M.  Total number of steps will be N+(N-1)*(M-1). 

The Interlacing is the function only for the Tracer Test environment.  This function is not available 

for the other test environment.  Also this function is not covered by the FLEX command set.
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Pwr Comp. – Power Compliance

Power limit is set 

to 5 W.

Source output and 

measurement is 

performed until 5 W.

Power compliance is effective to limit power consumption in the device.
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To Control Switching Matrix

This function

is not available 

for B1505A.

Step 1: Click Switching Matrix button to open the Switching Matrix Operation Panel.

Step 2: Enter the switch setup name.

Step 3: Define the switch setup by using the matrix on the operation panel window.  Label can be set 

to input ports and output channels.

Step 4: Click the Apply Switch Setup button to send the switch setup to the B2200/E5250 switching 

matrix.

Note: 

Before clicking this button, connect the B2200/E5250 to the B1500A via GPIB, and set the 

configuration.  To set the configuration, see Module 8.

The switch setups you create or modify MUST be saved in a preset group.

To save the setup, click the Save button.

To recall the setup, click the Recall button.

You can organize the setups by using the Preset List button. 

To select the available preset group, use the field below the Preset List button.  In the above example, 

the DemoSW group is selected and listed in the Preset List list.

To rename, duplicate, or delete the setups, and to add, rename, duplicate, or delete the preset group, 

use the function of the Preset List button menu or the Organize Preset Group dialog box shown in the 

next page.

Read Switch Setup: Read switch setup from B2200/E5250 via GP-IB and show it on the operation 

panel window.

Note: Standard revision of EasyEXPERT cannot support the E5250. The E5250 control is optional 

function of B1540A-002/B1541A-002.

Note: EasyEXPERT supports the E5250A installed with the E5252A matrix card.
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To organize preset group for switch setup 

Preset List     button

This dialog box is opened by selecting the Organize Preset Group function of the Preset List button 

menu, and is used to organize the switch preset group.

•Preset Group List

Lists the preset groups saved in the workspace.  The Add, Rename, Duplicate, and Delete buttons are 

available to organize the preset groups.

•Copy 

Sets the operation of the >> button and the << button. They work as Copy when this check box is 

checked, and as Move when this check box is blank.

•>> 

Copies or moves the preset setup selected in the left Preset Group box to the right Preset Group box.

•<< 

Copies or moves the preset setup selected in the right Preset Group box to the left Preset Group box.

•Close 

Closes the Organize Preset Group dialog box.

•Preset Group 

Lists the preset setups saved in the preset group.  The Select All, Unselect All, Rename, Duplicate, 

and Delete buttons are available to select or organize the setups saved in the preset group.
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To add switch setup to test preset group

Switch setups can be saved in the preset group for test setups.

Click the Export to Current My Favorite Group button.  The switch setup will be converted to a 

classic test setup and saved in the My Favorite Setup group opened in the main screen.

To select the available preset group, use the Preset Group field.  In the above example, the Demo 

group is selected and listed in the quick test setup list.

To duplicate, import, or export the preset group, use the function of the My Favorite Setup banner 

menu or the Organize Preset Group dialog box shown in the next page.
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Class Exercise

Add switch setup to test preset group.

1. Create a switch setup.

2. Create your switch preset group, and save your setup. 

3. Add the switch setup to your test preset group.

4. Save your test preset group. 

Note:
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To Manage Data Display Window

Data Display > Default Data Display Properties…

The Data Display Properties window is used to set the default setting of the Data Display window.  

This window is opened by selecting the Data Display > Default Data Display Properties... menu of 

the main screen.

The Effective Area is used to select the area effective when the Data Display window is opened, and 

provides the following check box.

•X-Y Graph: Check this box to enable the X-Y Graph area.

•Grid ON: Check this box to display the grid in the X-Y Graph.

•List Display: Check this box to enable the List Display area.

•Parameters: Check this box to enable the Parameters area.

The Graph Color area is used to set the color map for the Data Display window.  You can change the 

color of the background, text, graph grid, and line.  The color palette is opened by clicking the 

pattern of the item.

The Graph Trace Color area is used to set visibility, color, and thickness of the data traces Y1 to Y8 

plotted on the graph.

The Log Scale area is used to set the maximum number of decades to show the minor ticks for the 

log axis. If the number of graph decades is less than or equal to the entered value, the minor ticks are 

displayed. If it is greater than the entered value, the minor ticks are not displayed.

The Text Size area is used to set the font size for the graph. The available settings are Largest, Large, 

Medium, Small, Smallest, and Fixed. For settings other than Fixed, the appropriate size is 

automatically selected. For Fixed, a font size entry field is provided, and the specified font size is 

always applied.

•X/Y Axis Title: Font size for the axis title

•Scale: Font size for the X and Y coordinate values

•Legend: Font size for the graph legend
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To Manage Data Display Window

Data Display > Manage Data Display…

The Data Display Manager is used to control the appearances of the Data Display windows.  This 

window is opened by selecting the Data Display > Manage Data Display... menu of the main screen. 

The Data Display Window Order area lists the Setup Name of the Data Display windows opened.  

The list items from top to bottom correspond to the windows from front to back in the screen image. 

The Minimized Data Displays area lists the Setup Name of the Data Display windows minimized. 

The Data Display Window Configuration area provides the following radio buttons and a check box 

to change the appearances of the Data Display windows.  All functions are available for the opened 

windows.  See following slides for the display examples.

•Keep Setup: Keeps the present configuration of the Data Display windows.

•Tiling: Resize and collate the data display windows such that they fill up the entire screen.

•Stacking: Resize and collate the data display windows so that they overlap slightly with an offset.

•Overlaying: Resize, overlap, and make transparent the data display windows so that multiple graphs 

can be viewed and superimposed on one another.

The following check box must be checked to apply the same graph scale to all graphs.

•Apply same scale to all graph
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Tiling

This is a display example of Tiling.
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Stacking

This is a display example of Stacking.
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Overlaying

This is a display example of Overlaying.
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To tile/stack/overlay windows

Stacking

Tiling

Overlaying

When some Data Display windows are opened, the following Windows menu functions are useful.

Tiling

Tiles all Data Display windows on the screen.

Stacking

Stacks all Data Display windows on the screen.

Overlaying

Overlays all Data Display windows on the screen. Then the position, window size, and visibility of 

the most front window are applied to all windows on the screen.

The background of the X-Y Graph area is cleared except for the most back window.



2 Data Display and Management
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In This Module

• Data Display window

• Graph Analysis Tools

• Data Status

• To Change Graph/List/Display Setup

• To See Print Preview

• To Print Display Data

• To Copy Graph Plot/List Data

• To Save Analysis Result

• To Use Preview Window

This section describes the above topics.  You will understand how to use analysis tools, how to 

change display setup, and how to print/export test result data.
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Data Display window

X-Y Graph PLot Parameters

List Display

The Data Display window is opened after measurement automatically, or by clicking the Data 

Display button. And the window is used to display measurement data and analyze the data.

The Show X-Y Graph icon displays/hides the X-Y Graph Plot area.  This is the same as the View > 

X-Y Graph menu.

The Show List Display icon displays/hides the List Display area.  This is the same as the View > List 

Display menu.

The Show Parameters icon displays/hides the Parameters area.  This is the same as the View > 

Parameters menu.

Multiple data display windows can be opened while the Multi Display indicator is ON.  Then the test 

result data of the same test setup name will

be displayed on the exclusive Data Display window and the test result data of the different test setup 

name will be displayed on the new Data Display window.  To set Multi Display ON, click the Run 

Option button located at the top right of the Main window, check the “Allocate Data Display for each 

test” box on the Run Option dialog box, and click the Close button.
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Graph Analysis Tools

active line (normal line)

active cursor

cursor

marker

line (tangent line)

marker

This bar indicates 

which axis is 

effective for 

marker control 

and auto scaling.

cursor/marker position

(X value, Y1 value, Yx value)

Y1 Yx      (x : 2 to 8)

The Data Display window provides marker, cursors, and lines for analyzing test result data.  Marker 

is used to read measurement data and draw a tangent line.  Cursors are used to read the cursor 

position and draw a normal line, gradient line, or regression line.  The cursor/marker position data is 

displayed top of the graph plot area.

Clicking Y axis can select the Y axis effective for the analysis tools.  On the graph, left axis is always 

Y1 axis.  And the right axis is selectable from Y2 to Y8 axes.
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Graph Analysis Tools

Pointer

Text

Text Pointer

Text and pointer are the tools to decorate the X-Y Graph.

The text is used to leave notes on the graph.  The notes will be measurement conditions, device 

information, operator name, and so on. Up to 20 texts can be added to a graph.

The pointer is used to indicate the remarkable measurement point and show the X and Y coordinates 

like the marker.  The new pointer can be displayed on the marker point at first and can be moved on 

the measurement data curve by using the rotary knob or the mouse wheel.  Up to 30 pointers can be 

added to a graph.
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Graph Analysis Tools

Line Information:

Y1 intercept and 

gradient of 

active line

Line Information:

Yx intercept and 

gradient of 

active line

Line Information:

X intercept of active line

Show Graph Legend

Show Line Information

Graph Legend

When a line is displayed, the line information can be displayed in the graph plot area.  

The Show Line Information icon displays/hides the line information.  This is the same as the View > 

Line Information ON/OFF menu.

The Show Graph Legend icon displays/hides the graph legend.  This is the same as the View > Graph 

Legend ON/OFF menu.
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Graph Analysis Tools

Y1

Switch Display Mode

Hold this layer

Close this layer

Close All Displays

Layer selection tab.

This example has

three layers.

If the append measurement is performed, the data display layer is added to the Data Display window.  

In this example, the Data Display window has three layers.

Use the icons shown above to organize the data display layers. 

Switch Display Mode icon switches the mode, overwrite or append.

In the overwrite mode, the data is displayed in a new Data Display window.

In the append mode, the data is displayed on a new display layer in the present Data Display window.

The Data Display window can hold up to 10 display layers.  And the earliest layer over 10 will be 

automatically deleted.  The Hold this layer icon is available when the window holds at least two 

layers.  If this icon shows the standing pin, the layer will be held.  If this icon shows the laid pin, the 

layer can be deleted.  Double clicking the tab gives the same result as this icon.
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Graph Analysis Tools

Graph control

(X value, Y1 value, Yx value)

marker

line (tangent line)

marker

Graph control:

Auto Scale icon will change the graph scale automatically to fit the trace in the graph. The right 

arrow button opens the menu for enabling or disabling the run time auto scaling. This function is set 

independently for the X and Y axes.  If this function is enabled, the graph scale will be changed 

automatically to fit the trace in the graph during the measurement.  

Zoom In icon zooms the data graph in.  This enlarges the trace in the graph.  Then the center of 

zooming will be the cursor position.

Zoom Out icon zooms the data graph out.  This reduces the trace in the graph.

Graph Setup icon opens the Graph Setup dialog box used to change the graph axis setup.

Choose Active Y axis icon selects the Y axis that is effective for the analysis tools (marker control 

and auto scaling).

If multiple layers are opened on the Data Display window, the scale change is applied to the layers. 

This means that the X-Y graph scale will be shared by all display layers. The auto scaling is 

performed as follows.

1. Graph scale is optimized for the data on the selected layer (top layer).

2. The graph scale is applied to the graph in the all layers.

Note that auto scaling is performed independently for the left and right Y axes.

There is also a function for resetting the graph scale. Click View > Cancel Scaling > This Display or 

All Displays.  

This Display will reset the selected layer only. All Displays will reset all display layers.
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Graph Analysis Tools
Marker control

(X value, Y1 value, Yx value)

marker

line (tangent line)

marker

Marker control:

Marker ON/OFF icon enables or disables the marker.

Interpolation ON/OFF icon enables or disables the interpolation function of measurement data. You 

can read the interpolation data between two actual measurement points.

Marker Skip icon moves the marker to the next measurement curve that is added by the VAR2 

variable.

Marker Maximum icon moves the marker to the maximum measurement point.

Marker Minimum icon moves the marker to the minimum measurement point.

Marker Search icon opens the Direct Marker/Cursor dialog box used to specify the coordinate values 

to move the marker.



Module 2

Data Display and Management

2-10

Graph Analysis Tools

Line control

active line (normal line)

active cursor

cursor

marker

line (tangent line)

Line control:

Line 1 State icon enables or disables line 1 and its function: normal, gradient, tangent, or regression.

Line 2 State icon enables or disables line 2 and its function: normal, gradient, tangent, or regression.

Cursor to Marker icon moves the cursor to the marker position.

Adjust Gradient icon is available when a gradient line is active. Clicking this icon enables the rotary 

knob and the mouse wheel to increase/decrease the gradient of the line.  Clicking this icon again, 

clicking the rotary knob, or clicking the mouse wheel disables this function.
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To Enable Marker and Line

Marker > Marker ON/OFF
Line > Line 1 ON/OFF

Line 2 ON/OFF

Marker ON/OFF

Line 1 & Line 2

To enable maker, click the Marker ON/OFF icon, or select the Marker > Marker ON/OFF menu.

To enable the Line 1, click Line 1 icon and select one of the line mode.  Or select the Line > Line 1 

ON/OFF menu and select one of the line mode.

To enable the Line 2, click Line 2 icon and select one of the line mode.  Or select the Line > Line 2 

ON/OFF menu and select one of the line mode.

If you enable the Normal line, two cursors are available.  The cursors specify the points that the line 

passes through.

If you enable the Gradient line, a cursor is available.  The cursor specifies the point that the line 

passes through.

If you enable the Regression line, two cursors are available.  The cursor specify the measured data 

used to draw the regression line.



Module 2

Data Display and Management

2-12

To Draw Normal Line

2 cursors line

Line N > Normal
Cursor To Marker

Enable the Normal line by clicking the Line 1 (or Line 2) icon and Normal. 

Move cursors to draw the line.  The line passes through the cursor points. 

To move the cursor, you can use the Cursor To Marker icon.  The cursor will move to the marker 

point.
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To Draw Gradient Line

1 cursor
line

gradient

Adjust Gradient

Line N > Gradient
Cursor To Marker

Enable the Gradient line by clicking the Line 1 (or Line 2) icon and Gradient. 

Move the cursor to specify the point that the line passes through.  And click the Adjust Gradient icon.

Use the rotary knob or the mouse scroll button to adjust the gradient of the line. 

To move the cursor, you can use the Cursor To Marker icon.  The cursor will move to the marker 

point. 
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To Set Gradient Value

This is another way to draw the gradient line.

Set the line 1 or 2 ON and select the gradient line mode.  Then click Line > Gradient… to open the 

Gradient Value dialog box. 

On the dialog box, enter the desired gradient value, and click OK to draw the gradient line.
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To Draw Tangent Line

marker
line

data curve

Line N > Tangent

Enable the Tangent line by clicking the Line 1 (or Line 2) icon and Tangent. 

Move marker to draw the line.  The tangent line will pass through the marker point.
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To Draw Regression Line

line
2 cursors

measured data

Cursor To Marker
Line N > Regression

Enable the Regression line by clicking the Line 1 (or Line 2) icon and Regression. 

Move cursors to specify the region of the measurement data used for the regression calculation.

To move the cursor, you can use the Cursor To Marker icon.  The cursor will move to the marker 

point.
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To Fix a Line

Line N > Fix

The specified line cannot 

move while the Line Mode 

is set to Fix.

To fix a line, click the Line 1 (or Line 2) icon and Fix, or select the Line > Line Mode > Fix menu.

While the Line Mode is set to Fix, the specified line cannot move.
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To Add Text 

Text > New

To add a text, click Text > New.  A text editor appears.  Then enter the text you desire. 

The following functions are available for the selected text(s) via the Text menu, the Text icons, or the 

right-click menu.

Clicking on a text will select the text. To select the multiple texts, click the text while holding down 

the Shift key on the keyboard. 

Edit Mode: Edits the selected text. 

Size: Sets the font size of the selected text(s). The available setting values are Largest, Large, 

Medium, Small, Smallest, and Fixed Point (6, 7, 8, 9, 10, 11, 12, 14, 16, 18, or 20). For settings other 

than Fixed Point, an appropriate size will automatically be applied. For Fixed Point, the specified 

font size will always be applied.

Font: Sets the font of the selected text(s).

Text Color: Sets the text color of the selected text(s).  Click Customize to open the color palette.

Background Color: Sets the background color of the selected text(s).  Click Customize to open the 

color palette. 

Hide Frame/Show Frame: Hides or shows the frame for the selected text(s).

Delete: Deletes the selected text(s).

Dragging a text moves this text.
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To Add Pointers

Pointer > New

To add a pointer, set Marker ON, click Pointer > New.  A pointer and description (pointer ID and X-

Y coordinate values) appear.  Then move the pointer you desire by using the rotary knob or the 

mouse wheel.

The following functions are available for the selected pointer(s) or description(s) via the Pointer 

menu, the Pointer icons, or the right-click menu. 

Clicking on a pointer will select the pointer. To select the multiple pointers, click the pointer while 

holding down the Shift key on the keyboard. 

Clicking on a description will select the description of a pointer. To select the multiple descriptions, 

click the description while holding down the Shift key on the keyboard. 

Shape: Sets the shape of the selected pointer(s).

Hide Description/Show Description: Hides or shows the description of the selected pointer(s).

Delete: Deletes the selected pointer(s).

The rotary knob or the mouse wheel can be used to move the selected pointer in the VAR1 direction.  

The pointer can not be moved in the VAR2 direction.

Dragging a description of pointer moves this description of pointer.
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Data Status

If measurement unit detects any status while measurement, the status code is recorded with the 

measurement data.  In this example, a SMU detected the compliance condition in the drain channel, 

so the status code C is put just before the Idrain value.

SMU status code:

• C: Compliance

• T: Other channel compliance

• X: Oscillation

• V: Overflow

MFCMU status code:

• U: Unbalance

• D: I/V amp saturation

• V: Overflow
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To Change Graph Properties

The Graph Properties dialog box is used to set the following setting of the selected Data Display 

window.  This dialog box is opened by clicking the Properties... button in the X-Y Graph Plot area or 

by selecting the Edit > Graph Properties... menu of the Data Display window.

The Grid ON check box in the Effective Area is used to display the grid in the X-Y Graph.

The Graph Color area is used to set the color map for the Data Display window. You can change the 

color of the background, text, graph grid, and line/cursor. The color palette is opened by clicking the 

pattern of the item.

The Graph Trace Color area is used to set visibility, color, and thickness of the data traces Y1 to Y8 

plotted on the graph.

The Log Scale area is used to set the maximum number of decades to show the minor ticks for the 

log axis. If the number of graph decades is less than or equal to the entered value, the minor ticks are 

displayed. If it is greater than the entered value, the minor ticks are not displayed.

The Text Size area is used to set the font size for the graph. The available settings are Largest, Large, 

Medium, Small, Smallest, and Fixed. For settings other than Fixed, the appropriate size is 

automatically selected. For Fixed, a font size entry field is provided, and the specified font size is 

always applied.

•X/Y Axis Title: Font size for the axis title

•Scale: Font size for the X and Y coordinate values

•Legend: Font size for the graph legend
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To Change List Display Properties

Edit > List Display Properties…

Example: -1.2345 mA

Example: -1.23456789012345E-003 A

Example: C -1.2345 V

Data Status

Physical Unit

This dialog box is used to set the data display format in the List Display area.  This dialog box is 

opened by clicking the Properties... button in the List Display area or by selecting Edit > List Display 

Properties... menu of the Data Display window. 

Display: 

Check the following check box to add the data status or the physical unit to data. Unchecking the box 

removes it.

•Data Status: Adds or removes the status code before data.

•Physical Unit: Adds or removes the physical unit after data.

Number Format:

Selects the data display format from the following formats.

• Engineering Format (with Unit Prefix):

Data display with arithmetic point, SI prefix, and unit.

Example: -1.2345 mA

• Scientific Notation:

Data display with arithmetic point, exponential part (E, +/- sign, and three-digit number), and unit.

Example: -1.23456789012345E-003 A
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To Change Display Setup

View > Display Setup…

This dialog box is used to change the graph scale and data to be displayed in the Data Display 

window.

The X-Y Graph area sets the X and Y1 to Y8 axes of the X-Y Graph Plot area.

Name: Specifies the parameter for the axis

•Sharing: Specifies the group for sharing the Y axis scale. Select from Group 1, Group 2, Group 3, 

Group 4, or None (no grouping). The Scale, Min, and Max values are shared by the Y axes in the 

same group. The scale set by Run Time Auto Scale, Auto Scale, Zoom in, and/or Zoom out are also 

shared. If another layer on the Data Display window contains an X-Y trace which has the same name 

for both its grouped Y parameter and its X parameter, the scaling will also be shared by this X-Y 

trace. 

•Scale: Scale of the axis, Linear or Log

•Min: Minimum value of the axis

•Max: Maximum value of the axis

The List Display area selects the variables to be listed in the List Display area.  Up to 20 variables 

can be set.

The Parameters area selects the variables to be listed in the Parameters area.  Up to 20 parameters 

can be set.



Module 2

Data Display and Management

2-24

To See Print Preview

File > Print Preview…

The Data Display window provides the File > Print Preview… function to show the print preview.  

This is an example of the print preview.

•Select the File > Print Preview menu to open the Print Preview dialog box.

•Set the Print Range, Data to print, and Scaling.

•Click Preview button.  The Print preview window is displayed.
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To Print Display Data

bmp, emf, gif, or png format

File > Print File > Save Image As…

The Data Display window provides the display image output capability to a printer or a file.

Before printing, connect a printer to the B1500A/B1505A via the parallel interface or the LAN, and 

set up it by using the Add Printer Wizard of Windows.  After that, do following.

•Select the File > Print menu to open the Print dialog box.

•Set the Print Range, Data to print, and Scaling.

•Click Next button.

•Select the printer, and set the Properties.

•Click OK button.

You can export the display image to a file as shown below.

•Select the File > Save Image As… menu to open the Save Image As… dialog box.

•Select the format (file type) from Save As Type menu.

•Enter the file name.

•Click Save button.

The file can be imported by the graphics software that supports the exported file type.  The 

EasyEXPERT supports the following types.

•bmp: Bitmap image

•emf: Enhanced metafile

•gif: GIF image

•png: PNG image
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To Copy Graph Plot

Paste to WordPad

You can copy graph image to the clipboard, and paste it to a word processing software.  In the above 

example, the graph image is pasted to the WordPad.

This is an example of the copy and paste operation.

•Select the Edit > Copy Graph menu on the Data Display window.

•Select the Edit > Paste menu on the WordPad.
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To Copy List Data

Paste to Notepad

Open by a spreadsheet software

You can copy the data list to the clipboard, and paste it to a word processing software.  In the above 

example, the data list is pasted to the Notepad.

This is an example of the copy and paste operation.

•Select the Edit > Copy List menu on the Data Display window.

•Select the Edit > Paste menu on the Notepad.

You can save the data as a text file, and read it by using a spreadsheet software.  Data elements are 

separated by a tab.

Note:

As same as the Copy List function, the Copy Parameter function is used to copy the data in the 

Parameter area.
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To Save Analysis Result
Select File > Update Test Result

Select File > Save Image As…

Saves graph information to data record.

Saves graph image as a file.

To leave the graph modification information such as scaling, marker, cursor, and line on the graph, 

select the File > Update Test Result menu.

You can see the all information when you open the graph again.  Note that the modification 

information will be destroyed if you did not do it. 

To save the graph image as a file, select the File > Save Image As… menu.

You can save the image as a bmp, emf, gif, or png file.
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Class Exercise

Use the analysis tools.

1. Use your test setup (for example, GMMAX in the 

Demo preset group) and perform measurement .

2. Enable marker and draw line.  Try it for all line 

types.

3. Copy/paste/save data list, and open it by using a 

spreadsheet software (optional, if you can).

4. Save analysis condition.  Re-open the test record.

5. Export your test record.  And import it. 

Note:
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To Use Preview Window

The Data Display window provides the File > Print… function to print the graph image.  However, 

you may want to set the graph title and change the line style.  Then use the Preview window.  The 

Preview window is used to see and print the graph image you modified.

Select the View > Open Preview Window to open the Preview window and the Preview Settings 

dialog box.  And use the Preview Settings dialog box to set the title of graph, X axis, and Y axis, and 

change the line style.  To change the color and thickness, use the Color and Thickness dialog box 

opened by clicking the Color and Thickness… button.

Clicking OK button in the Preview Settings dialog box applies the modification to the Preview 

window and closes the dialog box.

Note:

The graph image in the Preview window cannot be saved.
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To Use Preview Window

This example is result of the changes shown in the previous page.

Line style was changed as shown above.  The titles are set as follows.

Graph title: ID-VG Characteristics

X axis title: Gate Voltage

Y1 axis title: Drain Current

Y2 axis title: Transconductance

Y3 axis title: Drain Current

Also color of line1 was changed to red, and thickness of trace was changed.

To change the setup again, open the Preview Settings dialog box by selecting the View > Preview 

Settings… menu.
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Class Exercise

Use the Preview window.

1. Use your test record used in the previous exercise.

2. Change the graph image as you want.

- Add graph title and change axis title.

- Change line style

- Change color and thickness

3. Print the graph image if a printer is available. 

Note:
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In This Module

• Classic Test Execution Mode

• I/V Sweep Measurement

• Multi Channel I/V Sweep Measurement

• I/V List Sweep Measurement

• I/V-t Sampling Measurement

• C-V Sweep Measurement

• Switching Matrix Control

• Direct Control

Note:
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Classic Test Execution Mode

• I/V Sweep

• Multi Channel I/V Sweep 

• I/V List Sweep

• I/V-t Sampling

• C-V Sweep

• SPGU Control

• Switching Matrix Control

• Direct Control

To use the classic test mode, click the Classic Test tab.  And select the execution mode.  The 

following modes are available.

•I/V Sweep: For X-Y characteristics measurement of I or V.

•Multi Channel I/V Sweep: For simultaneous multi channel (up to 10) sweep measurement of I or V.

•I/V List Sweep: For multi channel (up to 10) I/V sweep measurement using list data.

•I/V-t Sampling: For time-Y characteristics measurement of I or V.

•C-V Sweep: For DC bias-impedance characteristics measurement.

•SPGU Control: For voltage pulse output. Not available for B1505A.

•Switching Matrix Control: For B2200/E5250 switching matrix control. Not available for B1505A.

•Direct Control: For various measurements (e.g. C-f measurement, Quasi-Static C-V measurement) 

using Agilent FLEX commands.
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I/V Sweep Measurement

• To Define Source/Measurement Channels

• To Read Time Stamp Data and Data Index

• To Set Source Outputs (VAR1, VAR2, VAR1’, Pulse, CONST)

• To Set Timing Parameters

• To Set Sweep Abort Function

• Range, ADC, Advanced, SPGU

• To Set User Functions

• To Set Analysis Functions

• To Set Auto Analysis Function

• To Set Display Parameters (X-Y Graph, Data List, Parameter)

This section explains how to perform I/V sweep measurement.  You will perform the above tasks to 

execute the I/V sweep measurement.
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Channel Setup

SMU Channel Definition

-V name/I name

-I/V/IPULSE/VPULSE/COMMON

-VAR1/VAR2/VAR1’/CONST

SPGU Channel Definition

-V name

-VPULSE/ALWG

Setup Name

SMU4

SMU2

SMU1

SMU3

To Define Source/Measurement Channels

Click the I/V Sweep icon and open the setup editor.  Then click the Channel Setup tab to display the 

channel definition screen. 

1. Enter the Setup Name for the test setup to be defined on the setup editor.

2. List SMUs used for source output or measurement, and set the following parameters.

•Unit: SMU name or number.  The GNDU (ground unit) can be set instead of a SMU.

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), VPULSE (voltage pulse), IPULSE (current 

pulse), or COMMON (ground)

•Function: Source output function, VAR1 (primary sweep), VAR2 (secondary sweep), VAR1’

(synchronous sweep), CONST (constant)

V Name and I Name are used to specify the parameters displayed on the Data Display window.  The 

display parameters are selected on the Display Setup tab screen. For the GNDU, 0 V is returned to 

the V variable and no data is returned to the I variable. 

To use the SPGU channels, click the Add SPGU button.  The SPGU channel setup row will appear.  

Then set the following parameters.

•Unit: SPGU name or number

•V Name: Variable name for the voltage data.  No data is returned to the variable.

•Mode: SPGU output mode.  VPULSE (voltage pulse) or ALWG (arbitrary linear waveform voltage) 

for all SPGU.
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To Read Time Stamp Data and Index

Channel Setup

Variable name for time stamp data

Variable name for data index

You can read measurement data by using the Data Display window. Parameters displayed on the 

window are selected on the Display Setup tab screen.  If you enter the variable name in the V Name, 

I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables as the 

display parameters.

Note:

The time stamp is the time the measurement is started for each measurement point.

The index is the index number for each measurement data.
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To Set Primary Sweep Source

Measurement Setup

Start

Stop

Step

VAR1

The Measurement Setup tab screen is used to set the source output value and timing parameters.  

At the VAR1 area, you set the primary sweep source output.

•Unit: SMU name or number

•Name: Variable name of source output

•Direction: Single (start to stop) or Double (start to stop to start)

•Linear/Log: Linear sweep or Log sweep

•Start: Source output start value

•Stop: Source output stop value

•Step: Source output incremental step value

•No of Step: Number of sweep steps

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value
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To Set Secondary Sweep Source

Measurement Setup

VAR2

VAR1

At the VAR2 area, you set the secondary sweep source output.

•Unit: SMU name or number

•Name: Variable name of source output

•Start: Source output start value

•Stop: Source output stop value

•Step: Source output incremental step value

•No of Step: Number of sweep steps

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value
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To Set Synchronous Sweep Source

Measurement Setup

VAR1’

VAR1

At the VAR1’ area, you set the synchronous sweep source output.

•Unit: SMU name or number

•Name: Variable name of source output

•Offset: B value of the above formula.

•Ratio: A value of the above formula.

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value

The VAR1’ output is expressed by the following formula.

VAR1’ output = A × (VAR1 output) + B
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To Set Pulse Output

Measurement Setup

Period

Hold time

Width Width

Delay time cannot be set.

Trigger

Base

At the SMU Pulse area, you set the SMU pulse timing parameter and the pulse base value.

•Unit: SMU name or number

•Period: Pulse period

•Width: Pulse width

•Base: Pulse base value

Only a SMU can be set to the pulse source.
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To Set Constant Output

Measurement Setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), VPULSE (voltage pulse), IPULSE (current 

pulse), or COMMON (ground)

•Source: SMU output value

•Compliance: SMU compliance value
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To Set Timing Parameters

Measurement Setup

Hold time

Delay time

Measurement time

Trigger

At the Timing area, you set the source output and measurement timing.

•Hold: Source output hold time. Time after the measurement trigger until starting delay time.

•Delay: Measurement start delay time. Time after the hold time until starting measurement.

When a SMU forces pulse, the delay time is ignored.  Source output and measurement timing will be 

controlled by the pulse width and pulse period.
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To Set Sweep Abort Function

Measurement Setup

CONTINUE AT ANY

STOP AT ANY 

ABNORMAL

-Range overflow

-SMU compliance

-SMU oscillation

This field sets the sweep abort function.

When this field is CONTINUE AT ANY, the sweep measurement is not aborted.

When this field is STOP AT ANY ABNORMAL, the sweep measurement will be aborted when one 

of the following conditions is detected.

•Measurement range overflow

•SMU compliance

•SMU oscillation
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To Set Ranging Mode

Measurement Setup

Not available when a SMU pulse is used.

The Range button opens the SMU Range Setup dialog box.  The dialog box is used to set the 

measurement ranging mode.  This button is not available when a pulse source is used.

•Unit: SMU name or number

•Name: Variable name for the measurement data

•Mode: Ranging mode, AUTO, LIMITED, or FIXED

•Range: Range value

•Range Change Rule: BY FULL RANGE, GO UP AHEAD, or UP AND DOWN AHEAD

•Rate: Value used for range changing.  See the following formula.

For the AUTO or LIMITED, SMU automatically selects the minimum range that covers the 

measurement value, and performs the measurement by using the range.  For the limited auto ranging, 

the instrument does not use the range lower than the specified range value.  For example, if you 

select the 100 nA limited auto ranging, the instrument never uses the 10 nA range and below. 

BY FULL RANGE performs normal auto ranging operation.

For the GO UP AHEAD and UP AND DOWN AHEAD rules, specify the Rate value, 11 to 100, 

which fixes the boundary of the ranging. The ranging occurs when the measurement data goes across 

the boundary values shown below.

go up boundary = present measurement range × Rate / 100

go down boundary = present measurement range × Rate / 1000

The go down boundary is available only for the UP AND DOWN AHEAD rule.
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To Set ADC/Integration Time

Measurement Setup

The ADC/Integ button opens the A/D Converter & Integration Time Setup dialog box.  The dialog 

box is used to select the ADC for each SMU and set the integration time for each ADC (high 

resolution or high speed). 

A/D Converter:

•Unit: SMU name or number

•Name: Variable name of the measurement data

•ADC: ADC type, HR ADC (high resolution) or HS ADC (high speed)

•Measurement: Compliance side measurement or Force and Compliance sides measurement.

HR ADC is not available for HCSMU, HVSMU, and the measurement which uses SMU pulse.

Force and Compliance sides measurement is not available for HRSMU, MPSMU, and HPSMU.

Integration Time:

•Mode: ADC operation mode

AUTO, MANUAL, or PLC for HR ADC

AUTO, MANUAL, PLC, or TIME for HS ADC

TIME or PLC for the measurements using SMU pulse.

•Factor: Coefficient for the reference value of the integration time.

•Auto Zero: Auto Zero function ON or OFF.  For HR ADC.
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Advanced Setup

Measurement Setup

The Advanced button opens the Advanced Setup dialog box.  The dialog box is used to set the SMU 

filter and SMU series resistor settings, the wait time, the after measurement settings, and the 16440A 

selector semiconductor relay setting.

Channel Settings:

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Series R: SMU series resistor NONE or 1MOHM (1000000 ohm)

•SMU Filter: SMU filter ON or OFF

Wait Time Control:

•Factor: Coefficient for the reference value of the wait time.  For details, see online help or User’s 

Guide.

After Measurement Settings:

•Bias Hold after Measurement: Bias hold function ON or OFF.

•Output Value after Measurement: Source output value after measurement.  START (sweep start 

value), STOP (sweep stop value), SOURCE (sampling output source value), or BASE (sampling 

output base value)

Note: Pulse channel output after measurement is always Base value.

Semiconductor Relays (16440A SMU/PG Selector):

•CH1: Default or PGU OPEN

•CH3: Default or PGU OPEN

The fields define the selector channel’s switch condition during the measurement.  Default is the 

setting defined on the SMU/PG Selector screen of the Configuration window.
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SPGU Pulse Setup

Measurement Setup

This button is 

available when 

a SPGU channel 

is defined in 

Channel Setup.

If a SPGU channel is defined and set to the VPULSE mode on the Channel Setup screen, the SPGU 

Pulse Setup button is effective.  This button opens the SPGU Pulse Setup window which is used to 

define the voltage pulse output by the specified SPGU channels. Maximum 10 SPGU channels can 

be used.  Not available for B1505A.
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SPGU ALWG Setup

Measurement Setup

This button is 

available when 

a SPGU channel 

is defined in 

Channel Setup. This button opens the Define ALWG 

Waveform window used to define the 

arbitrary linear waveform.

If a SPGU channel is defined and set to the ALWG mode on the Channel Setup screen, the SPGU 

ALWG Setup button is effective.  This button opens the SPGU ALWG Setup window which is used 

to define the arbitrary linear waveform voltage output by the specified SPGU channels.  Maximum 

10 SPGU channels can be used.  Not available for B1505A.
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To Set User Functions

Function Setup

Data calculation

-Measurement data/source data

-Built-in function, etc.

Apply

Click the Function Setup tab to display the User Function/Analysis Function setup screen.  The user 

functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of the Data 

Display window.  Up to 20 functions can be set.

Name: Function name

Unit: Unit of the function

Definition: Definition of the function.  The following identifiers can be used.

-Variables for the measurement/output data used in this test

-Functions defined in the above lines

-Local variables passed from the application test that calls this test as a component

-Built-in functions and global variables

For details, see online help or User’s Guide.

Note:

The Apply button performs calculation of the definition in this screen. If this button is clicked when 

the Data Display window associated with this test has been opened, the display is also updated.  The 

associated Data Display window will be the Data Display window that displays the last measurement 

data or that is recalled at last.
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To Set Analysis Functions

Function Setup

Data calculation

-Measurement data/source data

-Read out function

-Built-in function, etc.

Apply

The analysis functions can be displayed on the Parameters area of the Data Display window.  Up to 

20 functions can be set.

Name: Function name

Unit: Unit of the function

Definition: Definition of the function. The following identifiers can be used.

-Variables for the measurement/output data used in this test

-Functions defined in the above lines

-Local variables passed from the application test that calls this test as a component

-Built-in functions and global variables

-Read out functions

For details, see online help or User’s Guide.

Note:

The Apply button performs calculation of the definition in this screen. If this button is clicked when 

the Data Display window associated with this test has been opened, the display is also updated.  The 

associated Data Display window will be the Data Display window that displays the last measurement 

data or that is recalled at last.
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To Set Auto Analysis Function

Interpolation

Line 1 setup

Line 2 setup

Marker setup

Auto Analysis
Apply

Click the Auto Analysis Setup tab to display the auto analysis setup screen.  The auto analysis 

capability allows you to display/move the marker/line on the data graph automatically after 

measurement.  The above example displays marker at Vd=1 V point and draw a tangent line for this 

point.

Interpolation Mode:  Check this box to enable the interpolation mode. You can position marker 

between measurement points. 

Line 1, Line 2:  This area sets the line 1 or line 2 automatically displayed and moved to the specified 

position after the measurement.  Check Enable box to enable the line.

For Type, select a line type, Normal, Gradient, Tangent, or Regression.

For Axis, select the axis effective for the line.

In First Point and Second Point, specify the cursor points used to draw line.

In Gradient, specify the slope of the Gradient line.

Marker:  This area sets the marker automatically displayed and moved to the specified position after 

the measurement.  Check Enable box to enable the marker.

For Condition, enter a variable name and a condition expression to specify where you want the 

marker to display.

For After, check this box to enable the additional condition.  And enter a second variable and 

condition expression. This sets up a search start condition for finding specified point.

For example, you can specify the following expressions to search for a measurement point that 

satisfies the first condition after the second condition is satisfied.

Condition: [DGM] = [MAX(DGM)*0.01] [x] After [DGM] = [MAX(DGM)]

Note:

The Apply button performs calculation of the definition in this screen. If this button is clicked when 

the Data Display window associated with this test has been opened, the display is also updated.  The 

associated Data Display window will be the Data Display window that displays the last measurement 

data or that is recalled at last.
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To Set X-Y Graph Display

Display Setup

Specify X axis and Y axis

Click the Display Setup tab to display the display setup screen. The X-Y Graph area is used to set 

the X axis and Y axis of the X-Y Graph Plot area in the Data Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis
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To Set Data List Display

Display Setup

Select variables to list

The List Display area selects the variables to be listed in the List Display area of the Data Display 

window.  Up to 20 variables can be set.
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To Set Parameters Display

Display Setup

Select parameters to display

The Parameters area selects the variables to be listed in the Parameters area of the Data Display 

window.  Up to 20 parameters can be set.



Module 3

Classic Test Environment

3-25

To Save Test Setup

Preset Group name.

Use this field to 

select preset group.

My Favorite Setup button

The test setups you create MUST be saved to the internal hard disk drive as “My Favorite Setup”.

To save the setup, click the Save button.

To recall the setup, click the Recall button.

You can organize the setups by using Preset Group.  In the above example, the Demo group is 

selected and listed in the “My Favorite Setup”.

To create a new preset group, click the My Favorite Setup button to display the function menu, and 

select Add New Preset Group. 

To select the available preset group, use the field below the My Favorite Setup button.
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To Export/Import Your Preset Group

My Favorite Setup button

Preset Group Export

You can export/import your preset group.

To export the present preset group, click the My Favorite Setup button, select Export, and specify the 

folder and the name of the preset group to export. 

To import the preset group, click the My Favorite Setup button, select Import, and specify the preset 

group to import. 
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Class Exercise

Define test setup and perform test.

1. Click I/V Sweep icon and open setup editor.

2. Define test setup as shown in the previous pages.

3. Save it as Trng Id-Vd.

4. Connect device, and perform test.

5. Export preset group, and import it. 
SMU4

SMU2

SMU1

SMU3

Note:
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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Multi Channel I/V Sweep

• To Define Channel Setup Screen

• To Set VAR1 Sweep Sources

• To Set Constant Output

• Other Measurement Setup Parameters

• To Set User Functions

• To Set Data Display

This section explains how to perform the Multi Channel I/V sweep measurement.  You will perform 

the above tasks to execute the Multi Channel I/V sweep measurement.
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Multi Channel I/V Sweep

Start measurement

Voltage or current

Stop value

Start value

0

Time

: Measurement

Hold time

Delay timeStop value

Start value

0

Voltage or current

Stop value

Start value

0

Voltage or current

Primary sweep source

Second sweep source

Tenth sweep source

Delay time

Multi Channel I/V Sweep measurement is similar to I/V Sweep measurement.

Changes from I/V Sweep are listed below.

•All SMU can be set to the VAR1 sweep source (up to 10 channels)

•All SMU can be set to the pulse output mode

•Both voltage mode and current mode are available for the VAR1 sweep output

•VAR1’ sweep output is not available

The output channels start to output in the order in which they are listed on the Channel Setup screen.

If multiple pulse output channels are used, the DC output channels start to output in the order in 

which they are listed on the Channel Setup screen, and then the pulse output channels start to output 

simultaneously.  And the all measurement channels perform measurements simultaneously.
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Setup Name

To Define Channel Setup Screen

SMU Channel Definition

-V name/I name

-I/V/IPULSE/VPULSE/COMMON

-VAR1/VAR2/CONST

SPGU Channel Definition

-V name

-VPULSE/ALWG

Channel Setup

Variable name for reading time stamp data

Variable name for reading data index

Click the Multi Channel I/V Sweep icon and open the setup editor.  Then click the Channel Setup tab 

to display the channel definition screen. 

1. Enter the Setup Name for the test setup to be defined on the setup editor.

2. List SMUs used for source output or measurement, and set the following parameters.

•Unit: SMU name or number.  The GNDU (ground unit) can be set instead of a SMU.

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), VPULSE (voltage pulse), IPULSE (current 

pulse), or COMMON (ground)

•Function: Source output function, VAR1 (primary sweep), VAR2 (secondary sweep), CONST 

(constant).  Up to 10 sources can be set to VAR1.

V Name and I Name are used to specify the parameters displayed on the Data Display window.  The 

display parameters are selected on the Display Setup tab screen. For the GNDU, 0 V is returned to 

the V variable and no data is returned to the I variable. 

To use the SPGU channels, click the Add SPGU button.  The SPGU channel setup row will appear.  

Then set the following parameters.

•Unit: SPGU name or number

•V Name: Variable name for the voltage data.  No data is returned to the variable.

•Mode: SPGU output mode.  VPULSE (voltage pulse) or ALWG (arbitrary linear waveform voltage) 

for all SPGU.

You can read measurement data by using the Data Display window. Parameters displayed on the 

window are selected on the Display Setup tab screen.  If you enter the variable name in the V Name, 

I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables as the 

display parameters.

Note:  The time stamp is the time the measurement is started for each measurement point.  The index 

is the index number for each measurement data.
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To Set VAR1 Sweep Sources

Start

Stop
SMU1

Start

Stop
SMU2

Measurement Setup

The Measurement Setup tab screen is used to set the source output value and timing parameters.  

At the VAR1 area, you set VAR1 sweep sources.

Follows are common parameters for all VAR1 sweep sources.

•Direction: Single (start to stop) or Double (start to stop to start) 

•Linear/Log: Linear sweep or Log sweep

•No of Step: Number of sweep steps

Following parameters can be set for each VAR1 sweep sources.

•Unit: SMU name or number

•Name: Variable name of source output

•Start: Source output start value

•Stop: Source output stop value

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value
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To Set Constant Output

Measurement Setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Source: SMU output value

•Compliance: SMU compliance value
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Other Measurement Setup Parameters

Measurement Setup

For the functions of Timing, Sweep status, Range, ADC/Integ, Advanced, SPGU Pulse Setup, and 

SPGU ALWG Setup, see the following pages respectively in the I/V Sweep section of this module.

•To Set Timing Parameters

•To Set Sweep Abort Function

•To Set Ranging Mode

•To Set ADC/Integration Time

•Advanced Setup

•SPGU Pulse Setup

•SPGU ALWG Setup

If a SMU is set to the pulse output:

The Range button is not available.

The dialog box opened by the ADC/Integ button is different from the I/V Sweep.  See “A/D 

Converter & Integration Time Setting” page.

The Pulse button is available which opens the Pulse Setup dialog box.  See “Pulse Setup” page.
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A/D Converter & Integration Time Setup

Measurement Setup

The ADC/Integ button opens the A/D Converter & Integration Time Setup dialog box.  The dialog 

box is used to set the operation of the high speed ADC. 

A/D Converter:

•Unit: SMU name or number

•Name: Variable name of the measurement data

•ADC: ADC type, HS ADC (high speed)

•Measurement: Compliance side measurement or Force and Compliance sides measurement.

HR ADC is not available for HCSMU, HVSMU, and the measurement which uses SMU pulse.

Force and Compliance sides measurement is not available for HRSMU, MPSMU, and HPSMU.

Integration Time:

•Mode: ADC operation mode TIME or PLC.

•Factor: Coefficient for the reference value of the integration time.

Pulse Averaging Count:

•Count: Number of pulsed measurements for averaging to get one measurement data. Not effective 

for HRSMU, MPSMU, and HPSMU. The setting is automatically set to the same setting on the Pulse 

Setup dialog box for using multiple SMU pulse output channels.
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Pulse Setup

Measurement Setup For multiple pulse sources

For single pulse source

Common: 

•Period: Pulse period. Entering AUTO sets the optimum value automatically.

•Measurement Delay Time: Delay time from the beginning of the pulse period to the beginning of the 

measurement. Entering AUTO sets the optimum value automatically so that the measurement is 

completed when the transition from peak to base is started by the pulse output channel which starts 

the transition at first.

Integration Time:

•Mode: ADC operation mode TIME or PLC.

•Factor: Coefficient for the reference value of the integration time.

Pulse Averaging Count:

•Count: Number of pulsed measurements for averaging to get one measurement data. Not effective 

for HRSMU, MPSMU, and HPSMU. 

The Integration Time and Count settings are automatically set to the same settings on the A/D 

Converter & Integration Time Setup dialog box.

Pulse Channels:

•Pulse Delay Time: Delay time from the beginning of the pulse period to the beginning of the 

transition from base to peak. This value must be 0 for HRSMU, MPSMU, and HPSMU.

•Width Pulse width. The value must be the same for HRSMU, MPSMU, and HPSMU.

•Base: Pulse base value



Module 3

Classic Test Environment

3-37

To Set User Functions

Data calculation

-Measurement data/source data

-Built-in function, etc.

Function Setup

Click the Function Setup tab to display the User Function/Analysis Function setup screen.  The user 

functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of the Data 

Display window.  Up to 20 functions can be set.

Name: Function name

Unit: Unit of the function

Definition: Definition of the function.  The following identifiers can be used.

-Variables for the measurement/output data used in this test

-Functions defined in the above lines

-Local variables passed from the application test that calls this test as a component

-Built-in functions and global variables

For details, see online help or User’s Guide.
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To Set Data Display

Specify X axis and Y axes

Select variables to list

Display Setup

Click the Display Setup tab to display the display setup screen.

The X-Y Graph area is used to set the X axis and Y axes of the X-Y Graph Plot area in the Data 

Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed in the List Display area of the Data Display 

window.  Up to 20 variables can be set.

For example, following variables are set for the Class Exercise.

Vbe, Ic, Ib, Vh, Ih
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Class Exercise

Define test setup and perform test.

1. Click Multi Channel I/V Sweep icon and open setup 

editor.

2. Define test setup as shown in the previous pages.

3. Save it as Trng Multi.

4. Connect devices (NPN Bipolar Transistor and Red 

Miniature LED) as shown in next several pages, and 

perform test.

5. Export preset group, and import it. 

Note:
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SMU Triax Connection

Force Lines to Fixture 1,2,3,4 Ports

16442A/B Fixture

B1500A Rear View

SMU4

SMU3

SMU2

SMU1

CMU

GNDU

Force side Sense side

For the non-Kelvin connections, connect only the Force lines, leaving the Sense lines open.

Connect corresponding numbers.  On the 16442A/B fixture use the numbers labeled 1 - 6, not 1 - 3. 

Your B1500 may not match the SMU configuration shown in this figure.  Note that SMU1 is the 

module top of the GNDU (ground unit).  The SMU number become large from bottom to top as 

shown.

This is the SMU cable setup that will be used in the remainder of the class exercises.
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Jumper Leads - MOS transistor

1 2 3 4 5 6

7 8 9 10 11 12

13 14 15 16 17 18

2019 21 22 23 24

25

27

26

28

14

1528

1

F

G

3
F

G

4
F

G

5

F

G

6
F

G

2
F

G

1

SMU

21
VMU

21

VSU

F

S

GNDU

F
2

F
1

PGU

B

E
C

17: Emitter

16: Base

15: Collector

E B C

13 14

Shorter Lead

With the 16442A/B fixture, note that there are two SMU numbering schemes....3 SMUs with force 

and sense, or six SMUs with force only.   For this class example we will use the six (6) SMU scheme. 

Connect jumper leads as follows.

Terminal 13 : SMU1 F terminal

Terminal 14 : GNDU F terminal

Terminal 15 : SMU4 F terminal

Terminal 16 : SMU3 F terminal

Terminal 17 : SMU2 F terminal

Locate the bipolar transistor in the corner of the 28-pin dual in line socket as shown, with the flat side 

of the device facing toward you. Unlike the MOS device, the bipolar transistor is not static sensitive.  

You may touch the leads without using a ground strap.

Locate the LED between terminals 13 and 14 of the 28-pin dual in line socket.
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Measurement Result Example

This is a test result example displayed on the Data Display window. 

At the start of measurement, LED lights off.  Beyond the threshold voltage, the LED lights on. 
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I/V List Sweep

• To Define Channel Setup Screen

• To Set VAR1 Sweep Sources

• To Set Constant Output

• Other Measurement Setup Parameters

• To Set User/Analysis Functions

• Auto Analysis Setup

• To Set Data Display

This section explains how to perform I/V List sweep measurement. You will perform the above 

tasks to execute the I/V List sweep measurement. 

I/V List Sweep measurement is similar to I/V Sweep measurement.

Changes from the I/V Sweep are listed below.

•VAR1/VAR2 step output values are set by using a vector data. Vector data from a spreadsheet 

software, either tab separated  or comma separated can be copied to the Define vector data dialog 

box via the Windows clipboard. 

•All SMU installed in the B1500 can be set to VAR1.

•VAR1’ is not supported.

For more information, see online help or User’s Guide.
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SMU Channel Definition

-V name/I name

-V/I/VPULSE/IPULSE/COMMON

-VAR1/VAR2/CONST

SPGU Channel Definition

-V name

-VPULSE/ALWG

Setup Name

To Define Channel Setup Screen

Channel Setup

Variable name for reading time stamp data

Variable name for reading data index

Click the I/V List Sweep icon and open the setup editor.  Then click the Channel Setup tab to display 

the channel definition screen. 

1. Enter the Setup Name for the test setup to be defined on the setup editor.

2. List SMUs used for source output or measurement, and set the following parameters.

•Unit: SMU name or number.  The GNDU (ground unit) can be set instead of a SMU.

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), VPULSE (voltage pulse), IPULSE (current 

pulse), or COMMON (ground)

•Function: Source output function, VAR1 (primary sweep), VAR2 (secondary sweep), or CONST 

(constant).  Note: Up to 10 sources can be set to VAR1.

V Name and I Name are used to specify the parameters displayed on the Data Display window.  The 

display parameters are selected on the Display Setup tab screen. For the GNDU, 0 V is returned to 

the V variable and no data is returned to the I variable. 

To use the SPGU channels, click the Add SPGU button.  The SPGU channel setup row will appear.  

Then set the following parameters.

•Unit: SPGU name or number

•V Name: Variable name for the voltage data.  No data is returned to the variable.

•Mode: SPGU output mode.  VPULSE (voltage pulse) or ALWG (arbitrary linear waveform voltage) 

for all SPGU.

You can read measurement data by using the Data Display window. Parameters displayed on the 

window are selected on the Display Setup tab screen.  If you enter the variable name in the V Name, 

I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables as the 

display parameters.

Note:  The time stamp is the time the measurement is started for each measurement point.  The index 

is the index number for each measurement data.
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To Set VAR1 Sweep Sources

Grid button

Measurement Setup

The Measurement Setup tab screen is used to set the source output value and timing parameters.  

At the VAR1 area, you set VAR1 sweep sources.

•Unit: SMU name or number

•Source: Click the grid button to open the Define vector data dialog box. Enter the vector data of 

VAR1. For example, -500 m, 0, 500 m, 1, 1,05,1.1, 1.15, 1.2, 1.25, 1.3, 1.35, 1.4, 1.45, 1.5, 1.55, 1.6, 

1.65, 1.7, 1.75, 1.8, 1.85, 1.9, 1.95, 2, 2.5, and 3 V are set for the Vth-gmMax. Step voltages near the 

gmMax are set to 50 mV and others are set to 500 mV.

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value



Module 3

Classic Test Environment

3-46

To Set Constant Output

Measurement Setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), VPULSE (voltage pulse), IPULSE (current 

pulse), or COMMON (ground)

•Source: SMU output value. For example, Vdrain is set to 100 mV for the Vth-gmMax.

•Compliance: SMU compliance value
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Other Measurement Setup Parameters

Measurement Setup

For the functions of Timing, Sweep status, Range, ADC/Integ, Advanced, SPGU Pulse Setup, and 

SPGU ALWG Setup, see the following pages respectively in the I/V Sweep section of this module.

•To Set Timing Parameters

•To Set Sweep Abort Function

•To Set Ranging Mode

•To Set ADC/Integration Time

•Advanced Setup

•SPGU Pulse Setup

•SPGU ALWG Setup
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To Set User/Analysis Functions

Data calculation

-Measurement data/source data

-Built-in function, etc.

Function Setup

Click the Function Setup tab to display the User Function/Analysis Function setup screen.  The 

user/analysis functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of 

the Data Display window.  Up to 20 functions can be set.

Name: Function name

Unit: Unit of the function

Definition: Definition of the function.  The following identifiers can be used.

-Variables for the measurement/output data used in this test

-Functions defined in the above lines

-Local variables passed from the application test that calls this test as a component

-Built-in functions and global variables

For details, see online help or User’s Guide.

For example, following user/analysis functions are set for the Vth-gmMax.

<Name>  <Unit>  <Definition>

Gm          S        diff(Idrain,Vgate)

gmMax    S         max(gm)

Von         V         @L1X

Vth          V         Von-(Vdrain/2)

For built-in functions, see online help or User’s Guide.
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Auto Analysis Setup

Auto Analysis Setup

Click the Auto Analysis Setup tab to display the Auto Analysis setup screen. This screen is used to 

set the automatic analysis function. When a measurement finishes, the function automatically draws 

lines, a marker, or both on the X-Y Graph of the Data Display window.

You can set up two lines and one marker for the automatic analysis function. 

In the Line 1 and Line 2 areas, you can set up the lines to be drawn. 

In the Marker area, you can set up the marker.

For details, see online help or User’s Guide.

For example, the Line 1 is set for the Vth-gmMax.

Type: Tangent

Axis: Y1

First Point: Data Condition

Condition: gm = gmMax
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To Set Data Display

Specify X axis and Y axes

Select variables to list

Select parameters to list

Display Setup

Click the Display Setup tab to display the display setup screen.

The X-Y Graph area is used to set the X axis and Y axes of the X-Y Graph Plot area in the Data Display 

window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

For example, following axes are set  for the Vth-gmMax.

<Name> <Sharing> <Scale>  <Min>     <Max>

X     Vgate                       Linear    -500 mV   3 V

Y1   Idrain     (None)       Linear    -1 mA     10 mA

Y2   gm         (None)       Linear      0 S         10 mS

The List Display area selects the variables to be listed in the List Display area of the Data Display window.  Up 

to 20 variables can be set.

For example, following variables are set for the Vth-gmMax.

Vgate, Vsource, Vdrain, Vsubs, Idrain, gm

The Parameters area selects the variables to be listed in the Parameters area of the Data Display window.  Up to 

20 parameters can be set.

For example, following parameters are set for the Vth-gmMax.

gmMax, Vth
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Class Exercise

Define test setup and perform test.

1. Click I/V List Sweep icon and open setup editor.

2. Define test setup as shown in the previous pages.

3. Save it as Trng List.

4. Connect an N-ch MOSFET as shown in next several 

pages, and perform test.

5. Export preset group, and import it. 

Note:
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SMU Triax Connection

Force Lines to Fixture 1,2,3,4 Ports

16442A/B Fixture

B1500A Rear View

SMU4

SMU3

SMU2

SMU1

CMU

GNDU

Force side Sense side

For the non-Kelvin connections, connect only the Force lines, leaving the Sense lines open.

Connect corresponding numbers.  On the 16442A/B fixture use the numbers labeled 1 - 6, not 1 - 3. 

Your B1500 may not match the SMU configuration shown in this figure.  Note that SMU1 is the 

module top of the GNDU (ground unit).  The SMU number become large from bottom to top as 

shown.

This is the SMU cable setup that will be used in the remainder of the class exercises.
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Jumper Leads - MOS transistor

16088-60002

Dual in line package

(28 pin)
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With the 16442A/B fixture, note that there are two SMU numbering schemes....3 SMUs with force 

and sense, or six SMUs with force only.   For this class example we will use the six (6) SMU scheme.  

On older fixtures, this scheme is shown in light blue lettering. In newer fixtures, this scheme is 

shown in white reverse background lettering.
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Device Orientation and Insertion

Insert the transistor last, 

AFTER connecting the 

cables and leads.  Remove 

the shorting wire after 

insertion in the socket.

14

15

1

1: Substrate

2: Source

3: Gate

4: Drain

23

G

S D

Sub

The MOS FET leads must be re-arranged into a straight line as shown.

IMPORTANT:

The MOS FET is highly sensitive to electrostatic damage.  Touching the bare leads can definitely 

destroy the device.  The device comes with a special shorting wire attached.  Bend the leads the way 

you want, insert the device in the socket, and then remove the shorting wire.  The wire has a tab.  Just 

grab the tab and pull straight out.  The wire will spiral out as you pull.  

Once the shorting wire is removed, you must use a wrist strap when handling the device.
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Measurement Result Example

This is a test result example displayed on the Data Display window. 
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I/V-t Sampling Measurement

• To Define Channels and Variables

• To Set Sampling Parameters

• To Set Stop Condition

• To Set SMU Outputs (CONST)

• Range/ADC/Advanced/SPGU

• To Set User Functions/

Analysis Functions

• To Set Data Display

This section explains how to perform I/V-t sampling measurement.  You will perform the above tasks 

to execute the I/V-t sampling measurement.
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Channel Setup

GNDU

SMU1

To Define Channels and Variables

SMU Channel Definition

-V name/I name

-I/V/COMMON

-CONST

SPGU Channel Definition

-V name

-VPULSE/ALWG

Setup Name

Variable name for time stamp data

Variable name for data index

Click the I/V-t Sampling icon and open the setup editor.  Then click the Channel Setup tab to display 

the channel definition screen. 

1. Enter the Setup Name for the test setup to be defined on the setup editor.

2. List SMUs used for source output or measurement, and set the following parameters.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Time Stamp Name: Variable name for the time stamp data

•Index Name: Variable name for the data index

V Name and I Name are used to specify the parameters displayed on the Data Display window.  The 

display parameters are selected on the Display Setup tab screen. For the GNDU, 0 V is returned to 

the V variable and no data is returned to the I variable. 

To use the SPGU channels, click the Add SPGU button.  The SPGU channel setup row will appear.  

Then set the following parameters.

•Unit: SPGU name or number

•V Name: Variable name for the voltage data.  No data is returned to the variable.

•Mode: SPGU output mode.  VPULSE (voltage pulse) or ALWG (arbitrary linear waveform voltage) 

for all SPGU.

You can read measurement data by using the Data Display window. Parameters displayed on the 

window are selected on the Display Setup tab screen.  If you enter the variable name in the V Name, 

I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables as the 

display parameters.

Note:  The time stamp is the time the measurement is started for each measurement point.  The index 

is the index number for each measurement data.
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To Set Sampling Parameters

Measurement Setup

Hold time

Measurement time

Sampling interval

Trigger

Click the Measurement Setup tab to display the setup screen for the sampling timing parameters and 

the SMU source output parameters.  At the Sampling Parameter area, you set the following sampling 

timing parameters.

Linear/Log:

Sampling mode. LINEAR for linear sampling. LOG10, LOG25, LOG50, LOG100, LOG250, or 

LOG500 for logarithmic sampling.  For the logarithmic sampling, the number after LOG indicates 

the number of measurement data in a decade. For example, LOG10 mode is used to get 10 

data/decade.

For the log sampling, the B1500 holds only the data that can be plotted on the log scale in the same 

distance as close as possible. Only the held data is counted in the number of measurement result data.

For the linear sampling with Interval < 2 ms, if the total measurement time runs over the specified 

time Interval × No of Samples, the sampling measurement will be stopped even if the number of 

measurement result data is less than the specified No of Samples.

Interval:

Interval of the sampling, in seconds. 0.002 to 65.535 s, 0.001 s resolution.

Interval < 0.002 s in 0.00001 s resolution is also available for the linear sampling.  It must satisfy the 

following formula.  For details, see online help or User’s Guide.

Interval ≥ 0.0001 + 0.00002 × (number of measurement channels-1)
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To Set Sampling Parameters

Measurement Setup

Hold time

Measurement time

Sampling interval

Trigger

No of Samples:

Number of samples. Integer. 1 to the following value.

For linear: 100001 / (number of measurement channels)

For logarithmic: 1 + (number of data for 11 decades)

Total Sampling Time:

This field just displays the total sampling time that is the time from the measurement start time for 

the first point to the end of sampling measurement. It does not include the hold time.

Total Sampling Time = Interval × No of Samples

Output Sequence:

Source output sequence. SIMULTANEOUS or SEQUENTIAL. 

Hold Time:

Time since the Source value output until the first sampling point, in seconds. 0 to 655.35 s, resolution 

0.01 s.

The following values are also available for Interval < 0.002 s.  |Hold Time| will be the time since the 

sampling start until the Source value output.

-0.09 to -0.0001 s, resolution 0.0001 s.

Base Hold Time:

Hold time of the Base value output until the Source value output, in seconds. 0 to 655.35 s, resolution 

0.01 s.
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To Set Stop Condition

Measurement Setup

Hold time

Measurement time

Sampling interval

Trigger

The stop condition is defined by using the Stop Condition fields on the Measurement Setup screen.  

This function stops the measurement as shown below.

1. Compares the value of parameter set to the Name field and the value defined in the Threshold 

field.

2. Counts how many times the selected Event occurs.

3. When the count reaches the value defined in the No. of Events field, sampling is stopped 

immediately.
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To Set SMU Outputs (CONST)

Measurement Setup

SMU constant output setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Base and Source: SMU output value

•Compliance: SMU compliance value

Base value is available for all output channels for the SIMULTANEOUS mode and the last source 

channel for the SEQUENTIAL mode.
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Range/ADC/Advanced/SPGU Setup

Measurement Setup

For the Range, ADC/Integ, Advanced, SPGU Pulse Setup, and SPGU ALWG Setup buttons, see the 

following pages respectively in the I/V Sweep section of this module.

•To Set Ranging Mode

•To Set ADC/Integration Time

•Advanced Setup

•SPGU Pulse Setup

•SPGU ALWG Setup

Note:

If the range changing occurs during measurement, the SMU may not complete measurement within 

the sampling interval.  So use FIXED range if the sampling interval is top priority and the 

resolution/sensitivity is second priority.
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To Set User Functions/Analysis Functions

Function Setup

Data calculation

-Measurement data/source data

-Built-in function, etc.

Data calculation

-Measurement data/source data

-Read out function

-Built-in function, etc.

Click the Function Setup tab to display the User Function/Analysis Function setup screen.

The user functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of the Data 

Display window.  Up to 20 functions can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

For details, see online help or User’s Guide.

The analysis functions can be displayed on the Parameters area of the Data Display window.  Up to 20 functions 

can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

•Read out functions

For details, see online help or User’s Guide.
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To Set Data Display

Display Setup

Specify X axis and Y axis

Select parameters to display

Select variables to list

Click the Display Setup tab to display the display setup screen. The X-Y Graph area is used to set 

the X axis and Y axis of the X-Y Graph Plot area in the Data Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed in the List Display area of the Data Display 

window.  Up to 20 variables can be set.

The Parameters area selects the variables to be listed in the Parameters area of the Data Display 

window.  Up to 20 parameters can be set.



Module 3

Classic Test Environment

3-65

Class Exercise

Define test setup and perform test.

1. Click I/V-t Sampling icon and open setup editor.

2. Define test setup as shown in the previous pages.

3. Save it as Trng Sampling.

4. Connect device (capacitance), and perform test.

5. Export preset group, and import it. 

GNDU

SMU1

Note:
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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C-V Sweep Measurement

• To Define Channels and Variables

• To Set Sweep Source

• To Set Signal Source

• To Set Measurement Timing and Abort Function

• To Set SMU Outputs (CONST)

• Range/Advanced

• To Set User Functions/
Analysis Functions

• To Set Data Display

• To Perform Compensation
and Correction

This section explains how to perform C-V sweep measurement.  You will perform the above tasks to 

execute the C-V sweep measurement.
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Channel Setup

To Define Channels and Variables

Setup Name

Channel Definition

-CMU/SMU

-V name/I name

-I/V/COMMON

Variable name for time stamp data

Variable name for data index

SMU1

SMU2

CML

CMH

Click the C-V Sweep icon and open the setup editor.  Then click the Channel Setup tab to display the 

channel definition screen. 

•Enter the Setup Name for the test setup to be defined on the setup editor.

•List units used for source output or measurement, and set the following parameters.

•Unit: MFCMU/SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Function: CONST or VAR1

•Time Stamp Name: Variable name for the time stamp data

•Index Name: Variable name for the data index

You can read measurement data by using the Data Display window. Parameters displayed on the 

window are selected on the Display Setup tab screen.  If you enter the variable name in the V Name, 

I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables as the 

display parameters.

Note:  The time stamp is the time the measurement is started for each measurement point.  The index 

is the index number for each measurement data.
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To Set Sweep Source

Measurement Setup

CV sweep

Start

Stop

Step

The Measurement Setup tab screen is used to set the source output and timing parameters.  

At the C-V(VAR1) area, you set the DC bias output of the MFCMU.

•V Name: Variable name of the MFCMU output

•Model: MFCMU measurement mode. Primary and secondary measurement parameters. 

•(C) Name: Variable name of the primary measurement parameter 

•(G) Name: Variable name of the secondary measurement parameter

•Direction: Sweep direction, single (start to stop) or double (start to stop to start)

•Linear/Log: Sweep output, LINEAR, LOG10, LOG25, or LOG50. where the number following 

LOG means the number of sweep points in one decade.

•Start: Source output start value

•Stop: Source output stop value

•Step: Source output incremental step value

•Compliance: Only for SMU. Compliance value. Enter the current limit value for the voltage source, 

or the voltage limit value for the current source.

•No of Step: Number of sweep steps
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To Set Signal Source

Measurement Setup

At the Signal Source area, you set the MFCMU output frequency and oscillator level.

•Frequency List: MFCMU output frequency

•F Name: Variable name of MFCMU output frequency

•AC Level: MFCMU oscillator level, 10 mV to 250 mV, 1 mV resolution
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To Set Meas. Timing and Abort Function

Measurement Setup

Integration time (AUTO or PLC)

Timing parameters

Sweep abort function

Hold time

Delay time

Measurement time

Trigger

CONTINUE AT ANY

STOP AT ANY 

ABNORMAL

-Range overflow

-MFCMU error

-SMU compliance

-SMU oscillation

At the Integration Time area, you set the integration time of the impedance measurement by the MFCMU.

•Mode: AUTO or PLC.  Rule to decide the integration time.  For details, see online help or User’s Guide.

•Factor: Coefficient for the reference value of the integration time.

At the Timing area, you set the source output and measurement timing.

•Hold: Source output hold time. Time after the measurement trigger until starting delay time.

•Delay: Measurement start delay time. Time after the hold time until starting measurement.

The Sweep [ ] status field sets the sweep abort function.

When this field is CONTINUE AT ANY, the sweep measurement is not aborted.

When this field is STOP AT ANY ABNORMAL, the sweep measurement will be aborted when one of the 

following conditions is detected.

•Measurement range overflow

•MFCMU error

•SMU compliance

•SMU oscillation
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To Set CONST Outputs

Measurement Setup

SMU output setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Source: SMU output value

•Compliance: SMU compliance value
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Range Setup for C-V Sweep

Measurement Setup

The Range button opens the Range Setup dialog box.  The dialog box is used to set the measurement ranging 
operation.

CMU Measurement Range:

•Unit: CMU name or number

•Mode: Ranging mode, AUTO or FIXED

•Range: Measurement range.  This field is effective when Mode=FIXED.
Available values are 50 ohm, 100 ohm to 300 kohm (=<200 kHz), 100 ohm to 30 kohm (=<2 MHz), and 100 
ohm to 3 kohm (=<5 MHz) in 1, 3 step

SMU Measurement Range:

•Unit: SMU name or number

•Name: Variable name for the measurement data

•Mode: Ranging mode, AUTO, LIMITED, or FIXED

•Range: Range value

•Range Change Rule: BY FULL RANGE, GO UP AHEAD, or UP AND DOWN AHEAD

•Rate: Value used for range changing.  See the following formula.

For the AUTO or LIMITED, SMU automatically selects the minimum range that covers the measurement value, 
and performs the measurement by using the range.  For the limited auto ranging, the instrument does not use the 
range lower than the specified range value.  For example, if you select the 100 nA limited auto ranging, the 
instrument never uses the 10 nA range and below. 

BY FULL RANGE performs normal auto ranging operation.

For the GO UP AHEAD and UP AND DOWN AHEAD rules, specify the Rate value, 11 to 100, which fixes the 
boundary of the ranging. The ranging occurs when the measurement data goes across the boundary values shown 
below.

go up boundary = present measurement range × Rate / 100

go down boundary = present measurement range × Rate / 1000

The go down boundary is available only for the UP AND DOWN AHEAD rule.
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ADC & Integration Time for C-V Sweep

Measurement Setup

The ADC/Integ button opens the A/D Converter & Integration Time Setup dialog box.  The dialog 

box is used to select the ADC for each SMU and set the integration time for each ADC (high 

resolution or high speed). 

A/D Converter:

•Unit: SMU name or number

•Name: Variable name of the measurement data

•ADC: ADC type, HR ADC (high resolution) or HS ADC (high speed)

•Measurement: Compliance side measurement or Force and Compliance sides measurement.

HR ADC is not available for HCSMU, HVSMU, and the measurement which uses SMU pulse.

Force and Compliance sides measurement is not available for HRSMU, MPSMU, and HPSMU.

Integration Time:

•Mode: ADC operation mode

AUTO, MANUAL, or PLC for HR ADC

AUTO, MANUAL, PLC, or TIME for HS ADC

•Factor: Coefficient for the reference value of the integration time.

•Auto Zero: Auto Zero function ON or OFF.  For HR ADC.
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Advanced Setup for C-V Sweep

Measurement Setup

The Advanced button opens the Advanced Setup dialog box used to set the following functions.

AC Level/DC Bias Monitor Settings:

Defines the variables for the AC level data and the DC bias data monitored by the MFCMU while 

the capacitance measurement is performed.

Channel Settings:

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Series R: SMU series resistor NONE or 1MOHM (1000000 ohm)

•SMU Filter: SMU filter ON or OFF

Wait Time Control:

•Factor: Coefficient for the reference value of the wait time.  For details, see online help or User’s 

Guide.

After Measurement Settings:

•Bias Hold after Measurement: Bias hold function ON or OFF.

•Output Value after Measurement: Source output value after measurement.  START (sweep start 

value) or STOP (sweep stop value)

Semiconductor Relays (16440A SMU/PG Selector):

•CH1: Default or PGU OPEN

•CH3: Default or PGU OPEN

The fields define the selector channel’s switch condition during the measurement.  Default is the 

setting defined on the SMU/PG Selector screen of the Configuration window.
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To Set User Functions/Analysis Functions

Function Setup

Data calculation

-Measurement data/source data

-Built-in function, etc.

Data calculation

-Measurement data/source data

-Read out function

-Built-in function, etc.

Click the Function Setup tab to display the User Function/Analysis Function setup screen.

The user functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of the 

Data Display window.  Up to 20 functions can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

For details, see online help or User’s Guide.

The analysis functions can be displayed on the Parameters area of the Data Display window.  Up to 

20 functions can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

•Read out functions

For details, see online help or User’s Guide.
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To Set Data Display

Display Setup

Specify X axis and Y axis

Select parameters to display

Select variables to list

Click the Display Setup tab to display the display setup screen. The X-Y Graph area is used to set 

the X axis and Y axis of the X-Y Graph Plot area in the Data Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed in the List Display area of the Data Display 

window.  Up to 20 variables can be set.

The Parameters area selects the variables to be listed in the Parameters area of the Data Display 

window.  Up to 20 parameters can be set.
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Calibration button

Advanced Options…

Calibration

To Perform Compensation and Correction

The MFCMU is equipped with the error correction function used to realize accurate impedance 

measurements. The correction function minimizes the effects of the error elements in the extension 

cables and the DUT interface such as manipulator and probe card.

•Phase compensation: Corrects phase error caused by extending measurement cables.

•Open correction: Corrects for stray admittance. Effective for high impedance measurements.

•Short correction: Corrects for residual impedance. Effective for low impedance measurements.

•Load correction: Corrects any error by using the working standard (load standard).

Click the Calibration button to open the Calibration window.  And click the CMU calibration tab on 

the window to perform the compensation and correction data measurement.

•To measure the phase compensation data, open the measurement terminals at the end of the device 

side and click the Measure... button.

•To measure the open correction data, open the measurement terminals at the end of the device side 

and click the Measure... button.

•To measure the short correction data, connect the measurement terminals together at the end of the 

device side and click the Measure... button.

•To measure the load correction data, connect the load standard that has the reference value or 

calibration value. Then, click the Measure... button.

For details of the error correction (CMU calibration) and the Advanced Options, see online help or 

User’s Guide.  The Advanced Options window is used for the compensation/correction data 

measurement setup.
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Class Exercise

Define test setup and perform test.

1. Click C-V Sweep icon and open setup editor.

2. Define test setup as shown in previous pages. And 

save it as Trng CV.

3. Open measurement terminals, and perform phase 

compensation and open correction.

4. Connect device, and perform test.

5. Export preset group, and import it. 

SMU1

SMU2

CML

CMH

Note:
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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Switching Matrix Control

• To Define Switch Setup

This section explains how to define the switch setup for B2200/E5250 Switching Matrix.  Not 

available for B1505A.

Note: Standard revision of EasyEXPERT cannot support the E5250. The E5250 control is optional 

function of B1540A-002/B1541A-002.

Note: EasyEXPERT supports the E5250A installed with the E5252A matrix card.
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To Define Switch Setup

-Open All

-Switch Setup

-Close Range

-Open Output

-Open Range

-Open Input

Setup Name

-BBM

-MBBR

To specify Input Port

To specify Output Channel

This setup screen is used to create the relay control setup (switch setup) for Agilent 

B2200A/B2201A/E5250A Switching Matrix.

To send the switch setup to B2200/E5250, click the Single button.  Before doing this, you have to 

establish the GPIB connection to B2200/E5250 by using the Switching Matrix tab screen of the 

Configuration window and B1500A is set to system controller.  See Module 8.

This screen provides the following GUI.

Add:  Adds a setup row for relay connection.

Delete:  Deletes the setup row.  To select the setup row, use the left radio button.

Up:  Moves the selected setup row upward.

Down:  Moves the selected setup row downward.  The setup row provides the following entry fields.

Operation:  Relay control operation.  Open All, Switch Setup, Close Range, Open Output, Open 

Range, or Open Input.  See the next page.

Input:  B2200/E5250 input port number or label.  Available for the Switch Setup, Close Range, and 

Open Input operations.

Outputs:  B2200/E5250 output channel number or label.  Four entry fields are available for the 

Switch Setup and Open Output operations to specify the output channels.  Two entry fields are 

available for the Close Range and Open Range operations to specify the range of output channels.

Rule:  Relay connection rule.  BBM or MBBR.

•BBM: Breaks the previous connection and then makes the new connection for the specified outputs.

•MBBR: Makes the new connection and then breaks the previous connection for the specified 

outputs.
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Operation and number of Outputs

Opens the relays connected to the specified input port.

Opens the relays connected to the specified output 
channels.  They are between two channels given by 
the Outputs fields.

Opens the relays connected to the specified output 
channels.  Up to four output channels can be specified 
at once.

Makes the connection from the specified input port to 
the specified output channels.  They are between two 
channels given by the Outputs fields.

Makes the connection from the specified input port to 
the specified output channels.  Up to four output 
channels can be specified at once.

Opens all relays.

Description

0

2

4

2

4

0

Number of 

Outputs

Open Input

Open Range

Open Output

Close Range

Switch Setup

Open All

Operation

Note:
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Class Exercise

Define switch setup and send it to B2200/E5250.

1. Click Switching Matrix Control icon and open setup 

editor.

2. Define switch setup as you want. And save it as Trng 

Switch.

3. If B2200/E5250 is available, establish the GPIB 

connection between B1500A (must be set to system 

controller) and B2200/E5250, and apply your switch 

setup.

Note:
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Direct Control

• To Define Channels and Variables

• To Set Measurement Conditions

• Advanced Setup

• To Set User Functions

• To Set Data Display

This section explains how to use Direct Control to perform various measurements (e.g. C-f 

measurement, Quasi-Static C-V measurement) using Agilent FLEX commands.
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Channel Setup

To Define Channels and Variables

Setup Name

CMU Channel Definition: V Name

SMU Channel Definition: V Name and I Name

SPGU Channel Definition: No variable

Variable name for time stamp data

Additional  Data Variables

Variable name for index data

Click the Direct Control icon and open the setup editor.  Then click the Channel Setup tab to display 

the channel definition screen. 

1. Enter the Setup Name for the test setup to be defined on the setup editor.

2. List channels used for source output or measurement, and set the following parameters.

•Unit: Name or number of the channel

•V Name: Variable name for the voltage measurement or source data.  For SMU and CMU.

•I Name: Variable name for the current measurement or source data.  For SMU only.

V Name and I Name are used to specify the parameters displayed on the Data Display window.  The 

display parameters are selected on the Display Setup tab screen.

You can read measurement data by using the Data Display window. Parameters displayed on the 

window are selected on the Display Setup tab screen.  If you enter the variable name in the V Name, 

I Name, Additional Variable Name, Time Stamp Name, and/or Index Name entry fields, you can 

choose the variables as the display parameters.

Note:  The time stamp is the time the measurement is started for each measurement point.  The index 

is the index number for each measurement data.

For example, the Trng C-f test setup has defined the following additional variables to monitor.

<Unit>          <Type>                                    <Name>

CMU1:MF    CMU Re(Y)                                 G

CMU1:MF    CMU Im(Y)                                  B

CMU1:MF    CMU DC Bias Monitor Data      DcMon

CMU1:MF    CMU AC Level Monitor Data     AcMon

CMU1:MF    CMU Frequency                         Freq
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To Set Measurement Conditions

Command Setup

Measurement Setup

The Measurement Setup tab screen is used to set Agilent FLEX commands for measurement.  

For example, following FLEX commands are set for the C-f Sweep Measurement.

<Command> <Arguments>

1    FMT                  13,1

2    TSC                  1

3    MM                   22,CMU1:MF

4    WTFC               0,0

5    WMFC              1

6    WFC                 CMU1:MF,4,1e3,5e6,50

7    ACT                  0,2

8    ACV                 CMU1:MF,30e-3

9    DCV                 CMU1:MF,1

10  RC                    CMU1:MF,0

11  TSR

12  XE

13  ReadDataBuffer

See B1500 Series Programming Guide for more details about FLEX commands.
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Advanced Setup

Measurement Setup

Advanced Setup

The Advanced button opens the Advanced Setup dialog box.  The dialog box is used to set the option 

setting, the SMU filter and SMU series resistor settings, the after measurement settings, and the 

16440A selector semiconductor relay setting.

Options:

•Primary Setup: ON or OFF.

If Primary Setup=ON, the primary setup is applied to the instrument when the Direct Control test is 

started.  For the primary setup condition, see the online help or User’s Guide.

Channel Settings:

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Series R: SMU series resistor NONE or 1MOHM (1000000 ohm)

•SMU Filter: SMU filter ON or OFF

After Measurement Settings:

•Bias Hold after Measurement: Bias hold function ON or OFF.

Semiconductor Relays (16440A SMU/PG Selector):

•CH1: Default or PGU OPEN

•CH3: Default or PGU OPEN

The fields define the selector channel’s switch condition during the measurement.  Default is the 

setting defined on the SMU/PG Selector screen of the Configuration window.
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To Set User Functions

Function Setup

Click the Function Setup tab to display the User Function/Analysis Function setup screen.  The user 

functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of the Data 

Display window.  Up to 20 functions can be set.

Name: Function name

Unit: Unit of the function

Definition: Definition of the function.  The following identifiers can be used.

-Variables for the measurement/output data used in this test

-Functions defined in the above lines

-Local variables passed from the application test that calls this test as a component

-Built-in functions and global variables

For details, see online help or User’s Guide.

For example, following user functions are set for C-f Sweep Measurement.

<Name>  <Unit>  <Definition>

PI                         3.1415

ImY          S        compenImY(Freq,G,B)

ReY          S        compenReY(Freq,G,B) 

C              F         ImY/(2*PI*Freq)
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To Set Data Display

Specify X axis and Y axes.

Select variables to list

Display Setup

Click the Display Setup tab to display the display setup screen. The X-Y Graph area is used to set 

the X axis and Y axes of the X-Y Graph Plot area in the Data Display window.

•Name: Name of variable to plot on the axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

For example, following axes are set  for the C-f Sweep Measurement.

<Name>  <Scale>  <Min>    <Max>

X     Freq       Linear      1 kHz     5 MHz

Y1   C            Linear     -250 nF   500 nF

The List Display area selects the variables to be listed in the List Display area of the Data Display 

window.  Up to 20 variables can be set.

For example, following variables are set for the C-f Sweep Measurement.

Time, Freq, C, G, B
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Class Exercise

Define test setup and perform test.

1. Click Direct Control icon and open setup editor.

2. Define test setup as shown in the previous pages.

3. Save it as Trng C-f.

4. Connect a device (capacitance) as shown in next 

several pages, and perform test.

5. Export preset group, and import it. 

Note:
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16442A/B Fixture

B1500A Rear View

SMU4

SMU3

SMU2

SMU1

CMU

GNDU

Cable Connections

The following cables are required to perform this class exercise.

CMU cable (Agilent N1300A-001/002), 1 ea.

One side of the CMU cable forms the attachment used to join and fix it to the CMU.  And the other 

side provides four BNC connectors used to connect the fixture as shown.

Connect the cables between the B1500 and the test fixture as follows.

Hcur : PGU1 (red)

Hpot : PGU2 (orange)

Lcur : VSU1 (black)

Lpot : VSU2 (gray)
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Jumper Leads – Capacitance

0.1uF

This class exercise requires four jumper leads to connect the DUT.  Connect the jumper leads 

between the following terminals.

PGU1 : terminal 4

PGU2 : terminal 4

VSU1 : terminal 1

VSU2 : terminal 1
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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In This Module

• SMU Pulsed Sweep Measurement

• I/V-t Sampling Measurement

• Negative Hold Time for High Speed Sampling

• Auto Analysis

• SMU Filter

• Standby Function

• Bias Hold Function

There are too many measurement functions to conveniently cover in one module.  Ultra low current 

measurement and capacitance measurement are covered in separate modules.  

This module covers the key features listed above.
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SMU Pulsed Sweep Measurement

• Use PULSE mode for precise force/measure timing

• Use PULSE mode for repeatable high current 

measurements

� To eliminate heating during IV sweeps

� To avoid device damage

• Set the expected maximum measurement value to 

Compliance

• Multiple pulsed source/measurement channels are 

available for Tracer Test and Multi Channel I/V Sweep 

Classic Test

SMUs can be pulsed for precise force/measure timing, or to reduce heating of the device when 

forcing high currents.

The measurement unit performs measurement by using the compliance range.  It is the minimum 

range which covers the Compliance value.  The Compliance value should be the expected maximum 

measurement value or greater.
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VAR1

Primary

VAR2

Secondary

SMU Pulse Mode

Multiple pulsed channels are available for Tracer Test and 

Multi Channel I/V Sweep Classic Test

VAR2

Secondary

Tracer Test and Multi Channel I/V Sweep Classic Test support multiple pulsed channels. VAR1, 

VAR2, and CONST can be pulsed.

For the other Classic Test such as I/V Sweep and I/V List Sweep, only one SMU can pulse while 

another follows.  VAR1, VAR1’, VAR2, or CONST may be pulsed.
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Pulse Setup Parameters

Time

Hold time

Pulse period

Measurement time

Pulse width

Voltage or current

Hold time

Pulse period

Measurement delay time Measurement time

Peak value

Base value

Previous value

Pulse widthDelay time

2. Using multiple pulse output channels

1. Using one pulse output channel

Voltage or current

Peak value

Base value

Previous value

When you select VPULSE or IPULSE on the Channel Setup screen, the Pulse button is available for 

the Measurement Setup screen.  Click the Pulse button to open the Pulse Setup dialog box, and set 

the pulse setup parameters on the dialog box. 

For the test which supports one SMU pulse,  use the SMU Pulse area on the Measurement Setup 

screen to set the pulse setup parameters.

Pulse period may be adjusted from 5 ms to 5 s in 100 us steps.  Pulse period is measured from the 

base value to peak value transition, between two consecutive pulses.

Pulse width may be adjusted from 0.05 ms to 2 s in 2 us steps for HCSMU or 0.5 ms to 2 s in 2 us 

steps for the other modules.  Pulse width is measured between the transition from base value to peak 

value and the transition from peak value to base value.
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• Use the HPSMU or GNDU as the current return 

path

• Use Kelvin connections (must use on GNDU)

• Use 16493L GNDU cable for the GNDU connection

Sense

Force

HRSMU

or

MPSMU

HPSMU   1.0 A

GNDU     4.2 A

Hints on Pulsing the HPSMU – B1500A

Example for B1500A:

Force

Sense

The 1 A SMU (HPSMU) cannot use another MPSMU or HRSMU as the current return.  It must be 

used with the other HPSMU or the GNDU that can sink enough current.  The GNDU is the unit that 

you can use without defining in the Channel Setup.

The GNDU can sink up to 4.2 A, and it is designed for the Kelvin connection.  The force and sense 

lines must be shorted near the DUT.

For the connection of the GNDU, do not use the normal triaxial cable.  The GNDU is rated for up to 

4.2 A, while the maximum current rating of the triaxial cable is 1 A.
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� You will observe a MOS FET family of curves 

� You will edit VAR1 from V mode to VPULSE mode

� You will learn how to properly define a "pulsed" algorithm

� Use the next several pages as you guide

� Get the IDVD setup

� Follow the instructions on the following pages

To Get Started:

Class Exercise

SMU Pulse Mode

You will setup a basic MOS family of curves without VPULSE.  Then change VAR1 to VPULSE.
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16442A/B Fixture

B1500A Rear View

SMU4

SMU3

SMU2

SMU1

CMU

GNDU

SMU Triax Connection

Force Lines to Fixture 1,2,3,4 Ports

This is the SMU cable setup that will be used in the remainder of the class exercises.

Connect the cables between the B1500 and test fixture as follows.

SMU1 : SMU1

SMU2 : SMU2

SMU3 : SMU3

SMU4 : SMU4
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Jumper Leads – MOS transistor

With the 16442A/B fixture, note that there are two SMU numbering schemes....3 SMUs with force 

and sense, or six SMUs with force only.   For this class example we will use the six (6) SMU scheme.  

On older fixtures, this scheme is shown in light blue lettering. In newer fixtures, this scheme is 

shown in white reverse background lettering.
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VPULSE 

Data Display Window

Make a measurement to verify the setup is correct.  You should see the above family of curves.  The 

algorithm is defaulted to standard staircase sweep on VAR1 (no pulsed SMU).
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Drain pulse

Enter new name before save

VPULSE 

Channel Setup

Switch VAR1 from V mode to VPULSE mode.  A new panel will pop up on the Measurement Setup.

Before saving this new setup, enter new name into the Setup Name field, then click the Save button.
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This box pops up 

only if VPULSE 

or IPULSE is set 

on Channel Setup.

Range and 

ADC/Integ

are disabled

Maximum measurement value

VPULSE 

Measurement Setup

Default pulse conditions for the Measurement Setup are shown here.  The base is 0, and the pulse 

duty cycle is 10 %.  These settings are OK for this class exercise.  Click the Single button to start a 

pulsed sweep measurement.

Range and ADC/Integ buttons are disabled for pulsed measurement.  The measurement range is 

always the compliance range.  And the integration time cannot be changed.

For example, if you change the Compliance value to 30 mA, the data beyond 30 mA cannot be 

measured.
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Interval

Hold Time

Starts sampling

Voltage or current

Channel 1 output

Voltage or current

Channel 2 output

Bias hold time

Measurement time

Source

Base

Source

: Measurement

Time

Time=0 (origin)

Time=Hold time + a Time=Hold time + Interval + b

a b

a, b : time from measurement start to integration start

I/V-t Sampling Measurement

B1500 supports the sampling measurement which performs the operation shown above.  

With the SEQUENTIAL output sequence, the source channels start to force the Source value 

sequentially.  Then the last source channel forces the Base value, and forces the Source value after 

the Bias hold time.  After the Hold time, the measurement channels start measurement sequentially, 

and repeat this in the specified interval if the measurement channel is ready to measure.  After the 

last sampling measurement, the source channels stop output sequentially.  

The order of source output is defined in the Channel Setup.  Top of the channels on the setup screen 

starts output first.  And the following channels start output sequentially.  After the measurement, the 

source channels stop output sequentially in the opposite order.

With the SIMULTANEOUS output sequence, the source channels start to force the Base value 

simultaneously.  And the channels force the Source value after the Base hold time.  After the Hold 

time, the measurement channels start measurement sequentially, and repeat this in the specified 

interval if the measurement channel is ready to measure.  After the last sampling measurement, the 

source channels stop output simultaneously.

For the measurement channels which use the high resolution A/D converter, the order of 

measurement is defined in the SMU Range Setup.  Top of the channels on the setup screen starts 

measurement first.  And the following channels start measurement sequentially.  For the 

measurement channels which use the high speed ADC, the channels start measurement 

simultaneously.
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� LINEAR

� Sampling interval: >= 2 ms

0.1 ms to 1.99 ms (limited)

� Number of samples: 1 to 100001

� LOG

� Sampling interval: >= 2 ms

� Number of samples: 1 + number of data for 11 decades

� Remaining data:

10/25/50/100/250/500 data are plotted into one decade 

of the log scale in the same distance

I/V-t Sampling Measurement

There are two sampling mode.  The linear sampling repeats the sampling in the specified interval 

until the number of measurement data reaches the specified number of samples.  High speed 

sampling is available if the following conditions are satisfied. The high speed sampling allows 

you to set the sampling interval 0.1 ms to 1.99 ms in 0.01 ms step.

1. Sampling mode is LINEAR

2. High speed ADC is used for all measurement channels

3. Interval >= 0.08 ms + 0.02 x (number of measurement channels) ms

The log sampling repeats the sampling in the specified interval and gathers the measurement data 

which can be plotted on the log scale in the same distance.   The sampling will be stopped when 

the number of measurement data reaches the specified number of samples.
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� Monitor the charging voltage of an RC circuit

� Learn LOG10 data interval

� Learn how to properly define a sampling algorithm

� Use the instrument setup as same as the SMU pulse exercise

� Connect the RC components as shown in the next page

� Get and run the RC-sampling-log setup

� Change the range or ADC and perform append measurement

To Get Started:

You will:

Class Exercise

Sampling Measurement
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0.1 uF

0.5 M

Jumper Leads – Sampling Exercise

The 0.5 M ohm and 0.1 uF values were chosen because these values are readily available, and they 

give a RC time constant suitable for observing 2 ms time steps. 
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10 data

10 data

10 data

Y data

X data

X + Y = 20

2 ms 200 s5 decades

Sampling Exercise – LOG10, 2 ms interval

RC Measurement

The RC-sampling-log setup is for the LOG10 sampling with 2 ms interval and 51 samples.

LOG10 sampling obtains 10 data in one decade.  And the data will be plotted on the log scale in the 

same distance.  However this rule cannot be kept at the beginning of sampling because of long 

interval.  

In this example, there are 10 data in each decade from 100 ms to 10 s, and 20 data in the remaining 

decades.  The first data will be near zero second.  See the List Display.
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10 data/decade

10 data/decade

10 data/decade

Sampling Exercise – LOG10, 2 ms interval
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Variable for time data

Sampling Exercise

Channel Setup
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High speed ADC 

FIXED range 

Sampling Exercise

Measurement Setup

Use the FIXED range and the high speed A/D converter to get 2 ms interval.

Change the range to AUTO.  Or change the ADC to the high resolution ADC.  And perform append 

measurement.  You may not get 2 ms interval at the beginning of sampling.
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-90 ms =< Hold Time =< -0.1 ms, 0.1 ms step

Bias starts  at 0 s 

Negative Hold Time 

Available for Interval < 2 ms

For the sampling measurement, the available hold time value is 0 to 655.35 s, in 10 ms step.

However, the negative hold time -90 ms to -0.1 ms, in 0.1 ms step is also available for the high speed 

sampling which the Interval is less than 2 ms.

This measurement result example is obtained by the setup shown in the following pages.
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Jumper Leads – Negative Hold Time
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Negative Hold Time 

Interval < 2 ms 

Current source 

Negative Hold Time

Channel and Measurement Setup
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GM max

*

Early Voltage

Vth

Isub max

Hands-off marker

and line fitting

Auto Analysis

Auto analysis automates the task of doing scalar calculation on swept data.  Computed parameters 

such as Vth or GMmax can be displayed in the Parameters area on the Data Display window.  The 

built-in user functions allow data to be plotted and analyzed according to any arbitrary formula.  The 

B1500 has built-in functions such as axis intercepts, logs, regression lines, area integration, max/min, 

and many more.  The ability to automatically extract important parameters such as threshold voltage 

without the need to manually manipulate screen cursors or markers is important in process 

development.
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Auto Analysis

Vth Example

Here we see a full-featured example of auto analysis.  GMmax and Vth are automatically calculated 

each time a measurement is made.  Even if you alter the analysis, say by moving the line, you can 

restore the original analysis by clicking the Apply button on the Auto Analysis Setup screen.

IMPORTANT!

Please note that formulas for auto analysis are not hard coded into the B1500.  You define the 

formulas, and so you can customize the method of performing the analysis.
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� Plot square root of the drain current  (SQRT Id)

� Plot rate of change of SQRT Id  (PEAK)

� Find Peak Value of the PEAK plot

� Drop down to the SQRT Id plot

� Draw a tangent line on the SQRT Id plot

� Read the X-intercept of the tangent line as Vth22

Vth Measurement

A Tedious Process Now Automated

In the previous example of graphically determining Vth, the above steps were automated.  There are 

other definitions of Vth which are less complex, but now you don't have to worry about complexity.  

The B1500 can perform the process without you having to interact with the screen.

Not only automation removes human error, but also it allows computer controlled analysis to proceed 

without interruption.
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� Make a MOS threshold voltage (Vth) measurement

� Observe how parameters for the analysis are defined

� Observe how the user functions and analysis functions are 

used in the analysis

� Use the standard MOS device and pin connections

� Get the GMMAX setup

� Make a measurement and turn the knob

� Click the Apply button to restore the analysis

To Get Started:

 You will:

Class Exercise

Auto Analysis

In this exercise you will observe how auto analysis works.  You will understand each setup screen 

required to implement an auto analysis process.
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Good

Continuous Curve

No Static Damage

BAD

Broken-Lumpy Curve

Severe Static Damage

*

*

Vth Measurement

Damaged MOS FET Device?

The class exercise uses a packaged MOS FET device which is very susceptible to static damage.  If 

the device has been handled or moved in and out of the socket a few times, you may see a BAD 

response as indicated above.  Replace the device with a new one.

At the wafer level, you can have the same problems.  Putting a charged probe with cables attached 

down on a gate junction can weaken or destroy the device.  Also, the B1500 offset cancel (zero 

cancel) sends signals down to the probes.  These voltages can damage a sensitive gate junction.



Module 4

Measurement Functions

4-29

Vth Measurement

Channel and Measurement Setup

Nothing new here.  This slide is included for completeness.  You will notice that these variables are 

heavily used on the Function Setup screen.
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Vth Measurement

Function Setup

Here are definitions for the Y1-axis plot (SQRT_ID) and the Y2-axis plot (PEAK).  

@L1X means the X-axis intercept of LINE 1.

@L1G^2 means the squared gradient value of LINE 1.  In this case, it is just calculating line 1 slope.  

It is squared to account for the fact that the Y1-axis is a square root.

Click Help > Agilent EasyEXPERT Help to open the online help.  And visit the Read Out Functions

page for all of these functions.
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Vth Measurement

Display Setup Page

VTH and BETA are values which will be displayed at the Parameters area on the Data Display 

window.  

These variables are defined in the Function Setup screen.
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Auto Analysis

Analysis Setup Page

This screen is the heart of auto analysis.  You define custom procedures for graphical analysis with 

fill-in-the-blank ease.  

(End of This Class Exercise)
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V/I DAC

Filter OFF

Filter ON

Time

Filter setting

SMU 

(V or I mode)

Force

Sense
Series Resistor

(1 M ohm)

SMU Filter

The filter is mounted on each SMU.  It assures clean source output with no spikes or overshooting.  

However, using a filter may increase the SMU settling time.  If measurement speed is top priority, set 

the SMU Filter OFF.
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SMU Filter: ON (add filter)

or OFF (no filter)

SMU Filter

To change the SMU filter setup, open the Advanced Setup window by clicking the Advanced button 

on the Measurement Setup screen.  And specify ON or OFF by using the SMU Filter pull down 

menu.

In the power on state, the Classic Test sets the SMU Filter to ON.
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Standby Function

Standby function sets any SMUs (except HRSMU with ASU) to specific output values and 

compliances before starting or after stopping measurement. Standby function is useful for power 

supplies of complicated device (eg. Smart TEG), defect analysis, and so on.

This slide shows the standby and measurement operation in the following setup. This example 

assumes that the channel setup is defined in the Standby Channel Definition as follows in the order, 

and the output value in the standby state is the same as the output value in the measurement state.

•SMU1: Voltage source, non-standby channel

•SMU2: Voltage Source, standby channel

•SMU3: Voltage Source, standby channel
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To Use Standby Function

Click the Standby Channel Definition button to open the Standby Channel Definition window.

Define Standby channels (Unit, Mode, Source, and Compliance).

Click the Standby ON button to set standby channel outputs. The Standby indicator will change from 

OFF to ON.
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CONST

VAR2

VAR2

CONST

Bias Hold   ON

Bias Hold   OFF

VAR1/VAR1’/CMU

VAR1/VAR1’/CMU

Source or Base value for Sampling

Stop or Start value

End of Single measurement

or

Start of next measurement

Stop value

O V

O V

O V

Bias Hold After Measurement

Bias hold function keeps bias output after a measurement is made.  For instance, the user may need 

to keep one or more SMUs on between measurements to bias up a Vcc pin of an IC.  Without this 

function, a user is forced to connect an external power supply. Now there is no need for extra 

supplies.

When this function is ON, the source channels apply the following value.

Constant source: Base value or Source value (I/V-t sampling)

Constant source: Source value (I/V Sweep or C-V Sweep)

VAR1/VAR1’ source: Start value or Stop value (I/V Sweep)

VAR2 source: Stop value (I/V Sweep)

CMU: Start value or Stop value (C-

V Sweep)
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� Perform Repeat Measurement

� Measure the LED I-V characteristics

� Monitor LED during Repeat Measurement

� Use the connection as same as the SMU pulse exercise

� Add an LED and jumper leads per following pages

� Get the LED setup

To Get Started:

You will:

Class Exercise

Bias Hold Function
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Shorter Lead

Jumper Leads – Bias Hold Exercise

Connect test leads as shown.  And add the LED between terminals 13 and 14 of the 28-pin dual in 

line socket.
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SMU1 Function to VAR1

Vh = 0 to 2.5 V

Bias Hold to ON

Output Value to STOP 

Bias Hold Exercise

Channel and Measurement Setup

Set the SMU1 Function to VAR1.  The VAR1 output 0 to 2.5 V is enough to light the LED.

Set the Bias Hold after Measurement field to ON to enable the bias hold function.  And set the 

Output Value after Measurement field to STOP.  This setup keeps 2.5 V output between sweep 

measurements.  So the LED can light between the measurements.
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Repeats three times

Click Run to start 

measurement

Repeat button

Bias Hold Exercise

Repeat Measurement Setup

Click Repeat button to open this window which is used to set and run the repeat measurement.

This example performs the LED I-V sweep measurement three times and then finishes the repeat 

measurement.
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LED lights on

LED lights off

Bias Hold Exercise

During the measurement, leave the fixture lid open.  And monitor the LED.  This measurement does 

not force dangerous voltage.  

At the start of measurement, LED lights off.  Beyond the threshold voltage, the LED lights on.  After 

the measurement, the LED keeps lighting until start of the next sweep measurement.  And this cycle 

is repeated until the end of the repeat measurement.  After the repeat measurement, the LED lights 

off.
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• To Open Application Test Definition 

• To Modify Test Definition 

• To Use Debug Tools

• To Use Built-in Functions

• To Add Data Display

• To Use Auto Analysis 

• To Use Test Setup Internal Variables

• To Use Auto Analysis twice (as Class Exercise)

• To Use Vector Data (as Class Exercise)

In This Module



Module 5

Modifying Application Test Definitions

5-3

Modification Overview

1. Open an application test definition to be modified

2. Open test definition editor

3. Save the definition as your test definition

4. Modify the definition as you like

5. Resave and close the definition

6. Export your test definition as your backup

This module explains the modification example using the Vth Const Id test definition.  After the 

modification, the new definition can perform the Vth Const Id measurement, display the Id-Vg curve, 

and additionally display the gm-Vg curve.
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To Open an Application Test Definition

Example: Select Vth Const Id as template

Click a test definition in Library list area, and click Select button to open the test definition.

For example, open Vth Const Id.
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To Open Test Definition Editor

Click Library>Open Definition of This Test…

Cancel

Define New Test…

Open Definition of This Test…

Delete Definition of This Test

Import Test Definition…

Export Test Definition…

Click Library and select Open Definition of This Test… to open the test definition editor.

The following pages show the modification example to display the gm-Vg curve given by the Vth

Const Id test result.
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To Save Definition As Your Definition

Save the definition as your definition (ex: Trng vth)

Test Definition editor

Save   Ctrl+S

Close

new categorynew test name

Create a new Category (ex. Exercise), and change the Test Name (ex. Trng Vth).

After changing the test name, save the test definition.  Saving the definition will change the window 

title to the new test name.  Window title will be changed from Vth Const Id to Trng Vth in this 

example.

In this example, the Trng Vth definition belongs to the Exercise category only.
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To Modify Test Definition

Change default values and add parameters (ex: Pcomp_d)

This area sets the 

properties of the 

specified parameter.

•Min

•Max

•Digits

•Resolution

•Unit

•Typical Values

•Symbols

Test Definition editor

On the Test Specification tab screen, you can add new parameters or change parameter settings.  

This example changes the default value of the Module parameters for the MOS FET class exercise 

typical setup and adds the Pcomp_d test parameter (drain terminal power compliance).

The Module parameter default values are changed as follows.  See the actual settings on the test 

definition editor.

Drain: SMU4

Gate: SMU3

Source: SMU2

Subs: SMU1

The Pcomp_d parameter is defined as follows.

Name=Pcomp_d, Type=Numeric, Default=1 mW, Description=Power compliance for drain terminal, 

Align=check, X=550, Y=120, Width=80, Ext=uncheck

Properties: Min=1 mW, Max=20 mW, Digits=4, Resolution=1 mW, Unit=W

For Align, X, Y, and Width values, consult the settings of the other parameters for the same terminal 

(ex. Drain). For example, Pcomp_d must be located between Vd and Subs entry fields (see 

application test screen on the main window).  So X and Width should be the same as the settings of 

Vd, and Y should be between 90 and 180 (see the actual settings of Vd and Subs on the test 

definition editor).

Typical Values… button opens a dialog box used to define the typical values used for the selections 

of the parameter value in the Application Test mode.  For example, set 2 mW to 20 mW in 2 mW

step for Pcomp_d.

Symbols… button opens a dialog box used to map a numeric value to a string.  For example, 

Value=1 and Symbol=ON are set, typing ON enters 1, and typing 1 enters ON.  The value must 

satisfy the Min, Max, Digits, and Resolution settings. The value and the symbol must be one by one.  

The definition is effective only for the parameter.
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To Modify Test Definition

Change or set test parameters (ex: Pcomp_d)

Test Definition editor

On the Test Contents tab screen, you can change the test execution flow (program flow), 

measurement conditions, display setup, and so on.

To add the Pcomp_d parameter to the measurement setup, click the Vth Const Id line in the program 

list.  And in the I/V Sweep setup editor, display the Measurement Setup tab screen.  And enter 

Pcomp_d to the Pwr Comp entry field.
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To Modify Test Definition

Change display setup and define external variables

Test Definition editor

External variable

Test setup internal variable

External variables must 

be defined before making 

the matching table.

On the Display Setup tab screen, you can change the graph scale Min/Max values or add/delete the 

list parameters.

This example makes the matching table between the External variables and the Measurement data.  

The measurement data can be referred outside the test setup via the external variable. 

Where, the measurement data means the variables used in the test setup.  And the external variables 

means the parameters defined in the Test Specification, the Local Variable Definition, or the Test 

Output’s Analysis Parameter Definition.

This example sets the matching table as follows.

Vth_constId external variable: Vth internal variable

GM_data external variable: gm internal variable

VG_data external variable: Vgate internal variable

ID_data external variable: Idrain internal variable

External variables must be defined before making the matching table.  In this example, the variables 

are defined in the Analysis Parameter Definition.  See the next page.
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To Modify Test Definition

Test Definition editor

Define Test Output and Analysis Parameters

This example defines the Test Output and the Analysis Parameters.

1. Display the Test Output screen.

2. Check the Define own Output Parameters.

3. Click the Define Analysis Parameters button.

4. Define the analysis parameters (ex. GM_data, VG_data, ID_data, and Vth_constID).

5. Define the X-Y Graph, List Display, and Parameters.

Note

External variables must be defined before making the matching table shown in the previous page.  In 

this example, the following parameters can be the external variables.

Parameters defined in the Test Specification

Variables defined in the Local Variable Definition

Variables defined in the Analysis Parameter Definition (this example)

Note

If this test definition is used in the other test definition, the analysis parameters can be referred 

outside this test definition.  This means that the analysis parameters can be the Measurement data in 

the External Variable Setup as shown in the previous page.
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To Modify Test Definition

Add local variable (ex: Yes for Message box)

Test Definition editor

Variable Yes is used in 

the message box.

Click Local Variables Definition line to display the local variable list.  And define variables.

This example defines Yes variable as follows.  This variable is used in a message box.  See the next 

page.

Name=Yes, Value=0, Description=User response
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To Modify Test Definition

Define Message box

Test Definition editor

This setup makes the OK button on 

the message box.

This message box 

asks you clicking the 

OK button to display 

the gm curve.

The value of the local 

variable Yes is set to 1 

from 0 by clicking the 

OK button.

This setup displays the message 

“To display the gm curve, click OK.”

on the message box.

Click the Message line in the program list.  And define the message box.

This example defines the message box that opens after the Vth Const Id measurement and displays a 

message and the OK button.

1. Enter the message.

2. Enter the button name. 

3. Select the variable used to keep the status of the button.

4. Repeat 2 and 3 for all buttons you want to add.
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To Modify Test Definition

Example: Displaying Message box

In this modification example, the message box opens after the Vth Const Id measurement is 

completed.  This message box asks you clicking the OK button to display the gm curve.
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Class Exercise

Perform the following modification example.

1. Open Id-Vd test definition.

2. Modify it as follows.

If Yes is clicked after Id-Vd test, move marker and 

tangent line to Vdrain=1 point.

If Yes is clicked, perform Vth gmMax test.

3. Use the debug tools.

4. Save the definition as a new one (ex. Trng IdVd Vth).

5. Perform the test.

6. Export the new definition, and import it. 

1. Add the Yes variable to the Local Variable Definition.

2. Insert the following lines between the lines Id-Vd and END BLOCK.

Message

IF Yes=1

Auto Analysis 

END IF

Message

IF Yes=1

Vth gmMax

END IF

3. Define the first message box.

Message: Do you perform auto analysis?

Button1 Label: Yes, Selected: Yes

Button 2 Label: No, Selected: (blank)

4. Define the second message box.

Message: Do you perform Vth gmMax test?

Button1 Label: Yes, Selected: Yes

Button 2 Label: No, Selected: (blank)

5. Define the IF statements.

Condition Expression: Yes=1

6. Define the Auto Analysis.

Line 1: Enable, Tangent, Axis: Y1, Data Condition: Vdrain=1

Marker: Enable, Condition: Vdrain=1

7. Change the Vth gmMax test parameters as follows.

Drain: Drain

Gate: Gate

Source: Source

Subs: Subs
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To Use Debug Tools

Break point

ReturnPort = SMU1

ReturnCh = OUT1

Variable Inspector

This slide shows an example of using the Variable Inspector for debugging.  Confirm whether the 

correct values are passed to the variables properly.

Set the break point, and click the Run button.  After the program is paused, click the Inspect button.  

The Variable Inspector is displayed.  You can check the values by using the variable display fields.  

The field can be displayed by using the Add XXXX Variable button.  XXXX will be Numeric, 

Vector, String, or Module.
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•Run

•Abort

•Stop

•Break

•Inspect 

To Use Debug Tools

The Debug tab menu provides the following buttons:

•Run button starts the debug (executes the test flow).  During execution, the label changes to Pause.  

Clicking Pause button pauses the execution, and changes the label to Run that is used to continue the 

debug (execution).

•Abort button aborts the debug (execution).

•Step button executes the highlighted line of the test flow.  Clicking the button repeatedly continues 

the execution by a line.

•Break button sets/releases the break point.  For the break point, this button releases the break point 

from the highlighted line.  Program execution will break at the break point automatically.

•Inspect button is available when the debug (execution) is paused or breaked.  This button opens the 

Variable Inspector used to monitor value of device parameters, test parameters, analysis parameters, 

local variables, or system variables.
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Debug: Inspect button

Break point

Paused point

To Use Debug Tools

The Variable Inspector is displayed by clicking the Inspect button after the program is paused, and is 

used to monitor or change the value of the device parameters, test parameters, analysis parameters, 

local variables, or system variables.  For the vector variables, only data monitor is available. The 

Variable Inspector provides the following buttons to add the variable monitor area.

• Add Numeric Variable

• Add Vector Variable

• Add String Variable

• Add Module Variable

The following functions are available for the menu displayed by clicking the banner of the variable 

monitor area.

•Up: This button shifts the variable monitor area upward.

•Down: This button shifts the variable monitor area downward.

•Remove: This button deletes the variable monitor area.
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To Resave and Close Your Test Definition

Close the definition editor, and overwrite your test definition

Save   Ctrl+S

Close

Test Definition editor

After you create your test definition, save the definition and close the Test Definition editor.

Click File > Close.  Confirm Test Definition Save dialog box is opened.  Click Yes to save your test 

definition and continue the close operation.  The Confirm Test Definition Overwrite dialog box is 

opened.  Click OK to overwrite your test definition.
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To Export/Import Test Definition

Click Library>Export Test Definition or Import Test Definition

Cancel

Define New Test…

Open Definition of This Test…

Delete Definition of This Test

Import Test Definition…

Export Test Definition…

The test definition can be exported as the EasyEXPERT test definition file format or XML file 

format.  And the file can be imported to the EasyEXPERT later.
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To Use Built-in Functions

Absolute value: abs(A)

Averaging: avg(A), mavg(A,B)

Data conversion: string(A), value(A)

Difference: delta(A)

Differentiation, integration: diff(A,B), integ(A,B)

Exponent, logarithm: exp(A), lgt(A), log(A)

Maximum, minimum: max(A), min(A) 

Reading data : getNumericData(A), getVectorData(A)

Square root: sqrt(A)

Trigonometric function: acos(A), asin(A) , atan(A), atan2(A,B), 
cos(A), sin(A), tan(A) 

The EasyEXPERT software provides the built-in functions to calculate the display data and 

parameter or to get the test result data.  The built-in functions can be used in the user function and 

analysis function of the test setup, and in the test execution flow of the test contents. 

The following functions are also available.

at(A,B), at(A,B,C), ceil(A), cond(A,B,C,D), dim1Size(A), dim2Size(A), floor(A), index(A,B), 

isValid(A), setDeviceId(A), storeAt(A,B,C,D), substring(A,B,C), swmToModule(A)

For details of the functions, see User’s Guide or online help.



Module 5

Modifying Application Test Definitions

5-21

To Use Built-in Functions

User function setup example

gm = diff(Id,Vg)

gmMax = max(gm)

GM_MAX=getVectorData(gmMax)

VTH=getNumericData(Vth)

GM=getVectorData(gm)

ID=getVectorData(Id)

VG=getVectorData(Vg)

This is an user function setup example.  This example uses the diff function to calculate gm values 

and the max function to get the maximum gm value.

Also, the getVectorData and getNumericData functions are used in the test execution flow to get the 

test result data.
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To Use Read Out Functions

Marker index value: @MI

X coordinate value: @MX, @CX

Y coordinate value: @MY, @MYn, @CY, @CYn

Regression line parameter: @L1CO, @L2CO

Line slope: @L1G, @L1Gn, @L2G. @L2Gn

Line X intercept: @L1X, @L2X

Line Y intercept: @L1Y, @L1Yn, @L2Y, @L2Yn

Intersection of lines: @IX, @IY, @IYn

n: integer. 1 to 8.

The EasyEXPERT software provides the read out functions to read the marker position, cursor 

position, line slope, line intercept, and so on.  The read out functions can be used in the analysis 

function of the test setup.



Module 5

Modifying Application Test Definitions

5-23

To Use Read Out Functions

Analysis function setup example

Vth = @L1X

This is an analysis function setup example.  This example uses the @L1X function to get the X 

intercept value of the line 1.
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To Add Data Display

Analysis: Display Data Setup

Data display

Measurement, 

data display, and 

data save

The test setup performs measurement, displays the test result, and stores the test result data to the test 

record.

In addition to the default test result display, you can make additional data display by using the 

Display Data Setup statement.  The statement provides the user interface as same as the Display 

Setup of the Classic Test or the Test Output of the test definition.  The above example displays the 

ID-VG/GM-VG curves, GM_MAX and VTH values, and tangent line by using the extra Data 

Display and Auto Analysis function.  See next slide.

Note:

This additional display data cannot be saved to the data record. However only the last display data 

can be saved if the Test Output has not been set.



Module 5

Modifying Application Test Definitions

5-25

To Add Data Display

Additional data display example

This is a test result example displayed on the Data Display window.

The auto analysis setup for this example is shown in the next page.
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To Use Auto Analysis Function

Analysis: Auto Analysis

• Line 1

• Line 2

• Marker

GM=GM_MAX

The Auto Analysis statement is used to apply the automatic analysis function to the last test result 

before this statement.  When the test finishes, the function automatically draws lines, a marker, or 

both on the X-Y Graph of the Data Display window.  This statement provides the same GUI as the 

Auto Analysis setup in the Classic Test. 

You can set up two lines and one marker for the automatic analysis function by using the setup 

editor.

In the Line 1 and Line 2 areas, you can set up the lines to be drawn.

In the Marker area, you can set up the marker.

This example draws the tangent line for the Y1 data at the maximum GM point. 
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To Control Test Result Data Outputs

Analysis: Data Display Control

Data Display: OFF/ON

Miscellaneous: Data Store Control

Data Store: OFF/ON

By the default setting, the results of the tests defined in your test definition are displayed on the Data 

Display window and are stored to the data record.

You can control the data display of the tests by using the Data Display Control statement.  Insert the 

statement, and remove the check from the Enable Data Display box to disable the data display.

You can also control the data storage of the tests by using the Data Store Control statement.  Insert 

the statement, and remove the check from the Enable Creating Test Result Record box to disable the 

data storage.

The functions cannot control the following data output.  They are always enabled.

-Data output by the Test Output of the test definition

-Data output by the last test setup if the Test Output has not been set
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To Use Test Setup Internal Variables

From Display Setup screen 

of Classic Test setup

Assign to external variables…

External Variable Setup

•Local variable

•Device parameter

•Test parameter

•Analysis parameter

Internal variable

From Application Test setup

Assign to external variables…

You may want to read the parameters/variables used in Classic Test setup or Application Test setup 

defined in the Test Contents.  Then use the External Variables Setup window used to make a 

mapping table between the test setup internal variables/parameters and the external variables (local 

variables, device parameters, test parameters, or analysis parameters).

To open the External Variable Setup window from a classic test setup:

•Specify the classic test.

•Click the Display Setup tab.

•Click the Assign to external variables… button.

To open the External Variable Setup window from an application test setup:

•Specify the application test.

•Click the Assign to external variables… button.

Note:  Application test internal parameter/variable to be connected to an external variable must be the 

analysis parameter in its test definition.  For the analysis parameter, see “To Define Test Output” in 

Module 6.
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To Use Test Setup Internal Variables 

Setup example Assign to external variables…

This example makes the mapping table between the test setup internal parameters and the analysis 

parameters. 

•Define VTH, GM_MAX, VG, ID, and GM as the analysis parameters.

•Set these analysis parameters to the display parameters.

•Open the External Variable Setup dialog box.

•Assign VTH to the internal parameter Vth.

•Assign VG to the internal parameter Vg. 

•Assign GM to the internal parameter gm. 

•Assign GM_MAX to the internal parameter gmMax.

•Assign ID to the internal parameter Id.

For the example definition, open the Trng idvd idvg2 definition stored in the ¥data folder on the 

Manual CD-ROM.  The Manual CD-ROM stores the example test setup and definition data used in 

this manual.



Module 5

Modifying Application Test Definitions

5-30

To Use Test Setup Internal Variables 

Result example

This is a result example of the test output setup shown in the previous pages.
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To Use Test Setup Internal Variables 

Using built-in functions

Local Variables Definition

BLOCK

IdVg

VG = getVectorData(“Vg”)

ID = getVectorData(“Id”)

GM = getVectorData(“gm”)

GM_MAX = getVectorData(“gmMax”)

VTH = getNumericData(“Vth”)

IdVd

END BLOCK

Vg, Id, gm, gmMax, and Vth

must be the display 

parameters of IdVg.

Display parameters of

the last Data Display window

Test setup

Test setup

This example shows another way to read the value of the internal variables (Vg, Id, gm, gmMax, and 

Vth).  In this example, you do not use the mapping table but use the getVectorData and 

getNumericData built-in functions.  The functions can be used to read the value of parameters 

displayed on the last data display. 

To read the value:

•Define VG, ID, GM, GM_MAX, and VTH as the analysis parameters.

•Set these analysis parameters to the display parameters.

•Insert the ASSIGN statements to add the formula shown above. 

Note:  Application test internal parameter/variable to be connected to an external variable must be the 

analysis parameter in its test definition.  For the analysis parameter, see “To Define Test Output” in 

Module 6.
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To Use Test Setup Internal Variables 

Using built-in functions, setup example

This example sets the following test flow:

Local Variables Definition    ! Defiles Yes variable

BLOCK

Message    ! Do you perform Id-Vg measurement?

IF Yes=1

IdVg ! Classic test setup for Id-Vg measurement

VG=getVectorData(“Vg”)

ID=getVectorData(“Id”)

GM=getVectorData(“gm”)

GM_MAX=getVectorData(“gmMax”)

VTH=getNumericData(“Vth”)

END IF

Message    ! Do you perform Id-Vd measurement?

IF Yes=1 

IdVd ! Classic test setup for Id-Vd measurement

END IF

Message    ! Click OK to display VTH and GM_MAX values and end the test

END BLOCK

For the example definition, open the Trng idvd idvg3 definition stored in the ¥data folder on the 

Manual CD-ROM.  The Manual CD-ROM stores the example test setup and definition data used in 

this manual.
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To Use Test Setup Internal Variables 

Using built-in functions, result example

This is a result example of the test output setup shown in the previous pages.
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� Make two kinds of MOS threshold voltage (Vth) measurements

� Observe how the user functions and analysis functions are used in the 

analysis

� Observe how auto analysis works twice

� Use the standard MOS device and pin connections

� Get the Vth gmMax setup

� Open test definition editor

� Modify the definition for Vth measurement by using the constant 

current method.

To Get Started:

 You will:

Class Exercise

To use Auto Analysis twice

In this exercise you will observe how auto analysis works.  You will understand each setup screen 

required to implement an auto analysis process.
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To Modify Test Definition
Opening Vth gmMax test definition 

1

2

3

4

1. Select the CMOS category.

2. Open the Vth gmMax test definition.

3. Click the Library button.

4. Select the Open Definition of This Test… menu.

The test definition editor is opened with the Vth gmMax test definition.
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To Modify Test Definition

Setting properties of numeric variable

1

1

3

2

1. Save the test setup as a new one.  For example, save it as Vth gmMax and Id of the Exercise 

category.

Click Add button to display the entry fields for the parameter.

2. Select the Id@Vth variable and the type of  Numeric.

3. Set properties of the Id@Vth variable.
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To Modify Test Definition

Analysis function setup 

1

3

2

4

1. Display the Test Contents screen.

2. Highlight the Vth_gmmax line.

3. Click the function Setup tab.

4. Add the Analysis function.  Set the following parameters.

<Name>    <unit>    <Definition>

Vth@Id V           @MX

This is an analysis function setup example. This example uses the @MX function to get the X 

coordinate value.
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Auto Analysis Setup
Auto Analysis Setup 1

2

Check this box.

1. Click the Auto Analysis Setup tab to display the Auto Analysis setup screen. 

2. Check the box to fix the Line 1.  If the box is not checked, the line will be moved when the 2nd 

Auto Analysis is done.

The 1st Auto Analysis is set in this slide.



Module 5

Modifying Application Test Definitions

5-39

To Set Display Setup

Display Setup
1

2

3

1. Click the Display Setup tab.

2. Click Add button to display the entry fields for the parameter.

3. Select Vth@Id to display.
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Auto Analysis Setup
The 2nd Auto Analysis Setup

1

23

4

5

6
Idrain=Id@Vth*Polarity

1. Display the Test Contents screen.

2. Click the Analysis Setup tab.

3. Highlight the Auto Analysis icon.

4. Hit Insert button.

5. Check the box of Interpolation Mode.

6. Check the box of Enable.  Then enter Idrain=Id@Vth*Polarity to find the constant current Vth.

The 2nd Auto Analysis is set in this slide.
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To Use Auto Analysis Twice

Result example

This is a result example of using two times Auto Analysis shown in the previous pages.

Vth, gmMax and Vth@Id are automatically calculated.
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Class Exercise

To Use Vector Data.

1. Open the Cgg-Vg test definition.

2. Modify it for the multiple frequency test using a 

vector variable.

3. Use the debug tools.

4. Save the definition as a new one (ex. Trng Cgg-Vg).

5. Perform the test.

6. Export the new definition, and import it. 

See the following pages which show an example to use a vector data.  The Cgg-Vg test definition is 

used as the reference of this example.  The FREQ variable in this test definition will be changed from 

the numeric type to the vector type.
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To Modify Test Definition
Opening Cgg-Vg test definition 

1

2

3

4

1. Select the CMOS category.

2. Open the Cgg-Vq test definition.

3. Click the Library button.

4. Select the Open Definition of This Test… menu.

The test definition editor is opened with the Cgg-Vg test definition.
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To Modify Test Definition
Setting properties of vector variable

1

2

3

4

1

1. Save the test setup as a new one.  For example, save it as Trng Cgg-Vg of the Exercise category.

2. Select the FREQ variable and change the type from Numeric to Vector.

3. Click the Dimension… button.  The Define dimensions dialog box appears.

4. Set the dimension of the FREQ variable.

The example in this slide sets the one dimension and three elements vector variable.
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To Modify Test Definition
Setting vector data

2

1

1. Click the Grid button of the FREQ variable.  The Define vector data dialog box appears.

2. Define the vector values for the FREQ variable.

The example in this slide sets the value 1 MHz, 2 MHz, and 3 MHz to the FREQ three elements 

vector variable.
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To Modify Test Definition
Using the at( ) function to read vector data 

2

1

3

1. Display the Test Contents screen.

2. Highlight the Cgg-Vg line.

3. Click the Measurement Setup tab and set the Frequency List using the at( ) functions.
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In This Module

• What is Test Definition

• What is Test Contents

• To Open Test Definition Editor

• To Define Test Specification

• To Define Test Contents

• Available Elements

• Available Variables

• To Define Test Output

This section explains how to create your test definition.  You will perform the above tasks to create 

the definition.
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What is Test Definition

Test Specification Test Output

Test Contents

•Test name

•Test description

•Variables

•Entry fields

•Multi display mode

•Variables

•Test result display

•Local variables

•Test execution flow

•Test setup

•Device parameters

•Test parameters •X-Y graph

•Data list

•Parameter display

•Classic test

•Application test

•My Favorite setup

•Analysis parameters

Test definition consists of test specification, test contents, and test output setup.  The test 

specification contains test name, description, device parameters, and test parameters.  The parameters 

will be the variables used to pass the test conditions to the test execution flow or test setup defined in 

the test contents.  Especially for the test parameters, you can specify the position of entry field for 

each parameter.  You can see the entry fields when the main screen displays this application test 

setup.  The test contents are the core of the test definition.  You will define the local variables, test 

execution flow, and test setup.  You can define the test setup by selecting application tests, classic 

tests, or my favorite setup, and entering the test conditions.  

The test output setup is optional.  If you have the following requirements, declare the analysis 

parameters and define the display parameters on the Test Output tab screen. 

-To send the test data to the subsequent tests

-To make the program branching depends on the test data

-To display/record the calculation result using the test data 

-To display/record the test data of this application test

-To change the multi display mode of this application test

Note:  You can use the device parameters, test parameters, and analysis parameters in the test 

execution flow (program flow) of the test contents without declaration of local variables.

Note:  If the multi display mode is Disabled, the all test result data will be displayed on the singular 

Data Display window.  If the multi display mode is Enabled, the test result data of the same test setup 

name will be displayed on the exclusive Data Display window and the test result data of the different 

test setup name will be displayed on the new Data Display window.
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What is Test Contents

Variables

•Device parameters

•Test parameters

Variables

•Analysis parameters

Local variables

Program Component

Application Test

Classic Test

Analysis

Miscellaneous

Test OutputTest Specification

My Favorite

Test contents are the test execution flow (program flow), and is the core of the test definition.  In the 

test contents, the following elements can be defined.

•Local variables

•Program components

•Application tests

•Classic tests

•My Favorite setup

•Analysis components

•Miscellaneous components

•Device parameters defined in the test specification

•Test parameters defined in the test specification

•Analysis parameters defined in the test output

The program is executed from top to bottom in the test execution program list.
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To Open Test Definition Editor

Define New Test…

To start test definition, open the test definition editor.

Select the Application Test tab, click the Library button, and select the Define New Test… function.  

The test definition editor will be opened.  See next slide.
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To Define Test Specification

Set test information

Define device parameters

Set properties 

of parameter

The test definition editor provides three tabs, Test Specification, Test Contents, and Test Output.  At 

first define the test specification.  Click the Test Specification tab.

In the Test Information area:

•Click the right button in the Category field to specify the category the new test definition belongs.

•Enter the Test Name.

•Select the Icon that will be displayed on the list area below the Library button of the main screen.  It 

is the image file used to select the test definition.  See previous slide.

•Enter the Description of the test.

In the Device Parameters Definition area:

•Click Add button to display the entry fields for the parameter.

•Set the Name, Default value, and Description for the parameter. When you add a parameter, you 

will see the entry fields at the Properties area.  The area shows you the properties (minimum value, 

maximum value, number of effective digits, resolution, and unit) for the device parameter or the test 

parameter specified by the radio button put on the left of the parameter name.

For the Typical Values… button and the Symbols… button, see online help or User’s Guide.
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To Define Test Specification

Define test parameters

Set properties 

of parameter

In the Test Parameters Definition area:

•Select the Background that will be displayed on the application test setup area of the main screen.  

Usually it is the image that shows the device connections.

•Set the Name, data type, Default value, and Description for the parameter.  When you add a 

parameter, you will see the entry fields at the Properties area. The area shows you the properties 

(minimum value, maximum value, number of effective digits, resolution, and unit) for the device 

parameter or the test parameter specified by the radio button put on the left of the parameter name.

•Set the X, Y, and Width values to specify the position of entry field displayed on the application test 

setup area.  

•Check the Align box to set the X origin of entry field to the left edge of the entry field.  Uncheck 

this box to set it to the left edge of the parameter name placed left next to the entry field.

•Check the Ext box.  The entry field will be put on the Extended Test Parameters dialog box that is 

displayed by clicking the Extended Setup button on the application test setup area of the main screen. 
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Setup example

This example sets:

Category: Exercise (This category may be created by the class exercise in Module 5)

Test Name: Trng idvd idvg

Icon: MOSFET.bmp

Device parameters:

Hold and Delay

Background: Vth_Const_Id.PNG

Test parameters:

Drain, Gate, Source, Subs, Idcomp, Igcomp

IdVd_V1start, IdVd_V1step, IdVd_V1stop, IdVd_V2start, IdVd_V2step, IdVd_V2nop

IdVg_V1start, IdVg_V1stop, IdVg_V1step, IdVg_Vdrain

Vsource, Vsubs

Entry field properties: 80 (width) x 30 (distance in vertical direction)

Press the Layout… button to open the Define Layout dialog box.
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Primary Entry Field

Setup example - Layout

The Define Layout dialog box is used to define the layout of the test parameter entry fields displayed 

on the application test setup screen.

The following methods are available for selecting the entry fields.

•Click on the entry field. Multiple entry fields can be selected by clicking on the entry field while 

holding down the Ctrl key on the keyboard.

•Drag the mouse to draw a rectangle around multiple entry fields.

•Select Select All from the EDIT menu to select all entry fields.

The selected entry fields are outlined by the blue rectangles. The primary entry field, which is the 

base for layout operations, is surrounded by a highlighted blue rectangle. Only one primary entry 

field can be selected. To change the primary entry field, click on a selected entry field. The entry 

field is always that was most recently  clicked will be the primary entry field.

The following methods are available for releasing (unselecting) the selected entry fields.

•Click the selected entry field while holding down the Shift key on the keyboard.

•Click outside of the selected entry fields to release all selected entry fields.

The following methods are available for defining the layout of the selected entry fields.

•Drag & drop with the mouse to move the selected entry field(s).

•Change the X/Y values in the property window to move the selected  entry field(s).

•Press the arrow keys on the keyboard to move the selected entry field(s).

•Use the functions in the Align menu to align the selected entry field(s) to the primary entry field.

•Use the functions in the Distribute menu to evenly distribute the selected entry fields horizontally or 

vertically.

•Use the functions in the Centralize menu to move the horizontal or vertical center of all selected 

entry fields to the horizontal or vertical center of the entry field area.

For more information, see online help or User’s Guide.
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Result example

This is a result example of the test specification setup shown in the previous pages.
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To Define Test Contents

4. Select available element

3. Specify the line

to insert element

or to be edited

5. Click Insert or 

desired button
2. Define the local variables used 

in this test contents

6. Define the setup required for

the highlighted line (element)

1

Starting to define the test contents:

1. Highlight the Local Variables Definition line.

2. Define the local variables used in this test contents (test execution flow).

3. Highlight the line that an element has to be inserted.

4. Highlight an element of Program Component, Application Test, Analysis, Classic Test, 

Miscellaneous, or My Favorite Setup tab menu.

5. Click the Insert button of the Edit tab menu.  The element will be inserted between the highlighted 

line and the next line.

6. Define the required setup.

To edit the test contents:

1. Optional.  Highlight the Local Variables Definition line.

2. Optional.  Define the local variables used in this test contents (test execution flow).

3. Highlight the line to be edited.

4. Highlight an additional element if you need.

5. Click the desired button if you need.

6. Define the required setup if you need.

Repeat this to create the test contents (test execution flow).
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Available elements

Program Component

Application Test

Analysis

Classic Test

Miscellaneous

My Favorite

Available elements are shown above.  The Program Component provides the typical program 

statements such as IF, LOOP, FOR, and so on.  They are used to control the test execution flow.  The 

Application Test, Classic Test, and My Favorite are used to define the test setup/test condition.  The 

Analysis provides the elements used to control auto analysis function and data display.  And the 

Miscellaneous provides other useful elements.  For details of elements, see online help or user’s 

guide.
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Available variables

Test Specification

•Device parameters

•Test parameters

Test Output

•Analysis parameters
You can connect the 

variables in test setup with

•Local variables

•Device parameters

•Test parameters

•Analysis parameters 

Test Contents

•Local variables

Assign to external variables…

Do not set the same name 

for variables and 

parameters.  The name 

must be unique.

In the test execution flow (program flow), you can use the following variables.

•Variables defined by the Local Variables Definition component

•Device parameters defined in the Test Specification

•Test parameters defined in the Test Specification

•Analysis parameters defined in the Test Output

You may want to read the parameters/variables used in Classic Test setup or Application Test setup 

defined in the Test Contents.  Then use the External Variables Setup dialog box or built-in functions.  

They can connect the test setup internal variables/parameters to the external variables listed above.  

For the example variable connections, see “To Use Test Setup Internal Variables” in Module 5.

Note:  Application test internal parameter/variable to be connected to an external variable must be the 

analysis parameter in its test definition.
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Defining local variables

Local Variables Definition

Add Numeric Variable button displays the Numeric Variable area that provides the following fields.

•Name: Numeric variable name

•Value: Initial value of the variable

•Description: Additional information for the variable

Add Vector Variable button displays the Vector Variable area that provides the following fields.

•Name: Vector variable name. Two dimensional array.

•Count: Number of elements, or array size

•Description: Additional information for the variable

This area also provides the following radio button used to specify how to set the initial value of the 

array data automatically.

• Assign Linear Values FROM [value of first element] TO [value of last element]

If Count>1, this sets first value + (N-1) x (last value-first value)/(Count-1) to the N-th element. If 

Count=1, this sets first value(=last value) to the element.

• Assign Linear Values FROM [value of first element] STEP [step value]

This sets first value + (N-1) x step to the N-th element.

Add String Variable button displays the String Variable area that provides the following fields.

•Name: String variable name

•Value: Initial value of the variable

•Description: Additional information for the variable

Add Module Variable button displays the Module Variable area that provides the following fields.

•Name: Module variable name

•Description: Additional information for the variable
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Editing test contents

•Block Selection

•Insert

•Delete

•Copy

•Cut

•Paste 

The Edit tab provides the following buttons:

•Block Selection/Line Selection toggle button selects the edit target selection mode.  In the line 

selection mode, clicking line just selects the line.  In the block selection mode, clicking line selects 

the block the line belongs.

•Insert button inserts the specified element between the highlighted line and the next line.

•Delete button deletes the highlighted line.

•Copy button copies the highlighted line to the clipboard.

•Cut button moves the highlighted line to the clipboard.

•Paste button inserts the line in the clipboard between the highlighted line and the next line.
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Debug menu

•Run

•Abort

•Stop

•Break

•Inspect 

The Debug tab menu provides the following buttons:

•Run button starts the debug (executes the test flow).  During execution, the label changes to Pause.  

Clicking Pause button pauses the execution, and changes the label to Run that is used to continue the 

debug (execution).

•Abort button aborts the debug (execution).

•Step button executes the highlighted line of the test flow.  Clicking the button repeatedly continues 

the execution by a line.

•Break button sets/releases the break point.  For the break point, this button releases the break point 

from the highlighted line.  Program execution will break at the break point automatically.

•Inspect button is available when the debug (execution) is paused or broken.  This button opens the 

Variable Inspector used to monitor value of device parameters, test parameters, analysis parameters, 

local variables, or system variables.
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Class Exercise

Create test definition and perform test.

1. Open test definition editor.

2. Define Test Specification (see previous page)

3. Define Test Contents shown below.

4. Save the definition as Trng idvd idvg.

5. Use debug tools to check the definition.

6. Connect device, and perform test.

SMU4

SMU2

SMU1

SMU3

Test Contents:

Local Variables Definition

BLOCK

IDVD

Message

IF Yes=0

END

END IF

GMMAX

END BLOCK
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Test Definition Example

variables

Use IDVD and GMMAX in the Demo preset group (My Favorite Setup) for the test setup.

Use the variables defined in the Test Specification to set the Unit on the Channel Setup, the source 

values on the Measurement Setup, the Min and Max values on the Display Setup, and so on.

For the example definition, open the Trng idvd idvg definition stored in the ¥data folder on the 

Manual CD-ROM.  The Manual CD-ROM stores the example test setup and definition data used in 

this manual.
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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To Define Test Output

2. Define the analysis parameters

3. Specify X axis and Y axis

4. Select variables to list 5. Select parameters

to display

1

6. Select the multi display mode
Comply with above level

Enable

Disable

The test output setup is optional.  If you have the following requirements, define the analysis 

parameters and set the display parameters.

-To send the test result data to the subsequent tests in an application test

-To make the program branching depends on the test result

-To make the calculation using the test data in the Test Contents

-To display/record the test result of this application test

-To change the multi display mode of this application test

To define the test output:

1. Check the Define own Output Parameters box.

2. Click the Define Analysis Parameters… button.  And define the analysis parameters on the 

Analysis Parameter Definition window.

3. Specify X axis and Y axis of the X-Y Graph of the Data Display window.

4. Select variables to list in the List Display area of the Data Display window.

5. Select variables to display in the Parameters area of the Data Display window.

6. Select the multi display mode using the Allocate Data Display for each test pull-down menu.

Note:  If the multi display mode is Disabled, the all test result data will be displayed on the singular 

Data Display window.  If the multi display mode is Enabled, the test result data of the same test setup 

name will be displayed on the exclusive Data Display window and the test result data of the different 

test setup name will be displayed on the new Data Display window.
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To Define Test Output

Analysis Parameters Define Analysis Parameters…

Define the analysis parameters as shown below:

At the Vector Parameters area or the Scalar Parameters area:

1. Click the Add button.

2. Enter the Name, Unit, and Description of the parameter.

For the sweep output/measurement data, use the vector parameter.

For the spot output/measurement data, use the scalar parameter.

For the data given by the max( ) and min( ) built-in function, use the vector parameter.

In this example, VG, ID, and GM are the vector parameter and VTH is the scalar parameter. 

GM_MAX is the vector parameter because the max( ) built-in function is used to calculate this value.
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To Define Test Output

Display Parameters

This example sets:

X-Y Graph: ID-VG plot for Y1-X graph and GM-VG plot for Y2-X graph

List Display: VG, ID, and GM

Parameters: GM_MAX and VTH

All parameters must be defined in the Analysis Parameter Definition window shown in the previous 

slide.

The X-Y Graph area is used to set the X axis and Y axis of the X-Y Graph Plot area on the Data 

Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed on the List Display area of the Data Display 

window.  Up to 20 variables can be set.

The Parameters area selects the variables to be listed on the Parameters area of the Data Display 

window.  Up to 20 parameters can be set.
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In This Module

• To Control External GPIB Devices

• To Call Execution Files

• To Perform Repeat Measurements

• Prober Control Script
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To Control External GPIB Devices

Miscellaneous: GPIB I/O

Write String to send a string command to GPIB device

Write Value to send a command to GPIB device

Read String to read a string value from GPIB device

Read Value to read a numeric value data from GPIB device

Read List to read a vector data from GPIB device

Read STB to read status byte of GPIB device

GP-IB Control Group Execution Trigger

Device Clear

Go To Local

Local LockOut

You can control external GPIB devices from the EasyEXPERT by using the GPIB I/O statement.  

The GPIB I/O statement provides the write/read functions shown above.  Select a write function and 

enter the necessary parameters to send a command to the GPIB device.  Select a read function and 

enter the necessary parameters to read response from the GPIB device.  For details, see online help or 

User’s Guide.

The followings are the GPIB Control functions.

•Group Execution Trigger: Sends a trigger to the specified GPIB device.

•Device Clear: Sends a device clear to the specified GPIB device.

•Go To Local: Returns the specified GPIB device to the local state.

•Local LockOut: Locks the specified GPIB device.

Note:  Before starting, enable System Controller.  See Module 8. Also establish the GPIB connection 

with the external GPIB devices.
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To Control External GPIB Devices

Agilent B2200 control example

To send command

Value 1

Value 2

Value 3

Value 4

{0}

{1}

{2}

{3}

Programming image:

*RST

:ROUT:FUNC ACON

(enters “SMU1” to StringPort)

:ROUT:SYMB:PORT {0},”{1}”

:ROUT:SYMB:PORT? {0}

(reads string data)

*OPC?

(reads operation complete flag)

(enters “OUT1” to StringCh)

:ROUT:SYMB:CHAN {0},{2},”{1}”

:ROUT:SYMB:CHAN? {0},{2}

(reads string data)

*OPC?

(reads operation complete flag)

This slide shows an example setup of the GPIB I/O statement.  This is a component of the test 

contents used to control the Agilent B2200 switching matrix.

This example uses the Write Value function to send the following command to the B2200.

:ROUT:SYMB:CHAN {0},{2},”{1}”

where, {0} is CardNo, {1} is StringCh, and {2} is ChanNo.

The followings are the reference of the setup editor.

•Address: GPIB address of the device

•Terminator: EOI, LF, CR/LF, LF+EOI, CR/LF+EOI, or NONE (no terminator)

•Format: Command (header and parameters) sent to the device

•Value 1: Value for {0}

•Value 2: Value for {1}

•Value 3: Value for {2}

•Value 4: Value for {3}

{0}. {1}, {2}, and {3} are variable available in the Format field only.

Note:  Use double quotes to enter a string to a local variable by using the Assign statement.
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To Control External GPIB Devices

Agilent B2200 control example

To read data

Programming image:

*RST

:ROUT:FUNC ACON

(enters “SMU1” to StringPort)

:ROUT:SYMB:PORT {0},”{1}”

:ROUT:SYMB:PORT? {0}

(reads string data)

*OPC?

(reads operation complete flag)

(enters “OUT1” to StringCh)

:ROUT:SYMB:CHAN {0},{2},”{1}”

:ROUT:SYMB:CHAN? {0},{2}

(reads string data)

*OPC?

(reads operation complete flag)

This example uses the Read String function to read the response from the B2200.  This example 

reads the :ROUT:SYMB:CHAN? query command response.  The result (ReturnCh value) must be 

OUT1.
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To Call Execution Files

Miscellaneous: Command Execution

Specifies variables used to receive execution 

results or output data.  This area is deleted 

by Read Type: None.

Specifies vector variable  or 

string sent to the exe file.

You can call the execution file (EXE file) from the EasyEXPERT.  Use the Command Execution 

statement and define the setup editor as shown in this example.

•Command Filename:  Execution file name (command name)

•Argument:  Command parameter or argument

•Write Type:  String or List (vector data)

•Read Type:  String, Value (numeric data), List (vector data), or None (no read data)

If you specify Write String, enter the string sent to the command.

If you specify Write List, enter the name of vector variable sent to the command, and specify the 

format of data element sent to the command.  See next slide.

In the Read String/Value/List area, specify the variables used to receive execution result and output 

data.  There is no entry field for Read Type: None.

•Result:  Numeric variable name.  Used to store the execution result.

•Value:  Numeric variable name for Read Value, or vector variable name for Read List.  Used to 

store the returned data.

•String:  String variable name.  Used to store the returned data.

•Length Actually Read:  Numeric variable name.  Used to store the byte length of the returned data.

The above example calls the sleep.exe file used to insert the wait time for program execution.  The 

WAIT value must be defined in msec.  After the normal command execution, the sleep.exe returns 1 

for Value and 0 for Result.  The sleep.exe file is stored in the following folder.

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT¥Utilities
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To set Format field

{I[,A][:F]}

• I List data index.  Or index of element.  Integer.

• [,A] Character length of the specified data element.

Positive integer for right-aligned, or negative

integer for left-aligned.  Optional.

• [:F] Format identifier.  C, D, E, F, G, N, P, R, or X. 

Lower case is available.  Optional.

Example: 

{0,5:E} First element, 5 characters, exponential notation.

{1:G} Second element, general.

{2,10} Third element, 10 characters, general.

The Format field is used to specify the data format of List (vector variable).  The strings shown in the 

above example can be defined in the Format field.

In the strings, the list data index is mandatory.  The character length and format identifier are 

omissible.  Then the length is not limited, and the format G is set.

C or c:  Circulation

D or d:  Decimal numeral

E or e:  Exponential notation

F or f:  Fixed point

G or g:  General

N or n:  Numeric

P or p:  Percent

R or r:  Round trip

X or x:  Hexadecimal numeral

For the format, see online help or manual of the Agilent T&M Programmers Toolkit.
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Exercise

Try to improve your test definition as you want.

• To Use Built-in Functions

• To Use Read Out Functions

• To Control External GPIB Devices

• To Call Execution Files
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To Perform Repeat Measurements

If Abort is clicked

Yes

Start (Run)

Start Procedure

No

Iteration Procedure

Final Procedure

End

Test Execution

No

Yes

status=True ?

Yes

No

Count >= limit

status=True ?

Count=Count+1

Count=0

A

status limit

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

Abort
5     

Repeat measurement is performed as shown in this flowchart.  The status is a response returned by 

the start/iteration procedure.  The Count is the accumulated number of test executions.  They are the 

stop condition of the repeat measurement.

The repeat measurement stop function is enabled by the following check boxes.

•Counter reaching to

•Procedure return condition

If the first box is checked and the limit value is specified, the repeat measurement will be stopped if 

Count >= limit.  To perform the repeat measurement, set the limit value more than the number of 

devices under test or remove check from this box.

If the second box is checked, the repeat measurement will be stopped if status = True.

When the second box is checked, the device ID automatic setup function is available and is 

enabled/disabled by the Automatically fill in Device ID check box.  The function enters the 

device_id value to the Device ID of the test result record.  The device_id is a response returned by 

the start/iteration/subsite procedure.

The Repeat Measurement Setup dialog box provides the following action buttons.

•Run: Starts repeat measurement.

•Abort: Stops repeat measurement immediately.

•Cancel: Closes the Repeat Measurement Setup dialog box.

Start/Iteration/Final Procedure:

Enter the full path name of the procedure.  For example, enter as follows.

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT¥Utilities¥ProberControl¥suss¥Start_suss.exe

Arguments:

Enter the options of the procedure.  See the following pages describing about procedures.  For 

example, enter –a GPIB0::5::INSTR –l C:¥temp¥prb.log.

If you use the sub die move operation (subsite procedure), the flowchart must be changed.  See page 

7-18.
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Subsite move Test Setup

Select

Specify ProberType.

Or specify driver for your prober in 
CustomProber.

Save

If you do not use the sub die (subsite) move operation, skip this page.

Click Application Test tab and open the Subsite move test setup in the Utility category.  On the 

Subsite move setup screen, specify ProberType (Cascade, Suss, or Vector) or driver for your prober 

in CustomerProber, and save it as a setup in your preset group (My Favorite Setup).  Then you can 

use the setup for your quick test.  See next page.

The Subsite move setup moves wafer chuck to the next subsite, reads device ID from the prober, and 

sets it to the Device ID of the test result record. 

For more details of the test setup, open the Test Definition window.

In the Subsite move test definition, an execution file callProbeDvr.exe is used.  This file is used to 

send Subsite_xxxx.exe to the prober specified by the prober_info.ini file and receive the response; 

status and device_id.  The callProberDvr.exe has the following input/output parameters.

Input: Full path of Subsite_xxxx.exe

Output: status; True (break) or False

Output: device_id

Note:  The callProberDvr.exe refers to the prober_info.ini file for the GPIB address and log file 

name.  Do not set the Arguments of Subsite_xxxx.exe.
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To Use Subsite move

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

5     

If you do not use the sub die (subsite) move operation, skip this page.

To perform the test with the sub die move operation, do as follows.

1. Add the Subsite move test setup to your preset group (My Favorite setup).

2. Set your preset group and test setups in the Quick Test tab screen.

3. Open the Repeat Measurement Setup dialog box.

4. Specify the procedures and the repeat measurement condition.

5. Start repeat measurement.

The Subsite move setup must be entered after measurements for a sub die.
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Prober Control Script

• Prober information file

prober_info.ini

• Start Procedure

Start_xxxx.exe

• Iteration Procedure 

Iterator_xxxx.exe

• Final Procedure 

Final_xxxx.exe

• Subsite Procedure

Subsite_xxxx.exe

xxxx: • cascade

• suss

• vector

Use prober control script in EasyEXPERT

Repeat Measurement Setup window

Prober control script is sample program used for semi-automatic prober control. The Agilent 

EasyEXPERT can call the script by using the Repeat Measurement Setup window.

See page 7-9 to call the script and perform repeat measurement.

See page 7-14 for the prober information file.

See page 7-13 for the start procedure.

See page 7-15 for the iteration procedure.

See page 7-16 for the final procedure. 

See page 7-17 for the subsite procedure.

To use the prober control script, specify the start/iteration/final procedure in the Repeat Measurement 

Setup dialog box (see page 7-9).  And use the Subsite move test setup in your quick test to control 

sub die move.  The Subsite move setup uses the subsite procedure for moving wafer chuck to the 

next subsite.  See page 7-10 and 7-11.
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Start_xxxx.exe
• Arguments: -a GPIB_address

-l log_file_name

Example:

–a GPIB0::5::INSTR –l C:¥temp¥prb.log

• Response: XML format data

status: True (break) or False

device_id: prefix:coordinate

Example:

<Response>

<Break>status</Break>

<Target>device_id</Target>

</Response>

<Response>

<Break>False</Break>

<Target>waf1a:3 1</Target>

</Response>

Start

End

Displays Device ID Entry dialog box 

Moves to the first position

Gets X-Y coordinate

Chuck up

Returns response

Updates prober_info.ini file

Displays Start Confirmation dialog box

Yes

No

Yes
Prober error?

No

Prober error?

B

To specify the start procedure in the Repeat Measurement Setup dialog box, enter the full path name 

of Start_xxxx.exe into the Start Procedure field.

After the repeat measurement is started, this procedure displays the Device ID Entry dialog box and 

waits for your input.  On the dialog box, enter a string used for the prefix of device_id.  After that, 

you will see the Start Confirmation dialog box that is used to confirm your wafer setup status.  Load 

wafer and perform wafer alignment, then click OK on the dialog box.  The procedure moves wafer 

chuck to the first probing position, checks the prober status, gets the X-Y coordinate of the probing 

position, and sets the wafer chuck to the UP position.  At last, the procedure returns the response.

The status is True or False.  It is used for the EasyEXPERT repeat measurement stop function.  When 

the Procedure return condition box is checked in the Repeat Measurement Setup dialog box, the 

repeat measurement will be stopped if status = True.

The device_id is a string for the Device ID of the test result record.  When the Automatically fill in 

Device ID box is checked in the Repeat Measurement Setup dialog box, the device_id will be entered 

to the Device ID of the test result record.

If you use the subsite procedure, the flowchart must be changed.  See page 7-18.

Note:  To ignore the Arguments, set the GPIB address and log file name in the prober_info.ini.
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Prober_info.ini

[Prober]

Address=GPIB::5::INSTR  

LogMode=True

LogName=C:¥temp¥prb.log

[Target]

UseID=True

SubsiteInfo=False

WaferInfo=False

ID=waf1a
<Response>

<Break>False</Break>  

<Target>waf1a:4 1</Target>

</Response>

device_id = prefix:coordinate

GPIB address of prober

Full path name of log file

Prefix you enter in the Device ID Entry dialog box.

ID is automatically recorded in the prober_info.ini file. 

The Device ID Entry dialog box is opened by Start_xxxx.exe.

The prober information file is necessary to execute the prober control script.  Before starting tests, 

open this file, edit it as you want, and overwrite it.  The name must be prober_info.ini.

The prober_info.ini file stores the information shown below.

•Address: GPIB address of prober

•LogMode: Log file creation mode; True or False

•LogName: Log file name (full path)

•UseID: Device ID creation mode; True or False

•SubsiteInfo: Set always False. This is just a place holder.

•WaferInfo: Set always False. This is just a place holder.

•ID: Ignore this variable. This is just a pass parameter.

If the procedures specify the –a option, the Address value is not used.

If the procedures specify the –l option, the LogName value is not used. 

To create a log file, set LogMode=True.

To use the prefix:coordinate format for the device_id value, set UseID=True.  If UseID=False, the 

device_id value will be coordinate, not prefix:coordinate.  The prefix will be the value entered in the 

Device ID Entry dialog box that is opened by Start_xxxx.exe.  This function is available when the 

Automatically fill in Device ID check box is checked.
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Iterator_xxxx.exe
• Arguments: -a GPIB_address

-l log_file_name

Example:

–a GPIB0::5::INSTR –l C:¥temp¥prb.log

• Response: XML format data

status: True (break) or False

device_id: prefix:coordinate

Example:

<Response>

<Break>status</Break>

<Target>device_id</Target>

</Response>

<Response>

<Break>False</Break>

<Target>waf1a:4 1</Target>

</Response>

Start

End

Chuck down

Moves to the next position

Chuck up

Returns response

Yes

Yes
Prober error?

No

Prober error?

Yes

No

Prober error?

Gets X-Y coordinate

No

B

To specify the iteration procedure in the Repeat Measurement Setup dialog box, enter the full path 

name of Iterator_xxxx.exe into the Iteration Procedure field. 

The procedure is called after the measurement is completed for a die.  This procedure sets wafer 

chuck to the DOWN position, moves it to the next probing position, checks the prober status, gets the 

X-Y coordinate of the probing position, and sets the wafer chuck to the UP position.  At last, the 

procedure returns the response.

The status is True or False.  It is used for the EasyEXPERT repeat measurement stop function.  When 

the Procedure return condition box is checked in the Repeat Measurement Setup dialog box, the 

repeat measurement will be stopped if status = True.

The device_id is a string for the Device ID of the test result record.  When the Automatically fill in 

Device ID box is checked in the Repeat Measurement Setup dialog box, the device_id will be entered 

to the Device ID of the test result record.

If you use the subsite procedure, the flowchart must be changed.  See page 7-18.

Note:  To ignore the Arguments, set the GPIB address and log file name in the prober_info.ini.
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C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT

5     

Final_xxxx.exe

Start

End

Chuck down

• Arguments: -a GPIB_address

-l log_file_name

Example:

–a GPIB0::5::INSTR –l C:¥temp¥prb.log

• Response: none

Stop condition

To specify the final procedure on the Repeat Measurement Setup dialog box, enter the full path name 

of Final_xxxx.exe into the Final Procedure field.

The procedure is called after one of the stop condition is detected.  This procedure sets wafer chuck 

to the DOWN position.

Note:  To ignore the Arguments, set the GPIB address and log file name in the prober_info.ini.
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Subsite_xxxx.exe
Start

End

Chuck down

Moves to the next subsite

Chuck up

Returns response

Yes
Prober error?

Yes

No

Prober error?

Gets X-Y coordinate

No

• Arguments: -a GPIB_address

-l log_file_name

Example:

–a GPIB0::5::INSTR –l C:¥temp¥prb.log

• Response: XML format data

status: True (break) or False

device_id: prefix:coordinate

Example:

<Response>

<Break>status</Break>

<Target>device_id</Target>

</Response>

<Response>

<Break>False</Break>

<Target>waf1a:3 1</Target>

</Response>

To realize sub die move operation, you need to define Subsite_xxxx.exe in your test definition and 

create your application test setup.  However, you do not need to take care of this procedure by using 

the Subsite move test setup included in the application library. The Subsite move setup moves wafer 

chuck to the next subsite, reads device ID from the prober, and sets it to the Device ID of the test 

result record.

Open the Subsite move test setup and save it as a setup in your preset group (My Favorite Setup).  

Then you can use the setup for your quick test.  

Note:  To use the Subsite move setup, set the GPIB address and log file name in the prober_info.ini.  

And ignore the Arguments for Subsite_xxxx.exe.

Note:  If you use a Suss prober, the number of Subsite move setups used in your quick test (die test) 

is important.  It must be N-1; N is the number of subsites defined in the prober.

The status is True or False.  It is used for the EasyEXPERT repeat measurement stop function.  When 

the Procedure return condition box is checked in the Repeat Measurement Setup dialog box, the 

repeat measurement will be stopped if status = True.

The device_id is a string for the Device ID of the test result record. 
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To Change Execution Flow

A
Subsite Procedure

No
Yes

status=True ?

Test Execution

B Move to the 1st subsite

If you use the subsite procedure, change the flowchart as follows.

On the page 7-9, replace the box A with the block A shown above.

On the page 7-13 and 7-15, insert the box B shown above to the position B of the flowchart.
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In This Module

• Function Status Indicators

• Run Option

• Automatic Data Export and Data Record

• Calibration

• Configuration

• XSLT Filters

• To Enable System Controller

• To Start Desktop EasyEXPERT

• To Use 415x Setup File Converter

This module describes the above topics.  You will understand what is the function status indicator, 

how to change the function status, how to perform selftest and calibration, how to perform SMU zero 

offset cancel, and so on.
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Function Status Indicators

Automatic data export OFF ON

Multiple data display OFF ON

ONSMU zero offset cancel OFF

ONStandby function OFF

Automatic data record ON OFF

Function status indicators let you know the status OFF or ON of the following functions.  The 

indicators are placed at the bottom of the main screen.

Multi Display OFF/ON: Shows the multiple data display function OFF or ON status.

Standby OFF/ON: Shows the standby function OFF or ON status.

SMU Zero OFF/ON: Shows the SMU zero offset cancel function OFF or ON status.

Auto Export OFF/ON: Shows the automatic data export function OFF or ON status.

Auto Record ON/OFF:  Shows the automatic data record function ON or OFF status.

Clicking indicator controls the function ON/OFF directly or opens the dialog box or window which 

controls the function status.
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Run Option

Save Data button 

appears if the last 

test result data is in 

the memory when 

both Auto Export and 

Auto Record are OFF, 

and allows you to save 

the last data as the 

test result record.

Multi data display OFF

Auto Export OFF and Auto Record OFF

Multi data display ON

Auto Export and Auto Record status:

or

or

Run Option button opens the Run Option dialog box used to change the status of the automatic data 

record function, the automatic data export function, and the multiple data display function. 

If the Record Test Result Data Automatically check box is checked, both or one of the automatic data 

record function and the automatic data export function will be set to ON.  To specify the function 

status, see the next page.

If the Record Test Result Data Automatically check box is not checked, both functions are set to 

OFF.  In this status, both data record and data export are not performed.  So the test execution time 

will be reduced.  Also, EasyEXPERT memorizes the last test result data.  And it can be saved as a 

test result record by clicking the Save Data button right next to the Run Option button.  This status 

will be useful for probe contact check, defect analysis, and so on.

The multiple data display function ON or OFF can be controlled by clicking the Multi Display 

indicator or by using the Allocate Data Display for each test check box on the Run Option dialog 

box.

About the multiple data display function:

If this function is OFF, the all test result data will be displayed on the singular Data Display window.

If this function is ON, the test result data of the same test setup name will be displayed on the 

exclusive Data Display window and the test result data of the different test setup name will be 

displayed on the new Data Display window.



Module 8

Miscellaneous Operations

8-5

Automatic Data Export and Data Record

The automatic data export function and the automatic data record function can be enabled or disabled 

by using the Test Results Data Auto Export dialog box.  This dialog box is displayed by clicking 

these indicators or selecting the Results > Transport Data > Auto Export Setting… menu.

The automatic data export function is used to export the test result data automatically to the storage 

device you specify.  You can specify the destination (storage device), exported file name, and file 

type.  To set the automatic data export function to enable (set to ON), check the Enable automatic 

data export to the specified storage device check box.

The automatic data record function is used to save the test result data to the internal HDD 

automatically.  This function can be disabled if the automatic data export function is enabled.  To 

disable the automatic data record function, remove the check from the Enable automatic data record 

to the internal storage device check box.

Even if both data export and data record functions are enabled, the functions can be set to OFF by 

removing the check from the Record Test Result Data Automatically check box on the Run Option 

dialog box.
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Module Self Calibration Calibration

The Calibration window is opened by clicking the Calibration button. The Module Self Calibration 

screen of this window is used to perform the calibration of SMUs.  The list area of this screen lists 

Name, Full Range, and Status.

Name: Name of module. To select, check the left check box.

Full Range: For the high resolution SMU (HRSMU) connected to the atto sense/switch unit (ASU). 

Full range calibration on or off.

Status: Calibration status. Pass or fail.

Notes: Error information when calibration failed.

To perform the self-calibration, specify the modules, open the measurement terminals of the 

corresponding modules, and click the Start Calibration button.

Full Range Calibration:

For the HRSMU connected to the ASU. Enables or disables the full range calibration. If this box has 

been unchecked, the B1500A does not use the 1 pA range.

Enable Auto Calibration:

Enables or disables the auto-calibration capability. If this box has been checked (function ON), and 

the B1500A/B1505A automatically starts calibration for all modules every 30 minutes if the output 

switches of all modules are off for 30 minutes.

NOTE:

To perform calibration correctly, open the measurement terminals.  If auto-calibration is enabled, do 

not forget to open the measurement terminals or disconnect the device under test from the terminals 

after measurement.
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SMU Zero Cancel

1

2

3

Calibration

The SMU Zero Cancel screen is used to perform the SMU zero offset current measurement and set 

the SMU zero offset cancel function.

This function subtracts the offset current from the current measurement raw data, and returns the 

result as the measurement data.  This function is used to compensate the error factor (offset current) 

caused by the measurement path such as the measurement cables, manipulators, or probe card.

To enable this function, perform the following procedure.

1.Check the left box of the Name column to specify the module to enable this function.

2.Click the Measure… button to perform the zero offset current measurement and wait until the 

measurement is completed.  The measurement data will be displayed in the appropriate cell.

3.Click the Close button to enable the zero offset cancel function.

To disable the function, uncheck the left box of the Name column, and click the Close button.

Note:

The offset cancel is not available for measurement over 100 nA range.  For 10 nA range 

measurement, the offset cancel is performed by using the 1 nA range offset value.  For measurement 

by a range less than 10 nA, the offset value measured by each range is used.

For more information, see online help or User’s Guide.
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CMU Calibration Calibration

The CMU Calibration screen is used to perform the measurement data correction of the multi 

frequency capacitance measurement unit (MFCMU).  For the easy way, perform the phase 

compensation and the open correction at least.  The check boxes left of the Open/Short/Load 

Correction and the Phase Compensation are effective after the corresponding measurement is 

performed.

Measure…: Opens a dialog box used to perform correction/compensation data measurement.  To 

perform the measurement, follow the dialog box.

Advanced Options…: Opens the “Advanced Options for CMU Calibration” dialog box used to set 

the frequencies for the correction data measurement and the reference values of the working 

standard.  See the next page.

To perform the open correction and the phase compensation, open the measurement terminals.

To perform the short correction, connect the measurement terminals together.

To perform the load correction, connect your load standard between the high terminal and the low 

terminal.

NOTE:

For a more accurate measurement, perform Open/Short/Load correction at the measurement 

frequency before starting the capacitance measurement.

If the measurement frequency is not included in the list of default frequencies below, click the 

Advanced Options... button and set the measurement frequency on the Frequency area of the 

Advanced Options for CMU Calibration window.

Default frequencies:

1 k, 2 k, 5 k, 10 k, 20 k, 50 k, 100 k, 200 k, 500 k, 1 M, 1.2 M, 1.5 M, 2 M, 2.5 M, 2.7 M, 3 M, 3.2 

M, 3.5 M, 3.7 M, 4 M, 4.2 M, 4.5 M, 5 MHz
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Advanced Options for CMU Calibration

This dialog box is opened by clicking the Advanced Options... button, and is used to set the 

information required to measure the open/short/load correction data and the phase compensation 

data. This dialog box provides the following action button.

OK: Applies the setup changes and closes this dialog box.

Cancel: Cancel the setup changes and closes this dialog box.

Frequency: You can select the measurement frequency setup mode from the following modes.

Measurement frequency setup modes:

Default (Use factory specified frequencies): Usually, select this mode. 23 points are automatically 

set. They are 1 k, 2 k, 5 k, 10 k, 20 k, 50 k, 100 k, 200 k, 500 k, 1 M, 1.2 M, 1.5 M, 2 M, 2.5 M, 2.7 

M, 3 M, 3.2 M, 3.5 M, 3.7 M, 4 M, 4.2 M, 4.5 M, and 5 MHz.

Specifies by list: Select this mode when you want to set the frequencies independently. The 

frequency must be 1 kHz to 5 MHz. The number of frequencies must be 1 to 101.  Click Add to open 

a dialog box, and enter the value.  For the unnecessary value, highlight the value and click Delete.

Specifies by range: Select this mode when you want to set the frequencies sequentially and 

automatically.  Specify the start frequency, the stop frequency, the number of steps, and the scale 

LINEAR/LOG. The start frequency must be less than the Stop value and at least 1 kHz. The stop 

frequency must be more than the Start value and no more than 5 MHz. The number of steps must be 

2 to 1001.

NOTE:

If the device measurement frequency is not equal to the correction data measurement frequency, 

calculation will be performed automatically to get the correction data for the device measurement 

frequency, and the calculated correction data will be used for the data correction of the measurement 

data.
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Advanced Options for CMU Calibration

Integration Time area defines the integration time used for measuring phase compensation data or 

open/short/load correction data.  The number of averaging samples (Mode=AUTO) or the averaging 

time (Mode=PLC) is set.

Mode: A/D converter operation mode, AUTO or PLC.

Factor: Factor for the initial value.  For details, see online help or user’s guide.
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Advanced Options for CMU Calibration

Reference Standard Values area provides the following entry fields used to set the reference values 

of the open/short/load standard.  If you use the standard, enter the reference values to the entry fields.

OPEN Reference: Capacitance and Conductance.  If you do not use the reference, enter 0 in the both 

fields.

SHORT Reference: Inductance and Resistance.  If you do not use the reference, enter 0 in the both 

fields.

LOAD Reference: Inductance and Resistance
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Main Frame
Configuration

The Configuration window is opened by clicking the Configuration button, and is used to display the 

system information and event log, as well as to perform diagnostics and self-test.

The Main Frame screen is used to display the system information and perform diagnostics.

Model Identification: Displays the instrument ID. B1500A or B1505A.

Line Frequency: Sets the power line frequency, 50 Hz or 60 Hz.

EasyEXPERT Rev.: Displays the revision number of the EasyEXPERT.

Firmware Rev.: Displays the revision number of the B1500A/B1505A firmware.

Host ID: Displays the host id of the B1500A/B1505A internal computer.

Main Frame Diagnosis: This area lists Item and Status.

Item: Name of diagnostics item. To select, check the left check box.

Status: Diagnostics status. Pass or fail.

To perform diagnostics, specify the items to perform and click the Start Diagnosis button.  A dialog 

box is opened.  Follow the dialog box to perform the diagnostics.  Some items need your judgement, 

pass or fail.  Also you will need to connect an adapter, press keys, check LEDs, and so on.

The Host ID is important for the B1540A-002 users and the B1541A-002 users.  It is necessary to 

activate the EasyEXPERT or Desktop EasyEXPERT Software Plus features.  For details, see the 

Software Entitlement Certificate.
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Modules
Configuration

The Modules screen is used to perform self-test of modules.

Slot: Slot number where the module is installed. To select, check the left check box.

Module Type: Module model number

Name: Module name

Status: Self-test status, Passed, Failed, Recovered, or ---- (self-test has not been performed)

SCUU: Specifies if the module is connected to the SCUU.

Notes: Error information when the module self-test failed.

To perform self-test, specify the modules, open the measurement terminals of the corresponding 

modules, and click the Start Self Test button.

Recover Module button is for the service use only.  This button makes the failed modules respond 

again.  This button does not solve the problem that causes the Failed status.

Status LED: Enables (ON) or disables (OFF) the status indicator (LED) of the ASU (Atto Sense and 

Switch Unit) and the SCUU (SMU CMU Unify Unit).
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ASU – B1500A
Configuration

The ASU screen is available if the B1500A installs the HRSMU connected to the ASU (Atto 

Sense/Switch Unit), and shows the ASU information.

Slot: Slot number

Module Type: Type of module

Name: Module name or SMU name

ASU Serial Number: Serial number of the ASU registered as a pair with the HRSMU. This cell 

displays an error message instead of the serial number if unpaired ASU is connected.

ASU I/O Path: ASU input to output connection, SMU or AUX

If the ASU I/O Path field is set to SMU, the ASU makes the path from the ASU Force input to the 

ASU output.

If the ASU I/O Path field is set to AUX, the ASU performs automatic switching in every test. The 

ASU makes the path from the AUX In input to the ASU output for the test without the HRSMU and 

makes the path from the ASU Force input to the ASU output for the test with the HRSMU.



Module 8

Miscellaneous Operations

8-15

Switching Matrix – B1500A
Configuration

The Switching Matrix screen is used to establish the GPIB connection with Agilent 

B2200A/B2201A/E5250A switching matrix and define the B2200A/B2201A/E5250A input port 

connections.

Switching Matrix Type: Displays the type of the switching matrix or No Switching Matrix.

GPIB Address: Specifies the GPIB address of the switching matrix. 1 to 30.

Poll: Confirms if the switching matrix of the specified GPIB address is connected to the B1500A.

Start Self Test: Starts the selftest of the switching matrix. 

SWM IN#: Switching matrix input ports. Enter the label used to specify the input port to the right 

entry field.  The port name and the connected module name can be the label.  The character : (colon) 

cannot be used.  Checking the Kelvin check box grays out the coupled even number port.  Checking 

the CMU check box grays out SWM IN10 for the E5250A or SWM IN14 for the B2200A/B2201A.  

The input ports IN11 to IN14 are not available for the E5250A.

Kelvin: Check this box if this port is used for the Kelvin connection.

CMU: To perform capacitance measurement through the switching matrix, check this check box and 

set CMU1:MF to the SWM IN9 for the E5250A or the SWM IN13 for the B2200A/B2201A.  And 

connect MFCMU to the Input 9 and 10 of the E5250A or the Input 13 and 14 of the 

B2200A/B2201A.  To perform capacitance compensation, see User’s Guide.

Extended Configuration: Opens the Extended Configuration dialog box.  See the next page.

Note: Standard revision of EasyEXPERT does not support the E5250.  The E5250 control is a feature 

of the B1540A-002/B1541A-002.

Note: The E5255A installed in the E5250A is not supported.
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Extended Configuration – B1500A

This dialog box is opened by clicking the Extended Configuration button in the Configuration 

window Switching Matrix screen.

Save as Hardware Profile is used to save the hardware profile that is the B2200A/B2201A/E5250A 

hardware configuration and the measurement module connection.  Click the Save button to save the 

present hardware profile.  The hardware profile can be made for each workspace individually.

CMU Compensation is used to select the compensation mode of the capacitance measurement using 

the B2200A/B2201A/E5250A.  Click one of the radio buttons, No Compensation, Select, and User 

Compensation Data File.  For the capacitance compensation, see User’s Guide.

• No Compensation:

Select this radio button if you do not need the capacitance compensation. The raw data without 

compensation is displayed and saved.

• Select:

Select this radio button to perform the capacitance compensation for the path from the 

B2200A/B2201A input ports to Agilent 16495F/G connector plate or Agilent B2220A probe card 

interface. The data after compensation is displayed and saved.

DUT I/F field is used to specify the model number of the path you use.  The selections are the 

16495F/G and B2220A.

Cable field is used to specify the model number of the cable from the B2200A/B2201A output to the 

DUT I/F.  The selections are the 16494A/B/C-001/002/005.  This mode cannot perform the 

capacitance compensation for the cables to positioner/manipulator or the probe card.

• User Compensation Data File:

Select this radio button to perform the capacitance compensation for the path from the 

B2200A/B2201A/E5250A input ports to the end of positioner/manipulator or probe card.  See User’s 

Guide.  The data after compensation is displayed and saved.

Note: Standard revision of EasyEXPERT does not support the E5250.  The E5250 control is a feature 

of the B1540A-002/B1541A-002.

Note: The E5255A installed in the E5250A is not supported.
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SMU/PG Selector – B1500A
Configuration

The SMU/PG Selector screen is used to specify the input connection and the channel connection 

status of the Agilent 16440A SMU/PG selector.

Enable SMU/PG Selector: Check this box to use the selector.

Selector CH1/CH2: Indicates the channels 1 and 2 of the first selector respectively.

Selector CH3/CH4: Indicates the channels 1 and 2 of the second selector respectively.

SMU Assignment: Specifies the SMU connected to the SMU input of the selector channel CH1, 

CH2, CH3, or CH4.

Input/Output Path: Specifies the connection status of the selector channel CH1, CH2, CH3, or CH4.  

Always SMU: Makes the selector channel “SMU on” state.

Normally PGU (AUX): Performs automatic switching in every test. The selector channel normally 

makes the “PGU on” state and makes the “SMU on” state only for the test which uses the SMU 

connected to the Input SMU terminal.

The CH1 and CH3 also provides the “PGU open” state which is set by using the Advanced window 

of the Measurement Setup.
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�Flash Memory Test

�Transistor photomos

SW1

SW2SW3

SW1

SW2

16440A Selector

To DUT

To DUT

Input SMU

Input SMU

Input PGU

Input PGU

SW1 &  SW2 : Mechanical Relay

SW3: Solid State Relay

Channel 1

Channel 2

SMU/PG Selector – B1500A

� Easy to switch between SMU and PGU

� Solid state relay

The selector has two channels as shown above.  Each channel has two ports (SMU and PGU).  

External pulse generators can also be connected.  The connectors are Triax for SMUs and outputs, 

and BNC for PGUs.

Up to two selectors (four channels) may be required for some reliability tests such as Flash 

EEPROM.

As a special design for Flash memory,  a solid state relay was added to float the drain.  This 

eliminates wear and tear of millions of closures that would occur with a mechanical relay.
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Module Selector – B1505A Configuration

The Module Selector screen is used to specify the input connection and the default input-output path 

of the module selector.

Enable Module Selector check box is used to enable/disable the module selector. If this box is 

checked, the module selector can be used.

Input: Specifies the modules connected to the module selector’s HVSMU, HCSMU, and HPSMU 

input ports respectively. For the port which no module is connected, blank the entry field. The Enable 

Series Resistor (100 kohm) for HVSMU check box must be checked if you want to insert the series 

resistor to the HVSMU path.

Output: The Default field is used to specify the module connected to the module selector output port 

in the idle state. When a measurement is performed, the module specified by the test setup is 

automatically connected.

Status: Shows one of the following status.

•Not Detected: Module selector has not been detected yet.

•Communication Established: Normal status. Module selector can be used.

•Communication Lost: Once the module selector was detected. However the communication has 

been broken now.

Auto Detection check box is used to enable/disable the module selector automatic detection. If this 

box is checked, the automatic detection of the module selector is performed when EasyEXPERT is 

launched.

Start Diagnosis button is used to start the module selector diagnosis. And the Status shows the 

diagnosis result.

Apply button applies the setting.
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Module Selector – B1505A

� Easy to switch the open condition, HPSMU, HCSMU, HVSMU, 

and HVSMU via 100 kohm

� Up to 20 A and 3000 V

B1505A +

N1258A Module  Selector or 

N1259A Test fixture with option 300 Module Selector
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0

0
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High

Low

Module selector is used to switch the measurement resource connected to the device under test 

(DUT) automatically. The measurement resource will be HPSMU, HVSMU, or HCSMU. One 

selector provides one switching channel.

The N1258A is used with a DUT interface such as your own test fixture and prober station.

The N1259A with option 300 is for the packaged device test.
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SMU Output Setting Limit

– B1505A

Configuration

The SMU Output Setting Limit screen is used to set the upper limit of the SMU output

value and compliance value.

Voltage Setting Limit: Sets the upper limit of the voltage output value and compliance value. 

Effective value: 200 V to 3000 V, in 100 V step.

Current Setting Limit: Sets the upper limit of the current output value and compliance value. 

Effective value: 1 A to 20 A, in 1 A step.

Apply button applies the setting.
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Event Log
Configuration

The Event Log screen displays the event log.

Date/Time: Displays date and time of the event.

Message: Event message

ID: Process ID of the event

Process: Process name

User: User name. Windows login name.

Host: Host name of the B1500A/B1505A

The Refresh button refreshes the event log.
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XSLT Filters

Highlight this line

Click this button

The XSLT (XSL-Transformation, eXtensible Stylesheet Language Transformation) filter files are 

used to export test records. The fifteen filter files listed below are stored in the 

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT¥Utilities¥XSLT folder.

The following filter files are used for exporting the measurement data only.

meas-csv.xsl, meas-tab-sv.xsl, meas-xmlss.xsl

The following filter files are used for exporting the measurement data with the index.

meas-index-csv.xsl, meas-index-tab-sv.xsl, meas-index-xmlss.xsl

The following filter files are used for exporting the measurement data with the meta data.

meas-meta-csv.xsl, meas-meta-tab-sv.xsl, meas-meta-xmlss.xsl

The following filter files are used for exporting the measurement data with the index and the meta 

data.

meas-index-meta-csv.xsl, meas-index-meta-tab-sv.xsl, meas-index-meta-xmlss.xsl

The following filter files are used for exporting all data including the test setup.

csv.xsl, tab-sv.xsl, xmlss.xs

Where, the meta data contains the test name, the setup name, the record time of the test results, the 

device ID, the counter number, the flag of the test results, and the remarks on the test results. 

Filter files that contain xmlss in the file name export test record in the XML Spread Sheet format.

Filter files that contain csv or tab-sv in the file name use a comma or a tab for the data separator.

For more information, see online help or User’s Guide.
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To Enable System Controller

Agilent IO Library Connection Expert

To control external GPIB devices, the B1500A/B1505A must be set to system controller.  Exit the 

EasyEXPERT, and close the Start EasyEXPERT window.  After that, launch the Agilent Connection Expert by 

clicking Start, All Programs, Agilent IO Library Suite, and Agilent connection Expert.

On the Agilent Connection Expert, change the GPIB configuration of the B1500A/B1505A.

•Select GPIB0.

•Click Change Properties… button.

•Change GPIB address to 21 that is the typical address number for the system controller.

•Check System controller box.

•Click OK button.

•Reboot the B1500A/B1505A.
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To Start Desktop EasyEXPERT

Database Backup Creation Wizard

Database Restoration Wizard

¥Documents and Settings¥All Users¥Application Data¥Agilent¥EasyEXPERT¥Service¥OfflineConfiguration¥UnitConfigB1500A.xml

¥Documents and Settings¥All Users¥Application Data¥Agilent¥EasyEXPERT¥Service¥OfflineConfiguration¥UnitConfigB1505A.xml

Important:

To set the same configuration as the B1500, 

copy the following file from B1500 to your PC. 

The location must be the same.

To open the Start EasyEXPERT window, click Start > Programs > Start EasyEXPERT menu.  This 

window provides the Option menu used to open the following dialog box.

Gpib Communication:

Select Online if the B1500A, B1505A, 4155B/C, or 4156B/C is connected to your computer and you 

want to control it via GPIB.  Or else select Offline.

Database Backup Creation Wizard:

Use this wizard to create the EasyEXPERT database backup (xdb file).

Database Restoration Wizard:

Use this wizard to restore the EasyEXPERT database backup.  The wizard can restore the xdb file or 

the backup which is a copy of the folder that contains the EasyEXPERT database.

EasyEXPERT Database:

Specify the EasyEXPERT Database path if you want to move the database to the other folder.

To launch Desktop EasyEXPERT, click the Start EasyEXPERT button.

Note:  Desktop EasyEXPERT supports most of the EasyEXPERT functions.  However, some 

functions are not supported on an external computers due to differences in hardware and so on.

Note:  For the installation procedure, see the readme file stored in the Desktop EasyEXPERT CD-

ROM.

Note:  For the offline mode.  To use the same module configuration as the B1500A/B1505A, copy 

the UnitConfigB1500A.xml/UnitConfigB1505A.xml file to your PC which the Desktop 

EasyEXPERT runs.  The file is stored in the B1500A/B1505A hard disk drive.  The location is 

shown in the slide.  The file must be copied to the same location in your PC.
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To Use 415x Setup File Converter

4155/4156 setup file

(file extension: MES or DAT)

EasyEXPERT setup file

(file extension: XTS)

Execution example:

C:¥Mydata>SetupFileConverter.exe setup1.dat

C:¥Mydata>SetupFileConverter.exe *.mes

SetupFileConverter.exe

Import

You can reuse the 4155/4156 setup file (MES file or DAT file) for the test using EasyEXPERT.  This 

is realized by Setup File Converter which has the function to create the XTS file by converting the 

MES or DAT file to the EasyEXPERT format.  This executable file is stored in the following folder.

C:¥Program Files¥Agilent¥B1500¥EasyEXPERT¥Utilities

You can execute the setup file converter on the Command Prompt as shown below.  If you want to 

use the Windows desktop instead of the Command Prompt, see the next page.

1. Create your working folder (for example, C:¥415xdata).

2. Copy your MES or DAT files to this folder.

3. Copy SetupFileConverter.exe file to this folder.

4. Launch the Command Prompt.

5. Go to your working folder (for example, C:¥> cd 415xdata).

6. Execute SetupFileConverter.exe as shown in the following example.

C:¥415xdata> SetupFileConverter.exe *.MES

This example converts all MES files in your working folder to the EasyEXPERT setup file format, 

and creates the XTS files in this folder.

Note:  If you execute the setup file converter without the parameter, the help message will be 

displayed.

Note:  The setup file converter provides some options.  See User’s Guide or online help for the 

options.
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To Use 415x Setup File Converter

1. Drag and drop the shortcuts of the MES/DAT file on 

the shortcut of the Setup File Converter.

2. File conversion is executed and system message is displayed.

3. XTS file and shortcut are created.

You can perform the file conversion on the Windows desktop as follows.

1. Create a shortcut of the SetupFileConverter.exe on the desktop.

2. Copy your MES/DAT files to the desktop.

3. Drag and drop the shortcuts of the MES/DAT files on the shortcut of SetupFileConverter.

This starts the file conversion and displays the system message. And if the conversion is completed 

successfully, the setup file converter creates the XTS files and the shortcuts on the desktop.

Note:  The setup file converter provides some options.  See User’s Guide or online help for the 

options.
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To Use 415x Setup File Converter
Click [Start] → All Programs → Agilent B1500A EasyEXPERT

→ 4155,4156 Setup File Converter

To create XTS file:

The following procedure converts the 4155/4156 setup file (.DAT or .MES) and creates the .XTS file 

in the folder the setup file is stored.

1. Click Select icon, or click File > Select Files to open the Select 4155/4156 MES Files or DAT 

Files dialog box.

2. Specify the 4155/4156 setup files to convert. Multiple files can be selected.

3. Click Open on the Select 4155/4156 MES Files or DAT Files dialog box.

4. Click Convert icon, or click File > Convert Files.

To read XTS file, use the import function to read the created .XTS file on the EasyEXPERT.
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